Resolved Mac Pro 2,1 running El Capitan is unable to boot into Apple Hardware Test

Discussion in 'Mac Pro' started by dood_son, Mar 9, 2017.

  1. dood_son macrumors newbie

    dood_son

    Joined:
    Mar 9, 2017
    #1
    Guys, I have a problem with running the Apple Hardware Test.

    I am currently running a Mac Pro 2,1 (Mac Pro 1,1 with an upgraded firmware) with a passive-cooled ATI Radeon 5750 that was ROM-tweaked to appear as a 5770. Bootscreen is available. The machine is sweet. Many off these mods were accomplished thanks to the incredible community of MacRumors forum.

    Unfortunately, I started experiencing some problems with the computer's inability to RESTART
    . It sleeps fine, starts up and shuts down just fine too. When I tell it to "restart" all I get is a black screen and the PSU won't switch-off. Looks like it cannot complete the command. I looked inside the case and always when that happens I get two diagnostic LEDs flashing: the CPU-A and CPU-B. Rare flashes. Computer unresponsive. Then I just kill it by holding the on/off switch until the shutdown. These LEDs never go on when the computer is being used. Just at an attempt to restart.

    I know that there may probably be maaaany problems causing this situation. So I thought that the right way to start looking for the problem was to run the Apple Hardware Test. And this is were my actual problem starts: no matter what I do I cannot get the Mac Pro to boot off the Apple Hardware Test drive (be it a USB stick or even an internal SATA drive). I also have a MacBook Pro 5,2 (A1297 2,66 GHz 17”) that I managed to boot using a USB flash drive with a corresponding Apple Hardware Test on it with no problems! I tried my luck with it just to make sure that I am not making a mistake in the procedure of preparing the AHT bootable volume.

    When I have my internal drive or USB stick containing a bootable volume of an AHT connected to the Mac Pro and switch it on (as I cannot RESTART) with the “D” button pressed, I only get an icon of a folder with a question mark and after a second the computer boots into El Capitan. Same happens if I hold down the "option" key and navigate to the internal drive / USB flash containing the Apple Hardware Test - the computer immediately boots into El Capitan. Do you have an idea why I cannot get it to boot into the Apple Hardware Test? Is there some problem resulting from the "non-standard" configuration of this Mac Pro?

    NOTE:

    While choosing the correct version of AHT for my machine (using this guide: https://github.com/upekkha/AppleHardwareTest) I also discovered that my Terminal read-outs for the “model” and “board-id” are not matching, as they are respectively: “MacPro2,1” (as expected) and “Mac-F42C88C8” (witch matches Mac Pro 3,1). Being unsure which Apple Hardware Test disk image to use because of this ambiguity, I’ve tried 3 different ones (018-2769-A.dmg for 1,1; 018-2667-A.dmg for 2,1 and 018-3273-A.dmg for 3,1). All to no avail.


    Please help!
     

    Attached Files:

  2. dood_son thread starter macrumors newbie

    dood_son

    Joined:
    Mar 9, 2017
  3. thierrybeginl macrumors newbie

    Joined:
    May 2, 2017
    #3
    I have the same problem...

    I just installed El Capitan with pikify v14 and boot64. That's all I know... no USB, no wifi and no "D" key starting Hardware Test.

    How did you solve it!?

    Thank you
     
  4. 6apxat macrumors newbie

    Joined:
    Jan 10, 2014
    Location:
    Moscow, Russia
    #4
    Hey, I have the exact same hardware problem with my MP (plus quite frequent sudden crashes).
    Have you solved your restart problem?
    And please tell us how you managed to run the AHT.
     

Share This Page