Mac Pro 2010 - El Capitan (Colour Depth and Mini Display Port Problems)

Discussion in 'Mac Pro' started by zterm, Mar 1, 2018.

  1. zterm macrumors newbie

    Joined:
    Mar 1, 2018
    #1
    Hello all,

    My system is composed of a mid-2010 MacPro with 32GB of RAM + ATI Radeon 5770 + DELL 2713H monitor connected through one of the Mini Display Port outputs.

    I have been using this system without a problem for more than 4 years, with different internal SSDs for OSX 10.6.8, 10.8.5 and 10.11.6.

    Although I had been using only El Capitan for some time, a few days ago I noticed some banding in the gradients.
    The native resolution of the monitor is 2560 x 1440 and I have never had this problem before, so I thought that the color depth would have been changed in the control panel. To my surprise, when I opened the control panel I noticed that in El Capitan there is no option to change the color depth.

    To see if it was a problem of El Capitan, I tried to boot from Mountain Lion and Snow Leopard, but while the system starts and works (I verified from another computer through shared screen), the screen remains black. Then, I tried connecting the monitor through DVI, verifying that the screen works, but when returning to the Display Port, the screen remains black.


    Through DVI, 2560 x 1440 can not be obtained but the color depth is correct.

    This system and this monitor have always been connected through Mini Display Port working without problems at maximum resolution and depth of color with any OS. Now, the Display Port outputs only work with El Capitan and only at a reduced color depth, I guess 15 bit. I even ordered a new DP cable, but problem persists.


    What could be the problem?

    Any suggestions or help will be appreciated.


    Thanks,

    CR
     
  2. ActionableMango macrumors G3

    ActionableMango

    Joined:
    Sep 21, 2010
    #2
    These wildly different symptoms don't make any sense to me. Is this a genuine Apple 5770 or a flashed PC card?

    I don't really understand what the problem is, but you might be able to work around it with a "dual-link" DVI cable. Those are capable of 2560x1440. If you are already using a dual-link cable, then it's another problem.

    You've already tried a fresh OS install.

    Maybe try resetting the monitor to its default settings.
     
  3. zterm thread starter macrumors newbie

    Joined:
    Mar 1, 2018
    #3

    Thanks for replying.

    It's a genuine card, the one that came with the MacPro.

    Yesterday, after reading an old post, I realized where the problem was. I remembered that my monitor was briefly used with a Windows workstation and apparently someone set the DisplayPort input to v1.2.

    I thought that I had already set it back to v1.1 but I re-checked it and noticed that it remained in v.1.2.

    When doing it again, I noticed that when selecting the option, there is a second confirmation that I surely ignored.

    Setting it back to v.1.1 solved the problem.

    Again, thanks.
    zterm
     
  4. Milos Lazic macrumors newbie

    Milos Lazic

    Joined:
    Mar 16, 2018

Share This Page

3 March 1, 2018