Mac Pro 5.1 continually restarting

Discussion in 'Mac Pro' started by gatd, Jan 13, 2018.

  1. gatd, Jan 13, 2018
    Last edited: Jan 14, 2018

    gatd macrumors regular

    Joined:
    Jun 2, 2008
    #1
    Hi my mac pro has gone nuts continually restarting!! any help would be greatly appreciated. thanks in advance for any help
    here is the last crash report

    Anonymous UUID: 6580A15B-E059-F28D-062A-97ABE0E32B62



    Sat Jan 13 15:53:50 2018



    *** Panic Report ***

    panic(cpu 10 caller 0xffffff800774cd6f): "TLB invalidation IPI timeout, unresponsive CPU bitmap: 0x1, NMIPI acks: 0x0, now: 0x0, deadline: 7706030116025"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/xnu/xnu-4570.31.3/osfmk/x86_64/pmap.c:2797

    Backtrace (CPU 10), Frame : Return Address

    0xffffff82cded30e0 : 0xffffff80076505f6

    0xffffff82cded3130 : 0xffffff800777d604

    0xffffff82cded3170 : 0xffffff800776f0f9

    0xffffff82cded31f0 : 0xffffff8007602120

    0xffffff82cded3210 : 0xffffff800765002c

    0xffffff82cded3340 : 0xffffff800764fdac

    0xffffff82cded33a0 : 0xffffff800777acc8

    0xffffff82cded33f0 : 0xffffff800765015a

    0xffffff82cded3440 : 0xffffff800777d604

    0xffffff82cded3480 : 0xffffff800776f0f9

    0xffffff82cded3500 : 0xffffff8007602120

    0xffffff82cded3520 : 0xffffff800765002c

    0xffffff82cded3650 : 0xffffff800764fdac

    0xffffff82cded36b0 : 0xffffff800774cd6f

    0xffffff82cded3750 : 0xffffff8007753ab4

    0xffffff82cded3830 : 0xffffff8007754a84

    0xffffff82cded3890 : 0xffffff80076dcb0f

    0xffffff82cded39c0 : 0xffffff80076dc3f2

    0xffffff82cded3a00 : 0xffffff80076d8383

    0xffffff82cded3a30 : 0xffffff8007c29f80

    0xffffff82cded3a50 : 0xffffff7f892cc8b0

    0xffffff82cded3ac0 : 0xffffff7f892cb500

    0xffffff82cded3b20 : 0xffffff8007cb9038

    0xffffff82cded3b70 : 0xffffff8007cc1e47

    0xffffff82cded3cb0 : 0xffffff8007729844

    0xffffff82cded3dc0 : 0xffffff8007655c30

    0xffffff82cded3e10 : 0xffffff8007632cbd

    0xffffff82cded3e60 : 0xffffff8007645b7b

    0xffffff82cded3ef0 : 0xffffff800775952d

    0xffffff82cded3fa0 : 0xffffff8007602926

    Kernel Extensions in backtrace:

    com.apple.iokit.IOSurface(209.2.2)[AE58720D-7079-388F-AD95-FD2366F98F8D]@0xffffff7f892c2000->0xffffff7f892dbfff



    BSD process name corresponding to current thread: WindowServer



    Mac OS version:

    17C88



    Kernel version:

    Darwin Kernel Version 17.3.0: Thu Nov 9 18:09:22 PST 2017; root:xnu-4570.31.3~1/RELEASE_X86_64

    Kernel UUID: 87641697-A3DD-30C4-B010-E65ECE57550B

    Kernel slide: 0x0000000007200000

    Kernel text base: 0xffffff8007400000

    __HIB text base: 0xffffff8007300000

    System model name: MacPro5,1 (Mac-F221BEC8)



    System uptime in nanoseconds: 7707531777663

    last loaded kext at 6455729976274: com.apple.driver.AppleBluetoothMultitouch 92 (addr 0xffffff7f8a98d000, size 57344)

    last unloaded kext at 5944680245964: com.apple.driver.AppleInputDeviceSupport 1201.8 (addr 0xffffff7f8a935000, size 90112)

    loaded kexts:

    com.nvidia.CUDA 1.1.0

    at.obdev.nke.LittleSnitch 5094

    com.apple.driver.AppleBluetoothMultitouch 92
     
  2. h9826790, Jan 13, 2018
    Last edited: Jan 13, 2018

    h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    Do you have a newly installed BT card / device?
     
  3. gatd, Jan 14, 2018
    Last edited: Jan 14, 2018

    gatd thread starter macrumors regular

    Joined:
    Jun 2, 2008
    #3
    no but now on checking system information/ ethernet cards its saying you don't seem to have any network cards installed and now to internet!
    problem was also mac would drop internet after an hour or so, tried smc pram reinstall etc
    do you think the logic board is failling or is it cpu related?
     
  4. frou macrumors 6502

    frou

    Joined:
    Mar 14, 2009
    #4
    Maybe the retainers on the Northbridge heatsink have popped
     
  5. gatd thread starter macrumors regular

    Joined:
    Jun 2, 2008
    #5
    just checked the northbridge and no it has not popped seems ok
    the wifi will connect on restart but then cuts after a few minuets and then won't reconnect at all and the computer restarts by its self, still showing no ethernet cards installed on system profiler really need help to find the problem
     
  6. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
  7. gatd thread starter macrumors regular

    Joined:
    Jun 2, 2008
    #7
    yes i have reinstalled the os clean drive with nothing else expect stock install
     
  8. devon807 macrumors 6502

    devon807

    Joined:
    Dec 31, 2014
    Location:
    Virginia
    #8
    Odd. Have you made any changes recently? What graphics card do you have?
     
  9. gatd thread starter macrumors regular

    Joined:
    Jun 2, 2008
    #9
    no changes stock apple card just this internet problem
     
  10. devon807 macrumors 6502

    devon807

    Joined:
    Dec 31, 2014
    Location:
    Virginia
    #10
    Try removing your Wi-Fi card and see if the issue persists.
     
  11. gatd thread starter macrumors regular

    Joined:
    Jun 2, 2008
  12. devon807 macrumors 6502

    devon807

    Joined:
    Dec 31, 2014
    Location:
    Virginia
  13. thewoj, Jan 14, 2018
    Last edited: Jan 14, 2018

    thewoj macrumors newbie

    Joined:
    Jan 8, 2018
    #13
    Wow, I am actually having the exact same problem currently. I just installed dual X5690s and they had been working fine since early December. A couple weeks ago I let them run at full load for several days and now my MacPro does the same thing.

    Basically, what I have found is that if I throttle the booster, intake, and exhaust fans up a little bit then it doesn't restart anymore at idle. Currently, I am running 1000 RPM for intake/exhaust and 1500 RPM for boosters. Similarly, if I run them at full blast while processing I can run all 24 cores full speed without restart. PCI and PS fans don't seem to matter to this issue.

    I, too, have found that WIFI will sometimes go out just before the system restarts, not sure what this has to do with the issue.

    I have recently repasted and bolted down my Northbridge, but that did not seem to fix it either. The only thing that has worked has been getting more air flow across the CPU board.

    I have tried:
    • Reverting to stock graphics card (currently using GTX980 Classified)
    • Moving the processor tray to another MacPro
    • Swapping the processors to a different processor tray
    • Removing RAM
    • Plugging MacPro directly into the wall rather than through power strip
    • Blowing dust out of heatsinks
    • Repasting/bolting Northbridge heatsink
    • Adjusting fan speeds
    • SMC reset
    • PRAM reset
    • Replaced X5690's with a new used pair of X5690's
    The only other permanent solution I have found is reverting back to stock processors (2.26 or 2.66 quad in the case of my 2 systems).

    I was just reading about throttling fans with SMC Fan Control in a X5690 thread, but it did not seem like it was necessary for system stability for those in the thread—just as a precautionary measure.

    Also, I have had a variety of errors show up after restarts, including the one in the OP as well as:
    • Panic(CPU 22): NMIPI for spinlock acquisition timeout, spinlock: 0xffffff8088072538, spinlock owner: 0xffffff8088f91288, current_thread: 0xffffff8088f91288, spinlock_owner_cpu: 0x16
    • panic(cpu 20 caller 0xffffff801d3dd5ed): "TLB invalidation IPI timeout: " "CPU(s) failed to respond to interrupts, unresponsive CPU bitmap: 0x400, NMIPI acks: orig: 0x0, now: 0x0"@/Library/Caches/com.apple.xbs/Sources/xnu/xnu-3789.72.11/osfmk/x86_64/pmap.c:2724
    • Panic(CPU 10): Unresponsive processor (this CPU did not acknowledge interrupts) TLB state:0x0
    • And, previously I was getting a panic for the IntelCPUPowerManagement kext, or something similar
    At this point I am between 2 possible solutions, either trying X5675 processors as this tray was actually intended for something similar, or just making a generous fan control scheme in SMC fan control. I do not like the latter solution as the system could still be unstable given a slight shift in temperatures.
     
  14. gatd thread starter macrumors regular

    Joined:
    Jun 2, 2008
    #14
    is the problem going to be on the backplane or cpu board I have no Idea seems strange that system info shows no ethernet hardware installed
     
  15. thewoj macrumors newbie

    Joined:
    Jan 8, 2018
    #15
    Can you confirm your system specs? Have you changed any hardware recently?

    Pardon my excitement, I have been working on this for several weeks now and I have not found another post from someone with similar sounding issues.
     
  16. gatd, Jan 14, 2018
    Last edited: Jan 14, 2018

    gatd thread starter macrumors regular

    Joined:
    Jun 2, 2008
    #16
    --- Post Merged, Jan 14, 2018 ---
    Specs are Mac Pro 5.1 2X 3.46 6cores(upgraded) was all working fine until sometime in December as well.no recent changes to hardware
    Another thing I can’t run diagnostics I downloaded the correct file and put in system core services but on starting and hold down d just won’t load the same dive put in my working 4.1 upgraded to 5.1 same processors loads the diagnostics fine as they are different machines I can’t swap parts only the memory but that made no difference.
     
  17. thewoj macrumors newbie

    Joined:
    Jan 8, 2018
    #17
    I have not tried running diagnostics yet, I have a feeling it will probably fail from overheating in short order, that seems to be the case when I do not have the fans running overtime.

    I have 2x MacPro 4,1 with 5,1 firmware. My primary computer is spec'ed the following:

    • MacPro 4,1 => 5,1 firmware
    • 2x X5690
    • 56gb 1333
    • GTX980
    • USB 3.0 Card
    • OS 10.12.6
    • SSD in optical bay
    • 4x spindle drives
    Have you tried a fan controller in OSX to see if you can stabilize the system? From what I have seen, it's when the Northbridge reaches a little over 150°F that the computer restarts. This is much lower than the threshhold for the Northbridge as stated by others, as well as the computer has restarted at lower reported temperatures of the Northbridge. As such, I am wondering if perhaps it's another component that doesn't have a temperature sender?
    --- Post Merged, Jan 14, 2018 ---
    I am tempted to install High Sierra and see if that changes anything—I doubt it would hurt at this point.
     
  18. gatd thread starter macrumors regular

    Joined:
    Jun 2, 2008
  19. gatd thread starter macrumors regular

    Joined:
    Jun 2, 2008
  20. thewoj macrumors newbie

    Joined:
    Jan 8, 2018
    #20
    I installed my 2nd proc tray with dual 2.26's, it is running completely stable during hard render. I am noting Northbridge temperatures of a touch over 170*F and proc temp's in the 160's.

    In the meantime I was re-reading through threads since I figured others must be having this problem.

    https://forums.macrumors.com/threads/2012-12-core-constantly-shutting-down.2036342/

    I had previously thrown this thread to the wayside as I was not having sleep issues, re-reading a little better there are at least 5 people in the thread encountering shut down issues under stress testing. The OP replaced essentially every part of his computer, and then sent it to an Apple vendor who was confident they could fix it. They ended up replacing the power supply and that fixed the issue. I was always kind of wary of the power supply in this case, I still think it's odd that the computer does not shut down when fans are running full blast but perhaps temperature on the CPU board is causing a larger draw from the processor/northbridge that leads to shut down?
     
  21. gatd thread starter macrumors regular

    Joined:
    Jun 2, 2008
    #21
    Can you try and run apple hardware diagnostics it’s available on github with instructions for usb stick and tell me what you get?
     
  22. thewoj macrumors newbie

    Joined:
    Jan 8, 2018
    #22
    Yeah, I can try that when I get home.

    I have a feeling (given past experience), that as soon as the processors warm up it will hard reset.

    Have you tried adjusting your fan speed in OSX to see if keeping temperatures down increases stability?
     
  23. gatd, Jan 16, 2018
    Last edited: Jan 16, 2018

    gatd thread starter macrumors regular

    Joined:
    Jun 2, 2008
    #23
    no but finally managed to run AHT and all was OK !! but its not ,also weird my sata bus thats connected to the HD drive bays is now extremely slow at loading the system drive 5 mins for an SSD drive if it makes it to desktop and still no ethernet hardware showing up
     
  24. gatd thread starter macrumors regular

    Joined:
    Jun 2, 2008
    #24
    update I have now swapped the processor trays between my 4.1 upgraded to 5.1 and my 5.1 ignoring the high fans speeds (which initial led me to shut down and not try as I thought they would be incomparable) the conclusion is the the processor tray and processors are working fine so that just leaves the backplane or power supply causing my problems.
    I am now going to remove the power supply from my 4.1 and put it in my 5.1 to test.Will post back the results as soon as done.
     
  25. bsbeamer macrumors 65816

    Joined:
    Sep 19, 2012
    #25
    What OS and build are you using?
    Are the 4,1 > 5,1 (and 3,1 > 5,1) workarounds common in these machines?

    There appears to be sudden problems with several hacked/updated/upgraded machines after the latest security updates. Wondering if the patch for Spectre & Meltdown (https://support.apple.com/en-us/HT208394) has anything to do with this. Technically, the patches were written to be machine specific with some model ID's even getting their own custom build to address (such as the iMac).

    Genuine MacPro 5,1 with all updates for 10.13.2 is at build 17C205.
     

Share This Page