MAC pro drive classification question

Discussion in 'Mac Pro' started by septicdeath, Feb 6, 2009.

  1. septicdeath macrumors member

    Joined:
    Dec 31, 2007
    #1
    I have a Areca 8port Raid card in my mac. The 4 internal drive's have had the minisas/ipass cable disconnected from the motherboard and routed to the first minisas connector on the Raid card. I also have 4 Drives in the 2 optical drive bays, these are connected via a minisas4i to sata 4 cable fan out.

    This creates my raid array, I then bought another ipass/minisas cable to 4 sata fan out and connected it to the port on the motherboard, and routed all 4 sata connections to a pci back plane with 4 esata ports on the other side. I would have expected any esata drives enclosures I connect to these ports to be labeled "internal" drives. (trying to get a boot camp going). They are connected to the motherboard ports afterall. My external enclosure happens to actually be a dual drive unit with a steelvine 57xx series cheapy sata port replicator, I've connected the unit up with the intent to install bootcamp, but the drive comes up after init as a "external" disk, is this the steelvine causing this? I really expected to see any disks connected to any of the 4 ports to be internal 0/1/2/3, how should it know its not on the internal sleds?

    Anyways, when I try to run the bc assistant it says you must boot from an internal disk, so I read into this that even though I think I have a disk connected to the internal connector, that since I boot from the raid array that I am going to have to install a version of OSX onto the "external" internal disk and boot from it before it will allow me to run the boot camp utility. I have reft on the system, should I just attempt to boot the windows media and go straight to the external internal drive? Hope that makes sense, anyways, I guess I'll boot from the DVD and look at the disk already labeled 'external" although like I said, I know its connected to a sata cable right off the inernal ipass/minisas, why its claiming its external I have no idea, does a esata pass through have some signature or something?


    Any help would be appreciated , thanks in advance,

    In hindsite, I should have just bought a raid card with all 8 ports passed to external sas connectors and kept the internal motherboard connected to the internal sleds and just built a 8 disk external raid array, but a 1600 dollars later its a little late. At least this way, all my raid is always with the box, and the bootcamp is the external disk which I will rarely use and not as critical.


    John
     
  2. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #2
    The enclosure is the problem.

    The Silicon Image chip (SIL 4723) can be configured as either internal or external. I found a copy of the User's Guide online, and it looks like you can access this feature. (Looking at the processor w/ green arrow icon).

    Hopefully this is the case, and it will be an easy fix. :D
    Good luck. :)
     
  3. septicdeath thread starter macrumors member

    Joined:
    Dec 31, 2007
    #3
    I couldnt find this in the instructions, but I paid a little more attention to the information that is presented when clicking on the device in disk utility and choosing info, even though after it format's it calls it a external disk and uses the external disk icon, the information clearly shows that its location is "internal" and on port #4. When I boot my OS, I am booting from the raid controller, I guess there is nothing I can do to install bootcamp to even an internal drive while booted from the raid5 on the raid. I guess I will need to install a "as small as possible" install of OSX onto the drive, boot that OSX and then run the Bootcamp utility. I'm thinking that this will work. I can tell you, compared to my areca raid card, this little 2 drive enclosures "fast" and safe modes are SLOW. I really think I'm going to send the unit back and just get a single external enclosure that has a simple psu, and a external esata that connects to a internal sata and connect one of my 300 or 750 gig hard drives. Its only bootcamp for playing games, I dont need to have a mirror for that, all my real data is on my raid 5.

    Thanks for the help.

    If anyone can assit with how to get the bootcamp partition app to install onto a drive on the internal bus "while" booted from a pcie raid card. Please chime in.



    John
     
  4. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #4
    Can you dedicate a drive to Windows?

    If so, you just install to that. No boot camp required. BIOS emulation is present in the EFI firmware, and is all you need in this case. There's no sharing a drive, so you don't have to partition. You just choose which OS you want to load on startup.

    Might simplify things, and keeping both OS's separate might help avoid "cross issues" like a failed OS drive taking both out.
     
  5. septicdeath thread starter macrumors member

    Joined:
    Dec 31, 2007
    #5
    Yeah, I've got the entire original MAC Pro sata bus re-routed to external esata ports. So it was going to get its whole own drive (I dont want it on the raid5 array). I just thought I would need to run the bootcamp assistant to start it off.

    Are you saying I can just format a whole drive as Masterboot record, say fat, and reboot with the windows media in dvd-drive and it will boot and allow me to install? I thought I needed to "prep" something by using the bcassistant.

    I have heard that refit which I am using will make it easier to boot the diffrent OS, at one point I used it to be able to boot linux, but that was long before all the raid cards and stuff, that was back last month when it was a single 320 on a sled in slot 1.


    I guess I can try, just havent tried it yet.
     
  6. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #6
    If you put Windows on it's own drive, just drop in the DVD, and begin. It will ask you to format, and you choose the format you wish. No bcassistant required. Separate drives for OS X and other OS's really does simplify matters. ;)

    You don't even need rEFiT, though it might be nice. It will work if you want to use it.
     
  7. septicdeath thread starter macrumors member

    Joined:
    Dec 31, 2007
    #7
    very strange

    I'm not sure where the hangup is happening, I guess it might be the esata controller located on just about every external enclosure out there. I'm hoping someone with a raid card has done this.

    I've spent about as much money as I can on various attempts to get this to work.

    First, so everyone knows what I have going on.

    I have a 8 port Areca Raid card, I have disconnected the cable that feeds the 4 internal mac pro drive bays from the mac pro's motherboard and re-routed it to the first minisas port on the areca raid card. This makes the 4 sata sleds inside the macpro connected to the areca raid card.

    I then bought a prosled 2 from trans intl. and mounted 2 more sata hard drives into the 2nd optical drive bay. I connected these 2 drives to the arcea raid cards second minisas connector via a mini-sas to 4 sata pigtail cable. So I have 2 more sata connectors left off the pig tail.

    I then purchased 2 diffrent pci back plane plates, 1 plate has 4 sata connectors on the inside and 4 esata ports on the outside, and I also purchased another pci back plane that has 4 internal sata connectors and 4 external sata connectors.

    I purchased a ipass mini-sas cable to 4 sata cable pigtail which I then plugged into the mac pro onboard ipass port.

    So I now have reconnected the mac pro's internal sata connector to a cable that has 4 sata pigtails on the other end. I have fed 2 of these connectors to the first two ports of the first pci bracket which feeds port 1 and 2 to 2 external esata ports. I also took the 3/4 connectors and fed them to the 2nd pci bracket feeding external "sata" ports.

    so I have the internal motherboard sata ports 1/2 feeding 2 external esata devices, and motheboard sata pors 3/4 feeding 2 external sata connectors.

    I cant get the windows install dvd OR OSX to recognize anything connected to the esata ports. even though they are just pass throughs to esata.

    I have taken a old computer Power supply with sata power connectors and powered up 2 300 gig sata drives and used regular sata cables to connect both drives to the 2nd brackets external sata connectors and the windows install media and os x can see and initialize both of the drives.

    I happen to have a internal sata L cable to external sata I connector cable, and when I connect one of the esata enclosures to the L sata connector that just was able to see the sata drive and the windows or OSX cant see the drives again.

    I'm not sure if I have everyone confused yet or not, maybe I should draw a picture, but its like all of the external esata enclosures that I have tried (both cheap (sabrent) and expensive (nexstar3)) seem to confuse the mac pro's internal sata bus, if I extend the motherboard connectors to connect directly to sata drives, they can see the drives, but if I use adaptors (in this case they are pci slot pass through brackets) to connect the motherboards sata ports to drives with a esata adaptor between the motherboards sata connector and the sata connector of a drive and nothing can see them

    Before I continue, can someone confirm they are following what I am saying, because if thats not making sense, Im not going to get any help. So let me stop there and wait for repsponses, maybe I should draw up some small graphics that show what I am saying before I continue, but this is crap.

    Right now, the onlyway I can use the mac pro's internal sata connector is to extend the ports via direct connected sata hard drives, so the disks are laying on the top of the macpro connected with long sata cables and getting power from a extra psu, they wont see drives inside nice external enclosures and esata ports.

    Let me know if I have anyone following me, this doenst makes sense does it...

    I wonder if I can install the OS to the drives, and then move them to firewire/usb enclosures and they will still boot, since it seems that its only windows/vista that is saying the OS cant be installed to a usb/firewire device.

    I got a head ache now. time to go home...

    thanks...

    John
     
  8. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #8
    Pics would help immensely. :)

    Which Areca card?

    You should be aware, the adapter plates do not work well with RAID cards, if you have in fact done this. Even if you get it to recognize the drive, it will have a nasty habit of dropping out. It's just too unstable.
     
  9. septicdeath thread starter macrumors member

    Joined:
    Dec 31, 2007
    #9
    its a 1222, Its weird, I took a sata drive by itself, powered it with a old psu, and connected it to the plate that is basically a sata to sata adaptor, ad I was able to format it and everything, you'll notice in my diagram that ports 3/4 on the sata to esata bracket are connected to my raid card, the raid card can see the external enclosure connected via esata, its just ports the onboard ports that cant see attached esata devices. *even* if i take a esata to sata cable i have connect the sata side to the same port I just formatted the drive connected to, connect it to the esata enclosure and os x cant see it. really giving me a head ache. both brackets look to be simple pass through circuit boards, either sata to sata x4 or sata to esata x4.


    drawing .jpg attached.
     

    Attached Files:

  10. septicdeath thread starter macrumors member

    Joined:
    Dec 31, 2007
    #10
    pics of pci slot brackets

    I figured I should show everyone what the 2 brackes, the sata to sata and sata to esata brackets.

    attached images

    At this point I'm open to any ideas, I originally thought that it might be the cheap enclosures esata controllers being weird, but I have a MBPro with a 3/4 slot esata card, and the mpc can connect, init, format, and obviously see both the cheap enclosure (19.99) and the expensive on (99.99).

    Since I was able to format, and then install Vista on the one drive I tested that was connected without an enclosure (L sata cable from drive to L sata port on bracket) I was wondering if I dont figure this out if I can take the drive and put it in the enclosure and connect it via USB (I've been told that windows "scans" the usb bus which would cause a disconnect from the drive at this time, and this is why no windows can usb boot). Again, thanks for any suggestions, I thought I did this and had this figured out.

    BTW, when Im done, I dont expect to leave the sata to sata bracket it, I just wanted the one sata to esata so that I could have 2 drives to the logicboard and 2 drives to the raid card, also, I dont want to loose the 2nd slot upgradability, right now the one sata to esata is in the slot built for the two wide graphics card, but my 8800GT is only 1 slot wide, so Im not loosing any pcie slots sticking with just 1. But since I ordered the sata to sata not realizing it was a sata L to sata L bracket, I figured I would see what I could get with that... WEIRD...
     

    Attached Files:

  11. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #11
    So it's only the logic board connections that's giving you the problem?
    (This is what I had understood from your first post).

    I've had issues with the int MiniSAS to ext MiniSAS versions using SATA drives. Unstable.

    I do have a question though, before we can completely rule the bracket (total connections) out. Cable length. How long is the total cable length from the logic board connector to the drives in question?

    I ask, as SATA cabling has limits. 1.0m passive, 2.0m active.
     
  12. septicdeath thread starter macrumors member

    Joined:
    Dec 31, 2007
    #12
    The first pigtail from the logicboard to the pci back plate is about 14".

    I have esata cables that are 36" to 72". Both the cables worked when connected to the 3/4express card esata card on the mac book pro.
    My one cable that is a L sata to I esata is about 12" and that hasnt work either, even when I connect it to the port that worked when directly connected to the drive.
     
  13. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #13
    Would you be able to confirm if there is in fact firmware on that enclosure?
    (I'm fairly sure it does, but would like to make sure).
     
  14. septicdeath thread starter macrumors member

    Joined:
    Dec 31, 2007
    #14
    I have both a western digital mybook with esata, as well as the Nexstar unit. I actually just got pissed off and opened the case up. The internal sas to 4 sata pigtail is actually about 24" long, longer than I thought.

    I think I am going to buy one of those external enclosures that holds 2 drives and has the silicon raid 0/1/jbod firmware on it, I used to have one of those and I seem to remember someone telling me that one will work.

    Running windows just really isnt worth all this trouble or money. If it wont work under parallels for now, I just wont mess with it.

    I left the wiring in place. Maybe I'll try again with the external 2-drive enclosure, as like I've said, been told that they will work better.

    The 3 I have tried are defiantly not working.
     
  15. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #15
    I think I'm getting the idea of what may be going on. Logic board MiniSAS (1 SATA connector) to a PM enclosure?

    As the original logic board conection was meant to access only 4 drives (1 fan out SATA per drive), I would actually be shocked if they provided PM enclosure capability. Just not needed for their intended design, and saves time/aggravation, and cost.

    If you connect them to dumb enclosures, 1 SATA connector/drive from the logic board, you'd be able to use the software RAID capabilities of OS X.

    Your idea of a 2 drive enclosure may also work, if it supports Mac. (No PM chip). This could be a little more aggravating though.

    Hope this helps. :)
     
  16. septicdeath thread starter macrumors member

    Joined:
    Dec 31, 2007
    #16
    I dont understand the statement PM enclosure compatability?. I do understand that whenever I connect to harddrives directory using only couplers to get to a drive mounted outside and powered by external PUS that they work. I also have noticed that the enclosures that I have are all firewire/usb/esata so I think they are not what you would call dumb enclosures) (would you direct me to a dumb enclosure?).

    I'm going to wiki "PM enclosure capability" because thats a new one to me. In the begining of the message you say logicboard minisas 1 sata cable, what I have is a minisas that turns to a round cable, and then provides 4 12" sections of flat standard sata internal looking cables with 4 sata L connectors on it plus a weird 5 cable ribbon cable.


    I've seen people selling a 2 port unit that connects to the 2 extra l sata II ports on the motherboard, but I've also heard you cant boot these? Any info here? can I just connect to these and then use any enclosure.

    What about some of the pcie esata cards that are out there? I really dont need to take it from the logicboard, I was just under the impression that I HAVE TO to have bootable drives.

    I actually hooked up the two 7/8 connectors from the raid card, and was able to configure what the raid card calls pass through disks. OS x sees these fines (in the enclosures I currently have) but of course when I try to boot vista it doesnt see it, I DIDNT EVEN THINK TO check areca's site and see if there was a F6 driver for the raid card, seeing that vista/xp allow that, I bet I could actually do this, as the areca card IS windows compatible I bet there is a driver out there for it.

    Thanks for working this through with me, I am SURE I wont be the last. By the time I am done, we will have a recommendation for a dumb enclosure or proof that the 2 seial-ata ports on the MB under the fan can be used to extend to esata brackets (newer technology esata extender cable for instance), or a PCIe esata card that can boot or proof that "additional drivers" can be added to the windows install so that the raid card ports rerouted out via esata bracket can be used. One of these has to work.

    now to wiki searc "PM enclosure capability"
    -John
     
  17. septicdeath thread starter macrumors member

    Joined:
    Dec 31, 2007
    #17
    Okay, I dont think the Western Digital My book home edition is expecting a port multiplier controller card, most of these enclosures that I have, all included a single esata bracket that was simply a 1 ended L connected sata ribbon cable, so I dont think they are expecting controllers with port multiplier capabilities, I would call these enclosures dump when compared to some of the hits I got on PM enclosures.

    My main concern is to be able to build a windows install off the esata port. MY purpose for selecting the internal logicboard other than it being there is that I know that the Intel ICH7 controller is going to be recognized by any os boot disk. I'm starting to think it might make sense to disconnect the cable going to the logiboard, remove the adaptor bracket and put in a pci card with 2,3,4 esata ports on it, just need to make sure that I can boot the drives on it. Maybe you can help there. Any ideas? As hunting down a enclosure doesnt sound fun, I still have a Macalley 1394a, usb2, esata on its way cause I thought they looked cool. that might be dumber than the other one I have. The fact that the Western Digital doesnt work is very alarming to me as well. I have had it on a Windows PC with just one of the simple single esata brackets connected to a internal sata port in just about all of my last 4 x86 pc's...

    Thanks
     
  18. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #18
    A Port Multiplier Enclosure would look like this (simple example). Basically, it takes a single eSATA input, and connects it to multiple drives. There's a small PCB inside that uses a circuit (chip) that switches between multiple drives, and passes the data down a single SATA connection.

    If attached to a controller, whether a separate card, or on the main board, it must be compliant with PM operation. Otherwise, it won't work.

    So a "dumb" enclosure only has 1 SATA connector per drive.

    Does this make sense?

    Areca's drivers. ;)
    You might also want to read this in reference to the Windows side and the ARC-1212.

    As far as eSATA cards, I'll have to look, to see which ones might be the best fit (Boot capable).
    Do you also need it to work with OS X as well? Or Windows only?
     
  19. septicdeath thread starter macrumors member

    Joined:
    Dec 31, 2007
    #19
    I only would need the pci esata card to boot windows, I have enough osx disk and since firewire/usb work too, I got that covered.

    That was my worry, as the devices that I have tried to connect to the esata/logic board ports have all been single drive enclosures. So even though my western digital has a firmware (I saw it was upgradeable and not to do it cause people were destroying them), all three I have had have had a controller board that slides down onto the sata drive making the power/sata connection, rather than say a "power plug" and small sata cable coming off a pcb board, but they all have had 1 sata connection inside them.So they all qualify as dumb, right?

    I'm having a little bit of a mental block because I DID have a Trans Intl MiniG http://www.transintl.com/store/minig.cfm that I believe I actually had hooked up to the esata ports and IT WAS WORKING. My co-worker says I had it hooked up usb, but when I boxed it up to return it I had to go retrieve the box and re-open it to put the 6' esata cable back into it. (The unit had a broken off external raid switch, so I couldn't config the device's jbod/ safe 33/ safe50, mirror, stripe) so I sent it back. I replaced it with all of these "dumb" enclosures. But I swore I was installing osx to it so I could make a internal osx boot to then bootcamp partition it, if you read the beggining of this thread, it actually started with me seeing the disk as external and asking why it wasnt called internal, so I'm pretty sure if I were to go back to this and just boot the windows media I could actually do this. All of our communication past you pointing me to the sil controller docs has been on a dumb enclosure.

    I have not yet tried to connect to the 7/8 ports of the areca and try to load the drivers with the F6 option, this only came to me because I saw the card WAS windows compatibility, so I figured there must be a way to use it, even though areca told me that I couldnt put Windows on the Raid, I think they didn't understand me and went straight to the first level support guy who immediately read that I had a OSX raid 5 and thought I wanted to bootcamp slice up the raid partition, rather than give a whole disk to it via pass through. They are so quick to reply with the first thing they read that is a remote match, most support is).

    I have found some post where people talk about using the newer technology bracket connected to the two sata II ports on the motherboard, and it being bootable and working with the esata, initial investigation seems to point that a few people have had issues with certian enclosures and it doesnt work, but there are people giving examples of units that DO work, so maybe I start there and try it on the logicboard connectors, if that doenst work, I buy a diffrent esata to sata bracket and connect to the two sata ii's on the motherboard. 1 is aready routed to the first optical drive incase in the future I wanted to run a sata dvd, because getting all the wiring up into the optical area for the 5/6 drives was a pain moving the fans and all that so I prewired that.

    So were back choosing a route.

    #1. I think I will try the areca passthrough disk and areca f6 drivers first, since I spend no more money. And give that a try.

    #2. I use one of the pc esata adaptors to internal sata brackets I already have connected to onboard sata II and try with the enclosures I already have.

    #3. I fork out the money for another MiniG or follow the recomendations from the threads on a 2drive enclosure (from OWC) dealing with the newer technology bracket and give that drive a try with the brackets I have, if that doesnt work get a newer tech bracket (cant see why its diffrent than using one I have and running internal sata cables to my bracket to the onboard ports.

    #4. Send it all back while I can, and say SCREW WINDOWS in native mode, and go get a cheap PC that I can just use if I really needed it.

    What do you think, anyone else out there connected to the 2 sata II ports to external drives via esata and have it work? Boot Windows?

    Thanks again.
     
  20. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #20
    Weird. This miniG is a PM enclosure. Is this the one you had previously?

    If you post a link to the current enclosures, that might help. Usually, the circuit is just a converter. USB to SATA, FW to SATA, and SATA pass through (assuming it has all of these features). The firmware part is what throws me, as I'm more accustomed to the circuit not requiring it. What is this firmware intended to do? RAID functions?

    Given you already have what you need to try it, I'd say go for 1 or 2. The only further investment is some time. ;)
     
  21. septicdeath thread starter macrumors member

    Joined:
    Dec 31, 2007
    #21
    I have no idea what the firmware on the WD is for, except that it has a vertical white line bar, as the drive fills up, the light lengthens along the vertical bar so maybe its for that, the only way I know that it had firmware is because I did a search on WD MyBook firmware and found hits on how a WD release was wiping the firmware, and failing before it restored the new update, leaving the enclosure useless, and WD wasn't supplying a old firmware or alternate firmware that allowed these people to flash back.

    I'm going to try some of my efforts today.
     
  22. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #22
    Yikes! :eek: :(

    I would have thought the only firmware involved would be that contained in the drive itself.
    Good luck, and please post the results. :D
     
  23. septicdeath thread starter macrumors member

    Joined:
    Dec 31, 2007
    #23
    Well, I started off with step #2. and Ran a short internal sata cable from one of the onboard sata II ports located on the macpro motherboard to the sata to esata bracket.

    The drive showed up on the desktop in OSX, so I partitioned it, set it to MBR and fat32 formatted.

    I rebooted the machine with the option key, the raid5 array shows up, the recently formated disk on the onboard sata port was presented, and the Vista 64bit sp1 dvd with both its layers (install/efi partition).

    Looking good.

    So I booted the vista install and unfortunately when it came time to select the disk, vista couldn't see anything. So its obvious the drivers for the sata onboards are not generic drivers contained in a vista 64bit sp1. Of course, vista is a lot smarter than xp, so I can put a usb key drive in and search it for drivers. Unfortunately the drivers I first guessed to download for a intel ich chipset were not recognized as anything that I needed.

    Since I think there is better chance of finding the drivers to get the pass through disk on the areca raid card, I decided to see what I could do with this option.

    will report there, any idea anyone on which windows drivers to use to use the onboard sata ii ports of the macpro motherboard?

    Now trying the passthough areca.
     
  24. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #24
    Have you checked the Areca drivers I linked earlier?

    It might have the version that you need. You should read the other link on the line below the driver link as well (text file), as it explains what's going on.
    (SCSI driver) ;) It might be affecting the SATA ports, as this driver is needed for the ARC-1222. Strange to you perhaps, but I've seen things like this before. (Driver interaction issues). :eek: :rolleyes:

    As far as a specific driver for the logic board ports, I'm not exactly sure. (Assuming the above is not the case). I would have thought Vista would have what's needed as well. :confused:

    Try sorting the Areca first, just in case it is an interaction issue. See if it helps the SATA side. Also check to verify the ARC-1222 is functioning correctly. (It should, but please verify, not assume).

    Let me know what happens. This is a weird one, and hard to help with on a forum. (I can't see what's going on). :(

    Good luck. :)

    Addendum:
    I hadn't thought of this, previously, as it's needed for OS X, but try removing the ARC-1222 before starting the installation of Vista. (You do a basic OS install first, then add the RAID card). Hopefully, it will successfully install. Then add the ARC-1222 to Vista (follow instructions, should be rather easy). Again, you will need to manually install the SCSI RAID driver. Assuming this is successful, once the ARC-1222 is back in, it should then work in OS X and Vista. (If you actually do want it in both OS's. If not, you'd need to go into Device Manager, and disable it in Vista).
     
  25. septicdeath thread starter macrumors member

    Joined:
    Dec 31, 2007
    #25
    Yeah. I actually used the link you sent me to and got the drivers. On a usb stick I am able to actually load the drivers for the raid card, and I can see the raid card. Of course, vista complains that it is GPT and cant do anything to the disk.

    I'm not sure why the "pass through" disk isnt showing up. Except that now its flaky even to OSX.

    I'm using the OWC Mercury Elite AL Pro with my own 2 x 320gb hard drives. during my search of the Newer Tech sata to esata connection to the onboard sata, this is one of the cases that people have claimed works connected to the mac pro sata ii ports. I can see it in OSX now, and If I install OSX to it, I can boot it, however, Windows doesnt see the drives, the sata chipset on the mac pro doesnt have the drivers built into it for some reason, WHICH makes no sense, since when you boot a normal mac pro with a drive on the sled, windows can install right to it.

    I think I actually have an idea, and although some might laugh, I think I know how I am going to do this.

    I have taken a 2.5" sata drive, and used doublesided tape to stick it to the PSU outter shell, the door actually closes and since its between the two rails on the side panel, its actually held in place. Now I am going to get a splitter and split power and run power right to it, and will re-route one of the sata cables from the pigtail on the sas connector up and into the optical bay like I did for the 2 drives up there for the 5/6 drives in the areca raid. Since I already know that I have had no problems connecting the logic board sata ends directly to hard drives (I've tested it with 3.5 3 different times now).

    I think its a shame that none of the raid cards allow you to install windows, over on apple's forum, its a huge topic, the only card that allows for it, does it by allowing you to connect 3 internal drives to a raid, and 1 of the internal drives gets allocated to the logicboard via a jumper cable from the logic board to the raid card. The caldigit card does this, *BUT* they have gone and made the external sas connectors on the card proprietary and you cant hook up any minisas external enclosure, you have to buy theirs at about 1800.00 for 4 terabytes, other than that, everyone is having the same issue I am having, everyone claims the onboard sata is bootable, then about 3 pages into the blog, someone mentions they cant install windows to it, its only os x bootable, and the next and the next and the next. Others conspire apple did it on purpose.

    Time to return this $500.00 worth of external enclosures and crap and just get 1 320 gb sata 2.5" disk and mount it where I said so, if that dont work, SCREW windows.

    Thank you for all your help. I'll give it one more try with the ext enclosure connected to the raid card in pass through mode, because after I installed the raid drivers and saw only the raid 5 raid, I went to the http page for the raid card and it claims that the "pass through disk: Failed Status" not sure if it disconnected or what.?!?!?

    makes no sense to me that a 100 dollar pc motherboard can have the sata oprts extended and work with esata controllers.

    One site I have been too, claims that when the Mac boots the windows os, it drops out of ACHI mode and has a huge routine to make the onboard sata ports usable in windows, check out -> http://www.xlr8yourmac.com/feedback/Mac_Pro_Ext_SATA_Case_Kit.html

    and search for Spare SATA ports with Windows, what a mess.

    Will keep thread updated..
     

Share This Page