Mac Pro not recognizing RAM

Discussion in 'Mac Pro' started by petersonwork, Apr 8, 2011.

  1. petersonwork macrumors newbie

    Joined:
    Jul 8, 2008
    #1
    Hey how's it going, I currently have a Mac Pro and have had it for about 3+ years(unfortunately not under apple care anymore). Just so you can see what I am working with here, I bought it how it is except I purchased 4 more gigs or RAM(it had 2) making a total of 6. I purchased after doing research on which RAM I needed I asked on many forums including this one and got the same result so I got it. I read both Apples instructions on installing new RAM and the instructions that came with it. Worked perfectly for years until just now.

    About this Mac: (Version 10.6.7)
    Processor: 2 x 2.8GHz Quad-Core Intel Xeon
    Memory: 2 GB 800 MHz DDR2 FB-DIMM
    This here^^ Used to say 6 Gigs just up until 2-3 days ago and never had a problem since I bought it, til now. I cannot recall installing any new software or anything at all. I was working on a new design project and I just noticed with a couple programs open I was running a bit slow.
    Maybe something fried or burnt out? Maybe I worked it too much? I don't know.....I'm not a doctor...hehe.

    I tried opening my case and just simply taking out the RAM and putting it back in but it did not recognize it.

    MY RAM:
    ---===Top Slot===---
    Factory made two 1GB sticks

    ---===Bottom Slot===---
    OWC (custom) two 2gb sticks

    Any help would be very much appreciated!

    Also I know there are forums and such on the Apple support section of their website but is there any way, if you do not have a Apple Care(not anymore) to contact someone directly?
     
  2. philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #2
    so what ram is bad the owc? try turning the machine off and moving the owc ram with apple ram if the machine reads the owc in the other slots and the apple can't be seen then the slots are bad.
     
  3. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #3
    You could also try cleaning the contacts with rubbing alcohol (isopropyl, as high a % as your local drug store carries).

    Another thing in keeping with philipma1957's recommendation (very good one), is to also try moving the riser cards (card with the DIMM slots attached), and see if that helps if moving the DIMM's around does not. Also, if you have to do this, go ahead and clean those contacts as well. ;)
     

Share This Page