Mac Pro wifi problems - transmit rate of 1 constantly

Discussion in 'Mac Pro' started by fluidedge, Sep 30, 2010.

  1. fluidedge macrumors 65816

    fluidedge

    Joined:
    Nov 1, 2007
    #1
    Having enormous troubles with using Wifi on my MP. I've had this before and it's a PITA.

    The transmit rate just drops to 1 (it should be up in the 90s shouldn't it?) Is there any known fix? I'm using Leopard. Should I upgrade to Snow Leopard? Does this solve it?

    I think it's a known problem?
     
  2. philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #2
    as always wifi is not consistent and will vary from location to location. If you are near airports or military bases interference will slow your rates of speed.

    Is this the same piece of gear the had problems or is this a new MP. For solutions hardwire. If hardwire is not acceptable. look for an antenna to boost signal. also try another channel there may be less interference. remember wifi is more like a radio then a cell phone. crosstalk is more common. If you have good neighbors ask around maybe someone has a new wifi that is interfering with you.
     
  3. fluidedge thread starter macrumors 65816

    fluidedge

    Joined:
    Nov 1, 2007
    #3
    RIGHT I think i might have found a very neat solution to this.

    I have an iBook that has perfect internet signal (probably due to the thin plastic shell compared to the 1/4" thick aluminium!)

    I've enabled internet sharing as follows:

    router - - - - - - - ibook (wifi) --------- Mac Pro (wired ethernet)

    Now I get a perfect internet connection on my mac pro as if it was connected to the router by cable but with no ugly cables running through my flat. :)
     
  4. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #4
    My WiFi sucks. I don't even know why I blew $50 on the card.
     
  5. fluidedge thread starter macrumors 65816

    fluidedge

    Joined:
    Nov 1, 2007
    #5
    I agree. The Apple instistance of form over function (aluminium case!? - looks great but no signal can get in) is a bit annoying.

    I think they should not include WiFi as an option or at least move the antennas to outside the case.
     
  6. Transporteur macrumors 68030

    Joined:
    Nov 30, 2008
    Location:
    UK
    #6
    The WiFi on my machine works pretty well.
    Full signal through 4 walls and transfer rates of 7MB/s using an Airport Express (n based of course).

    But as already mentioned, the WiFi signal strongly depends on the position of the machine. A few inches can sometimes make a huge difference because magnetic fields (like from power wires, speakers etc.) interfere the signal.
     
  7. SnoFlo macrumors regular

    SnoFlo

    Joined:
    Feb 5, 2010
    #7
    I was getting no end of wireless problems on my MP until I changed around the wires to the Airport Extreme card to 2, 3. Now I get all bars (knock on wood).
     

Share This Page