Macbook - No Sound - Volume control locked

Discussion in 'MacBook Pro' started by Hustle, Aug 26, 2007.

  1. Hustle macrumors 6502a

    Jul 29, 2007
    I was using iShowu earlier to make a video for YouTube. When i clicked record, i stopped getting sound. Once i had finished, i still got no sound.

    The volume control bar is on full and it wont let me move it anywhere, and im still not getting any sound, even though the volume is locked on full.

    What could be causing this?.

    Yes, i've restarted etc...
  2. Hustle thread starter macrumors 6502a

    Jul 29, 2007

    It seems the output device was changed from internal speakers to the one below it.
    Silly me.
  3. sineadni macrumors newbie

    Jan 10, 2010
    Audio locked

    Bonjour Hustler I have the same thing with my Mac, I've been told that it's something to do with the fact that I've connected my amp to it and that the volume on the amp higher than that on the computer has locked my audio on my Mac??? And that there was no way I could get it back??? HELP

  4. sidneyssa macrumors newbie

    Oct 19, 2008
    Unlock the Audio

    Go to "System Preferences" click on "Sound" make sure that the "Input" is set to "Internal Microphone" and the "Output" is set to "Internal Speakers".
    Good Luck!
  5. jmartigu macrumors newbie

    Mar 25, 2011
    No sound on my MACbok

    I did try going to preferences and the output part says "the selected device has no output controls" and it doesn't allow me to select anything!
    Any suggestions?
  6. jmartigu macrumors newbie

    Mar 25, 2011
    Solved it!

    Apparently, when plugging headphones or other devices, sometimes a little switch inside the output port clicks and it changes the sound output to "digital audio" or something of that kind.

    What happens is usually this:
    1. The internal speakers still chime when your Mac is powered on
    2. A 'no parking' like symbol appearing below the sound icon whenever you attempt to manipulate the volume on your Mac
    3. A red light continues to emanate from the audio output port
    4. Only "Digital audio out" as the only output source displayed in the Sound panel of the System Preferences.

    Sometimes, just plugging and unplugging the headphones again works, but what I actually did was, very gently, use a toothpick to click the little switch inside the port back on...and voila!

    Hope this helps.
  7. verothiel macrumors newbie

    Apr 7, 2011
    Sound input

    Can I just say thank you, jmartigu, I started panicking as my macbook is already a bit wonky, and I really thought I'd lost the sound - plugging in and unplugging the headphones did the trick!

    Huzzah for the Internet :)
  8. mac-matt macrumors member

    Dec 31, 2009

    plugging in a headphone did the trick for me too. thanks
  9. GermanyChris macrumors 601


    Jul 3, 2011
    Yup +1
  10. Jordo960 macrumors newbie

    Sep 9, 2011
    This is exactly the problem I have. Plugging in the headphones has not worked. Is the switch on the side of the headphone port? In the back?
  11. parker770 macrumors member

    Apr 5, 2010
    Just keep fiddling with it with a toothpick or any other non-metallic object.
  12. smoking monkey macrumors 65816

    smoking monkey

    Mar 5, 2008
    You Only Live Twice
    I just had the same thing happen to me. Be patient. It took me about 1 hour to finally fix it.

    The first thing I though was my headphones had caused it. That was correct in a way. So I plugged them in again and pulled them out several times.

    That didn't work. So I then checked the boards and found threads about this and realized I just had to keep trying.

    I repaired permissions and then restarted my computer 3 times. On the third time after plugging in my headphones and pulling them out again, I got my sound back.

    I did have the red Digi light emanating from the jack before turning it on and off as well. I wasn't able to see a small switch inside as my eyes aren't great so I just kept at it until it was fixed.
  13. pdc39 macrumors newbie

    Sep 23, 2011
    im having a similar problem to all people above, except mine wont play any sound no matter what, except for startup sound. The volume logo on the toolbar is gray and when you try to move the volume it doesnt move, and there is a little 0 with a slash thru it beneath the volume controls when you use the keyboard shortcuts.
    I tried all of the paper clip, blowing, jiggling, etc and nothing has worked. Under my system pref it says in the output menu that i am in "Digital Out" but that there are no audio controls for this device. There is no other output option, and the master volume for output wont work.
    any ideas?
  14. smoking monkey macrumors 65816

    smoking monkey

    Mar 5, 2008
    You Only Live Twice
    Your problem is identical to the problem I had. Read my post above and you should be able to resolve it with some patience.
  15. bodger macrumors newbie

    Nov 18, 2012
    Get some electrical contact cleaner & spray it into the headphone socket. I tried the above solutions but that's what instantly fixed it for me.
  16. higgs01 macrumors newbie

    Sep 11, 2012
    lost sound on macbook

    thanks for the help ,,, lost my sound but did as instructed plugged in earphones and got sound back,,,;)
  17. Thommy1106 macrumors newbie

    Dec 7, 2012
    This was helping absolutely. After toothpick operation all is working perfect again! Thanks a lot!!!
  18. JWAIII macrumors newbie

    Dec 20, 2012
    I gotta say, this is kinda ridiculous. I've had other odd little troubles with this new MacBook Pro, including a challenging time transferring information from my other computer (which should be pretty basic). I hope this isn't indicative of the direction Mac is taking - one of the best things about Macs, in my experience dating back to '95, has been the absolute ease of use in the everyday stuff. Like sound. Maybe I've been lucky? But this sound issue? Fixed by plugging in headphones over and over until it works? Are they making these things back in the garage again?
  19. Cameron8 macrumors newbie

    Mar 20, 2013
    I'm having similar troubles with my Mac. It's been freezing suddenly the past 2 days and I wasn't sure why. So looking online advice said shut the computer down and hold down both shift buttons @ once before you hear the start up tone. So I did and still heard the start up tone. Going to itunes now, the volume is locked in what seems to be the same way as the rest of all yours. But the itunes wont play anything either. Not will youtube. It all worked before I had to force it to shut down by holding the power button since nothing else worked frozen. I can click on the song and even though I couldn't hear it I still expected it to play, just muted. Same with youtube. Just black, loading but never playing. I've been fiddling around with the headphones, plugging them in and messing with other objects like suggested but it's not working. I went to System Pref. then Sound & all that shows up is "No input device found" and the volume bar is locked. Any advice? What happened between it freezing, shutting down and coming on? The music played fine and I wasn't wearing headphones so it's not like I triggered something inside it.
  20. kuramayoko10 macrumors newbie

    Sep 8, 2011
    Blowing air

    For me the only solution is by blowing air inside the port.
    Sometimes it take a while but then it comes back.

    I have to do it many times. It is not a permanent fix.
    This really sucks =/
  21. ahmed tariq macrumors newbie

    Mar 14, 2014
    No sound on my MACbok

    This is exactly the problem I have. Plugging in the headphones has just worked but when i unplugged the headphones i lost my sound. please help me ... how can i prevent this exercise (Plugging the headphones or unplugging the headphones). HELP
  22. Digitalis88 macrumors newbie

    Apr 21, 2014
    Sound blocked


    I have the same problem. I inserted many times head plugs and toothpicks. Nothing seems to work. The light disappears but still the problem remains.
    Can somebody help me on this?
  23. BarryKayton macrumors newbie

    May 10, 2014
    Solution: Use Terminal to reset audio

    I had a similar problem: using the volume control keys shows the volume set to max but there's a locked symbol below the indicator.

    Removing and inserting the headphones made no difference.

    I solved the problem by opening and pasting the following command:

    sudo killall coreaudiod

    This quits the Core Audio daemon. But the system then relaunches Core Audio.

    Solved the problem without having to restart.

    You can read more about the solution here:
  24. TB07-NJ macrumors 68020

    Jul 7, 2008
    I have tried every fix so far found on the web (both hardware and software) with no luck. Only thing I haven't tried was the switch/contact cleaner which sounds like a good idea as a last resort. I have a 2010 MBP and the red light always stays on in the headphone jack. Maybe a little WD40 would do it?
  25. carlson508 macrumors newbie

    Jun 16, 2014
    you are a life saver!!! plugged in headphones and boom the sound works. thank you for being smarter than I lol

Share This Page

35 August 26, 2007