Macbook Pro 2018 - Charging & RAM issues

Discussion in 'MacBook Pro' started by RichardFASmith, Aug 8, 2018.

  1. RichardFASmith macrumors newbie

    Joined:
    Jun 28, 2005
    #1
    Just got the new MacBook Pro (15", i7, 512GB, 16GB RAM) and have been getting a few bugs. Maybe others have had similar issues and can help.

    A lot of the time when plugging in the power adapter the noise indicates its charging, the bolt appears on the battery icon in the menu bar, but yet it still runs down the battery. Turns out it often shows as "Battery not charging".

    Initially thought a problem with 3rd party power adapter, but still happens with supplied adapter (although less frequently. I've tried resetting the SMC which may have made a small difference, but not really fixed (and poor that less than a week in the SMC needed resetting). I've tried different power outlets etc...

    Then it particularly has trouble with USB-C hubs. Got a very well reviewed one from Amazon that others have said can be used to easily charge laptop, connect HDMI to QHD monitor and a couple of other USB peripherals without problem. Works for me occasionally, sometimes just power, sometimes just monitor, but on a friends MBP 2018 it works every time for all ports.

    Also suspect I may have an issue with RAM not being released when apps close. My previous laptop was 2013 MBP Retina 15" 16GB, and I didn't bump up against the limits of the RAM anywhere near as quickly. It often seems from the Activity Monitor that after quitting an application using a lot of RAM, the RAM consumption stays the same.


    -------

    There's a bit there to digest, but has anyone else had similar issues? If so what has worked for you?

    Also, while I believe the USB-C hub is fine as it appears to work on other MBP laptops, just in case can anyone recommend a sub £100 hub/dock that will deliver/pass-through enough power to charge, connect a QHD display and also run 1 or 2 other peripherals for short bursts?
     
  2. fokmik macrumors 68040

    Joined:
    Oct 28, 2016
    Location:
    USA
    #2
    Some of the users , got rid of issues by wipe the ssd and fresh install
    You should try it...i guess the RAM not being released will be no longer an issue...the only question remain is the charging issue
     
  3. m-e macrumors regular

    Joined:
    Aug 6, 2015
    #3
  4. SDColorado Contributor

    SDColorado

    Joined:
    Nov 6, 2011
    Location:
    Highlands Ranch, CO
    #4

    I assume you have already tried an SMC reset and that did nothing to resolve any of the issues? If not, it’s worth a try. It may not help, but it’s a first step. As you may already know, the procedure is a little different for the 2018’s with the T2 chip. Scroll down if you aren’t familiar with the different process.

    https://support.apple.com/en-us/HT201295
     
  5. ubitmeomg macrumors newbie

    Joined:
    Jul 13, 2004
    #5
    I am having the same problem. This morning, my 13-inch 2018 4TBT3 macBookPro wouldn't charge from any of the USB-C ports. This is not the first time I had this hardware issue.

    The first time, one of the USB-C ports on my macbookPro stopped taking charge. occurring roughly 20days after purchase. I took it to the Apple store and they took it, replacing it completely with a brand new one a month later.

    It is 20days after receiving my replacement, and I am having the same issue as the first time with the USB-C ports not charging the notebook; only it is all four USB-C ports instead of just one!!!

    This is maddening because I know I'll be a month without my macbookPro when I take it in again. For some reason, this issue happens 20days or so after starting a fresh MacBookPro with this issue, in my limited n=2 experience. Just crazy how reproducible it is in terms of both days and issue.
     

Share This Page

4 August 8, 2018