MacBook Pro 840 EVO Nightmare

Discussion in 'MacBook Pro' started by guineaphinea, Jan 31, 2014.

  1. guineaphinea, Jan 31, 2014
    Last edited: Jan 31, 2014

    guineaphinea macrumors newbie

    Joined:
    Jan 31, 2014
    #1
    Hey everyone, sorry for the long post but I wanted to make sure I didn't leave out any details. Thanks in advance!

    Last week, my Mid-2012 13" i7 MBP suddenly started to freeze, boot slow, and began to click (or so I thought, I'm paranoid). Not unfamiliar with a drive failure, I replaced the drive with a working 7 year old 200GB Seagate drive. I restored from my Time Machine backup and all was well. In an effort to not have to deal with hard drive issues for the remainder of my Mac's life, I purchased a 500GB Samsung 840 EVO.

    Upon installation, I formatted the drive to JHFS+ and tried a fresh install of Mavericks via USB stick which failed (and I failed to check the log, yay). I replaced the Seagate drive, remade the stick, and tried the install again. Multiple attempts at formatting (including trying to use Terminal: diskutil) all fail alternating between two errors: "File system formatter failed" and "Wiping volume data to prevent future accidental probing failed". Also, trying to perform a disk erase using terminal returns a "POSIX I/O Error". The drive also fails to format when booted into Internet Recovery. An Apple Hardware Test returns a "4HDD/11/40000004: SATA (0,0)" error.

    Using the USB stick, I tried installing Mavericks to the SSD with an external USB 2.0 to SATA enclosure where it performed at USB2 speeds, but flawlessly. As soon as I installed the SSD with Mavericks into the MBP, it failed to boot.

    I was about to RMA the SSD until I put it in my 6-year old HP, formatted it, and it installed Windows 7 where it functioned quickly and flawlessly.

    The only thing keeping me from purchasing a new SATA cable is the fact that I'm typing this right now with no issue from a 7 year old 200GB Seagate drive. Also, I'm about tired of dumping money into an already expensive laptop. I would travel to an Apple store for service but the nearest one is over 1.5 hours away.

    I've updated the firmware of the SSD to the latest available, reset PRAM/SMC, reseated the SATA cable at least 7 times, and considered throwing this thing in the trash at least 42 times.

    13 frustrating hours later and I'm still left with a half-functional Macbook 3 weeks out of warranty. Any help is greatly appreciated and thanks again...
     
  2. ecschwarz macrumors 6502a

    ecschwarz

    Joined:
    Jun 28, 2010
    #2
    It sounds like you did all you could've initially. I'm just spitballing here, but I think you might want to try to get a different drive - Windows machines have different partitioning and formatting schemes and might be less sensitive (initially) to a failing SSD. Some of that may be exacerbated with running it internally versus the slower external enclosure...either way, I would try to test with more variables, and the easiest may be an SSD swap.

    I'd also try the dying (dead?) hard drive in the external enclosure with a thorough test of the drive - maybe one of the zeroing options in Disk Utility just to stress test it...
     
  3. torana355 macrumors 68020

    Joined:
    Dec 8, 2009
    Location:
    Sydney, Australia
    #3
    Do you know anyone else with a Mac machine where you could test the new SSD? Short of trying a new Sata cable it seems you have tried almost everything.
     
  4. MasturB macrumors newbie

    Joined:
    Jan 31, 2014
    #4
    So the question goes back... to return the Evo and order a Crucial, or to keep my Evo... lol
     
  5. guineaphinea, Feb 1, 2014
    Last edited: Feb 1, 2014

    guineaphinea thread starter macrumors newbie

    Joined:
    Jan 31, 2014
    #5
    Alright, just for kicks (thanks ecschwarz for planting the seed) I installed the factory (and what I thought to be dead) drive in my external USB enclosure, booted off of it, and lo and behold everything is functioning fine. More and more this situation is leaning towards the internals of my MBP.

    Now, three questions... First, what would make the SATA cable of a year old MBP that has NEVER been opened suddenly fail? Second, why is a 7 year old Seagate drive the only drive that seems to function properly in the internal SATA slot? Third, isn't it more likely that it's the SATA cable and NOT the SATA controller?

    The entire reason I bring up the SATA controller is the fact that when the factory drive was "failing" it simply would freeze. I was originally thinking hard drive failure because of the sounds it was making. These Toshiba drives have completely different sounds than the Western Digitals/Seagates I see fail in PCs I work on. The drive is making the same noises it was when it was in my MBP (yet working 100% in the USB enclosure) so I assume it is working normally.
     
  6. Anitramane macrumors 6502

    Joined:
    Dec 23, 2013
    #6
    well one thing i know for sure is that the Sata cables suck and break in the macs alot.
     
  7. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #7
    I installed an EVO drive into a client's 2010 13" MBP. I used Carbon Copy Cloner to clone the original drive which I first updated to Mavericks.

    Work like a charm and she loves her MBP again :cool:
     
  8. Barney63 macrumors 6502a

    Barney63

    Joined:
    Jan 9, 2014
    Location:
    Bolton, UK.
    #8
    Could it be anything to do with the speed of the sata drive? Your 7 year old drive will be slower and maybe the sata bus/controller can manage that.

    Barney
     
  9. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #9
    If I read your first post correctly, you have a current and good Time Machine backup right? Why not put the Evo back in, ensure the Time Machine rive is connected, boot it up, use Disk Utility to format the Evo and then restore from Time Machine?
     
  10. J@ffa, Feb 1, 2014
    Last edited: Feb 1, 2014

    J@ffa macrumors 6502a

    J@ffa

    Joined:
    Jul 21, 2002
    Location:
    Behind you!
    #10
    This sounds almost certainly like your Mac's internal SATA cable is at fault. The best and quickest way to test this for sure is to place your new Samsung SSD back inside your Mac, boot from an external drive (your old one will do fine if it works to that extent) and download and run the SMART Utility application to see if you have any errors at all listed under 'Interface CRC error'. You can only check this sort of diagnostic info on a drive when it's connected internally, hence the slight hoop jumping here. The reason your old drive is working (albeit intermittently) is almost certainly because it's a SATA II drive and the Evo SSD is SATA III and thus making much fuller use of the cable. The issues with the old drive are possibly the fault of the cable, but it could equally be that it's failing and the cable is on the blink.

    As to why it's gone wrong, it's almost certainly nothing you did. The hard drive cables on MacBook Pros have been pretty flakey historically, though since the newer models suffer from such things far less it's probably just bad luck. Once the cable's replaced everything should be perfect with the new SSD. Just so you know, once you get it repaired, the drive will still have CRC errors (they get logged to drive at a low level and persist after formatting and the like), but obviously shouldn't increment up any more. You could even buy the right cable yourself online and save yourself the trip to the Apple store and the wait for the repair. Disconnecting it from the logic board is probably the hardest part of the process, and you've already done it half a dozen times :D

    Edit: Oh, and if I'm right— if you put the SSD in an external enclosure, you'll be able to install an OS to it there and it'll work gloriously. If you then pop it in the machine, it'll probably boot some/all of the time but occasionally struggle or freeze like your old drive did.
     
  11. guineaphinea, Feb 1, 2014
    Last edited: Feb 1, 2014

    guineaphinea thread starter macrumors newbie

    Joined:
    Jan 31, 2014
    #11
    Why in the world would Apple continue to use them if they're problematic? Kinda sad that a $1600+ laptop can't outlast a cheap $600 HP.

    Someone on the Apple Support Communities stated that...makes sense.

    Sadly, the EVO is basically as good as dead when it's installed internally. It's recognized but any attempts at formatting, writing, or reading are futile.

    System Report is showing that the working 7 y/o drive I have in here now is running at 1.5Gbps. The drive is definitely a SATA 2 drive but it's negotiating at 1.5Gbps...interesting! I wonder if it's falling back to 1.5Gbps speeds as a failsafe, there are no 'force SATA 1 speed' jumpers set on the drive!

    I've already done this and while it was in the enclosure, everything was perfect...as soon as I put the SSD in the internal bay, it failed to boot 3/3 times.

    Alright, so I'll spend the money and buy a new one. Here's my dilemma...iFixit and Powerbook Medic are out of stock. The only one I can find online is on eBay here. Does this seem fine to buy? I've never purchased anything with eBay before! :p
     
  12. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #12
    First, check Software Update to ensure no firmware upgrades are available. I use an 840 Evo, though a 120 GB, and it works beautifully in my 2012 MBP.
     
  13. ecschwarz macrumors 6502a

    ecschwarz

    Joined:
    Jun 28, 2010
    #13
    I'd check that, too - other than that, I think the cable might be your best bet. I'm using the 840 Evo on my 2012 model, and it negotiates a 6Gbps connection. The other thing is that even on older machines (I know yours isn't), Samsung's drives tend to work well with slower SATA connections, too. There are a few others that have some issues and often give people grief when used in optical drive installations.
     
  14. guineaphinea thread starter macrumors newbie

    Joined:
    Jan 31, 2014
    #14
    Yeah, I checked that after two failed installs and sadly already had the latest firmware. I ordered the SATA cable I listed earlier from eBay and I'm hopeful that will fix the problem! It should be here on the 6th, I'll report back then!
     
  15. ecschwarz macrumors 6502a

    ecschwarz

    Joined:
    Jun 28, 2010
    #15
    Great - I think we're all going to be anxious to hear if it works. If that is the case, I'm sorry to hear that it failed - in my experience with working with these with students, the non-Retina MacBook Pros have been pretty robust overall, so hopefully this is an annoying bump in the road for you!
     
  16. guineaphinea thread starter macrumors newbie

    Joined:
    Jan 31, 2014
    #16
    Well, two days past the estimated shipping date (thanks USPS), the SATA cable has arrived and been installed!

    I've fresh installed Mavericks onto the EVO and enabled TRIM without a problem! Been using my MBP for about 4 hours now without any hiccups at all! Negotiated link speed is back to 6Gbps as well!

    If today is any indication of the future, I'm again very happy with the performance of the machine. Boot times are 15-20 seconds compared to 1.5 minutes and system responsiveness is amazing now...no beach balls! Battery life is already seeing an improvement as well, I've been on battery for 45 minutes now and am still at 91%.

    I'm very, very satisfied. Thanks everyone!
     

    Attached Files:

  17. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #17
    Great to hear!!! :cool:
     
  18. jotajota macrumors newbie

    Joined:
    Dec 14, 2014
    #18
    gratitude/solution

    hello buddy.

    i dont know how to let you know all my gratitude for your post and your updates.
    at this moment, i´m in a center of 2 macbook (1 retina, 1 non-retina 2011) with same f*king crazy problem. weird is non-retina have same issue with an OEM HDD, it not accepting installation - crazy errors- of any version of OSX in any HDD models or size (came with incredible slow motion (yosemite), and retina not accepting installation of any version of OSX any ssd (came with OEM 128GB samsung ssd and i was upgrading to same samsung 840 EVO 500GB). retina came to me with corrupted OS system.

    after 2 days research, i found your topic, and read about cable issue.
    tried ssd on non-retina MBP and hdd on retina MBP. for my surprise it works. in my situation, last shot, i choose to exchange sata cables between then, and for my much more surprise, workit like a charm!

    thank´s to all you guys, and forum.

    cheers.


    ps: I´m Apple/PC support technician in Brazil and this is my first cable problem. already get kind of everything...almost was saying to retina´s owner to try a recall in B&H because some topics i saw about firmware/ incompatibility in retina MBP and some SSD models before find this one.
     
  19. hallux macrumors 68020

    hallux

    Joined:
    Apr 25, 2012
    #19
    I hate to tell ya, your "Retina" model is not a Retina. All of the Retina MBP's have blade-type SSDs. Even though the 2012 units used a SATA connection the drive from an standard MBP would NOT easily interchange and did NOT have a cable. I just looked at the exploded diagrams of the 13" and 15" Retina MBPs on Apple's service site, no cables and blade SSD on both.
     
  20. guineaphinea thread starter macrumors newbie

    Joined:
    Jan 31, 2014
    #20
    Yeah I thought the Retinas used the blades... Not really sure how, but glad it helped. It's coming up to a year now and I'm typing this on the same cMBP!

    This forum rocks!
     
  21. SadSSDMAN macrumors newbie

    Joined:
    Dec 18, 2014
    #21
    I'm new to MacRumors and SSD upgrading but just couldn't help drool over the Samsung 840 Evo 250 GB when it was just a $100 during Black Friday 2014.

    While I bought the SSD, it's been 18 days and I'm still scared to upgrade my Macbook Pro non retina (Mid 2012). With horror stories like these, I'm confused as to what to do.

    I don't want to go and fess up $100 to some "Authorized Apple Dealer" if it just takes a lot of time.

    So should I do a clean install with a Usb or should I clone?

    ----------

    See this is what I don't understand

    Why did the SATA cable work for the old HDD but not the SSD?

    If it was a faulty SATA cable, shouldn't it have not worked for either?
     
  22. l.a.rossmann macrumors 65816

    l.a.rossmann

    Joined:
    May 15, 2009
    Location:
    Brooklyn
    #22
    Hard drive cables on Apple 13" Unibody laptops fail all the time. They're all sh/t. From 2009 through 2012. They are the only laptop in six years of work I have ever had to replace this piece on, and regularly enough that I bought 500 of them. I'm down to about 17 left now, but still going steady.
     
  23. guineaphinea thread starter macrumors newbie

    Joined:
    Jan 31, 2014
    #23
    Don't be worried about it all. If your current drive is working great, chances are everything will be great with the SSD.

    Do the upgrade and enjoy how fast your Mac can be.

    I would personally do a clean install with a USB or using internet recovery. I doubt anything would go wrong if you didn't, but clean installs are just that...clean. It's still up in the air on how necessary it is, but I use Trim Enabler. It forces OS X to enable the TRIM algorithm on the drive as if it was an Apple SSD.

    Neither the factory 500GB drive nor the SSD would work on the faulty cable. Both are 6Gbps drives. When I started having issues, I put an old Seagate (3Gbps) drive in and it worked fine. The fact that it was a slower drive that negotiated at a slower speed didn't make as full of use of the cable and thus allowed for a higher fault tolerance in the cable.
     
  24. SadSSDMAN macrumors newbie

    Joined:
    Dec 18, 2014
    #24
    As you said, I tried it out, and sure enough the SSD is running smoothly!

    Now for the Firmware, do I have to disable TRIM for the firmware update
     
  25. johnh57 macrumors regular

    Joined:
    Jul 6, 2011
    Location:
    Montana
    #25
    I'm far from being an expert, but from what I've learned so far- disable trim, but when it asks if you want to enable kext signing say no. Enabling / disabling trim is easy. Turning kext signing off and on seems to be more problematic.

    I enabled kext once and the trim enabler got confused. Ended up having to delete trim enabler and reinstalling it.
     

Share This Page