MacBook Pro optical out won't turn off

Discussion in 'Digital Audio' started by ldambergs, Oct 2, 2006.

  1. ldambergs macrumors newbie

    Oct 2, 2006
    Somehow the optical digital audio on my MacBook Pro has turned itself on, and I can't turn it off. It's pretty annoying because it has disabled the speakers. When I stick headphones in, they work just fine (they're regular, analog headphones), but as soon as I take them out the red light inside the port turns back on, and the analog audio opition disappears from the sound preference pane. All that appears in preferences is Digital Out.

    Has anyone else had this problem? How do I get my speakers working again?

  2. scottlinux macrumors 6502a


    Sep 21, 2005
    Trash the file ~/Library/Preferences/

    Then restart and see if that helps.
  3. ldambergs thread starter macrumors newbie

    Oct 2, 2006
    Actually, it's a hardware problem with the combined analog/digital optical port. I found a thread on the Apple Discussion site ( ) that discusses it. Apparently, one solution is to stick a toothpick in the port and fiddle around until some sensor latch releases. Scary. Good thing I'm still covered under Applecare - this laptop's going in for some servicing!
  4. zimv20 macrumors 601


    Jul 18, 2002
  5. stoddad macrumors newbie

    Jan 14, 2007
    Toothpick and 10 seconds

    I experienced this very same problem. The toothpick working in about 10 seconds. I think the sensor is at the base (bottom of the minijack) hole.

    I was surprised it worked so easily. I hope this isn't going to be a continuing problem. It is good to have my speakers back.
  6. caseystrom macrumors newbie

    Sep 10, 2006
    This is caused by being hard on the interface, bad plug inserted, bending plug, or just being forceful. Ive had my left I/O board replaced by apple twice because of this issue.
  7. mohthom macrumors newbie

    Feb 22, 2007
    No, it's not. It's caused by shoddy Apple design. Take it to the apple store and they'll replace the audio IO board (with a better design jack and output preamp). That's what happened with me . . .

  8. bwburrell macrumors newbie

    Sep 5, 2007
    The toothpick method worked for me. My AppleCare is expired now, so I'm out of luck. Good thing the Random Shut-off issue started happening like two weeks ago...guess I can pay for my own logic board :)
  9. pguerrer macrumors newbie

    Nov 17, 2008
    Pic for the curious

    My MBP got this issue today. I must admit that in my case it's probably due to defective hardware: I once pulled the cable accidentally to the side, which could have damaged the latch sensor :(
    Luckily the toothpick worked like a charm.
    In any case I've attached an image showing how it was before fixing it:

  10. oYx macrumors regular

    Sep 2, 2007
    does the audio output still sound hissy after the replacement? i think the hiss alone is reason enough for apple to do a replacement.
  11. macrumors member

    Oct 1, 2002
    had the same problem, and toothpick worked like a charm. hope it doesn't happen again - though if it does, I'll just take it to the retail store before my applecare runs out..
  12. silverspoon macrumors newbie

    Nov 9, 2009
    toothpick and repair

    Hi, I used a toothpick and also had results. Although on reinserting audio plugs (headphones, lineout etc) the problem occurs again, resulting in additional toothpickery! Would anyone suggest that this a replaceable reason for apple store? I am still under warranty.

  13. juanomatic macrumors newbie

    Jan 6, 2010
    New York City
    I have a unibody MacBook Pro 13" (Mid-2009) and I am having the same problem. I didn't have a toothpick handy so i used a twisty-tie. Too bad they didn't fix this problem.
  14. davejohnusrname macrumors newbie

    Jan 15, 2010
    toothpick worked!

    Had this same dumb problem. Hasn't been easy to get the headphone lead into and out of the jack for the last 2 yrs and this "Digital Out" on all the time thing occurred recently.

    I didn't even know my computer had digital out!

    Anyway the toothpick worked very easily.

  15. teklikethis macrumors newbie

    Jun 6, 2008
    i couldnt find a tooth pick, so i used a qu-tip without the cotton on it. it worked! anything that saves a trick to the apple store is fine by me :)
  16. ritcho macrumors newbie

    Feb 19, 2010
    got it fixed using paperclip w/tape

    Had the same audio problem...

    Symptoms: no audio from internal speakers, pressing volume control buttons displayed a circle with bar thru it, system prefs showed digital output... and original headphones worked fine and controls worked when plugged in..

    First thought it may have been software problem or settings adjustment or my addition of third party software as i had recently downloaded and been using Boxee alot lately and maybe something got out of whack.

    I read the previous posts and saw the toothpick workaround..

    Saw the red light glowing inside the headphone jack... which i learned was the optical digital output.. which i didnt use but im guessing somehow got triggered..Possibly because i was regularly plugging and unplugging a connection to my audio for my Boxee setup..

    Since i was at work, no toothpick available... I took a paperclip, wrapped plastic tape around the end (didnt want to put metal inside the sensors inside there) gave a bit of a tape overhang on end of paperclip and bent that portion of the tape so it had a tiny 90 degree crook at the end of the tape...

    Wiggling didnt work.. pushing in and out didnt work.. then turned and and made a circle inside the best i could thinking i could reset a sensor.... when i pulled out the paperclip.. saw the red light had gone off... looked at my tape wrapped paperclip.. and low and behold.. dirt/dust was stuck to it...

    Everything back to normal.. volume control works.. internal speaker now detected in system prefs etc... all is good in the world :)
  17. ImpostorOak macrumors member


    Dec 27, 2009
    I've had this problem for over a year and it sucks. I've tried sticking just about everything in there to no avail. I didn't get Applecare, so I'm out of luck there.

    The problem is actually caused by a little switch inside the jack that gets stuck. When you stick in an audio cable, it pushes the switch down. If it's an analog cable, the end is made of metal. If it's optical, the end is made of plastic. If the switch is pressed down, the computer checks to see if the plug inside is metal or plastic based on conductivity. When it gets stuck and nothing is in there, it thinks an optical cable is plugged in since the switch is down but nothing conductive is in there. That's why it works with headphones or external analog speakers.

    I might try the tape thing. It's about the only thing I haven't tried and I don't really have $450 to replace the logic board.
  18. chabadav macrumors newbie

    Mar 4, 2010
    digital out active but red LED not always showing

    I had this problem yesterday after installing Windows 7 on Bootcamp partition (probably coincidence but thought worth mentioning).
    However, although I see the red LED light only occasionally in the headphones socket of my MacBook Pro (2008), my volume control is constantly in background and locked in digital out mode. Headphones work normally if I insert them.
    I have tried inserting a few objects (toothpick, pen ink holder, matchstick) but to no avail.
    My MBP is 1.5 years old and I have no applecare so repair not an option for me.
    Any additional tricks anyone can think of?

  19. rsm20 macrumors newbie

    Dec 23, 2009
    I used a earbud thing, and cut the top of and stuck it in, ull feel it kind of attach to something inside, pull the cotton bud out and the red light flickers, well it did with me, i was happy as larry when i saw it lighting up:) now i can go buy my optical cable, although it only flashed twice? is that what its supposed to do?:confused:
  20. regainchris macrumors newbie

    Apr 12, 2010
    This is total bulls#@t, after spending 4 grand on a macbook pro I shouldn't have to stick fricken toothpicks into it! I've had my mac for about a month now and havent done any forcing or shoving of any kind, so why is this happening?:mad:
  21. krazykk macrumors newbie

    Apr 13, 2010


    Thanks for the information asbout the switch, after reading that I felt more comfortable about how to release the switch. A co-worker has had this issue for a long time and I told him I would try and figure it out. Once I realized I had to try and lift up the switch every thing worked great!

    What a great place for help!


  22. page2bwritten macrumors newbie

    Apr 21, 2010

    Who would believe that on a $1699 macbook this worked! I have had nothing but problems with my macbook since the warranty expired! I still love mac, but this answers my question.. Why did the applecare plan go from $69.00 (a year and a half ago) to $299.00. Now I know! :mad::apple::mad:
  23. reikoshea macrumors newbie

    May 24, 2010
    Simply mind boggling that this works.

    Thanks to the guy who recommended a qu-tip instead of a toothpick. I dont have any toothpicks either.

    Drove me nuts for the better part of an hour trying to figure out why my built-in speakers disappeared from the preferences menu.
  24. Naariah macrumors newbie

    Nov 10, 2008
    It Works!!

    Thank you so much guys.

    I used the tooth pick method and it worked wonders.
    I still have a couple of years on my apple care, so if it happens again I'll take it into an Apple store.

    But for now.... It Works!!
  25. valna macrumors newbie

    Jul 7, 2010
    no internal speakers

    this is what worked for me.

    just insert your headphone/earphone plug into the audio-in jack (next to the earphone jack) then remove. the sound comes back and the "prohibit" sign (circle withe the diagonal line) disappears.

Share This Page