MacBook Pro Persistent Crash

Discussion in 'macOS Sierra (10.12)' started by Anime1215, Apr 27, 2017.

  1. Anime1215, Apr 27, 2017
    Last edited: Apr 27, 2017

    Anime1215 macrumors newbie

    Joined:
    Apr 26, 2017
    #1
    Hello everyone,

    For the past week, my MacBook Retina, 2.2 GHz Intel Core i7, 16 GB 1600 MHz DDR3, and it's running on macOs Sierra 10.12.4 (I bought it back in July 2015) has been crashing every day. I use to run InsomniaX to keep the MacBook from idle sleep when I close the lid. I since deleted the app thinking it was the cause the crash. However, this past week, when I open the lid, I see a dark screen and I'm force to hold down the power button and force restart my laptop. After I log in, I get this display message of:

    "You shut down your computer because of a problem"

    Initially, a kernel panic report was generated and it was determined that and adobe plugin was causing this particular kernel panic report and has since been deleted, but the crash still persists with no kernel panic report generated. Here is the kernel panic report at pastebin: https://pastebin.com/UYa9Bkja


    After a crash happened I went into console reports and found this under system.logs:

    Apr 26 18:11:46 Michaels-MacBook-Pro loginwindow[110]: objc[110]: Class TIMLog is implemented in both /System/Library/CoreServices/Menu Extras/TextInput.menu/Contents/SharedFrameworks/TextInputUI.framework/Versions/A/TextInputUI (0x10b17e858) and /System/Library/CoreServices/Menu Extras/TextInput.menu/Contents/SharedSupport/TIMCore.bundle/Contents/MacOS/TIMCore (0x10853db10). One of the two will be used. Which one is undefined.

    Apr 26 18:11:47 Michaels-MacBook-Pro com.apple.xpc.launchd[1] (com.apple.imfoundation.IMRemoteURLConnectionAgent): Unknown key for integer: _DirtyJetsamMemoryLimit

    Apr 26 18:11:47 Michaels-MacBook-Pro com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.user.501): Service "com.apple.xpc.launchd.unmanaged.loginwindow.110" tried to hijack endpoint "com.apple.tsm.uiserver" from owner: com.apple.SystemUIServer.agent

    Apr 26 18:12:17 --- last message repeated 1 time ---

    Apr 26 18:15:35 Michaels-MacBook-Pro com.apple.xpc.launchd[1] (com.apple.quicklook[547]): Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.apple.quicklook

    Apr 26 18:50:31 localhost bootlog[0]: BOOT_TIME 1493247031 0

    Please keep in mind that nothing is attached to the laptop except my apple watch. I tried resetting the SMC and NVRAM and nothing.

    I made the liberty on asking on the Apple forums but it has since gone silence. Here is the link to the apple forums:

    https://discussions.apple.com/message/31675177#31675177



    The most recent crash happened again last night. Here is what the system.log states:

    Apr 27 00:35:47 Michaels-MacBook-Pro com.apple.xpc.launchd[1] (com.apple.quicklook[979]): Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.apple.quicklook

    Apr 27 00:39:58 Michaels-MacBook-Pro com.apple.xpc.launchd[1] (com.apple.quicklook[985]): Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.apple.quicklook

    Apr 27 00:39:58 Michaels-MacBook-Pro syslogd[50]: ASL Sender Statistics

    Apr 27 11:54:52 localhost bootlog[0]: BOOT_TIME 1493308492 0

    There is another post in this same forum and it was suggested from another user to run a program called EtreCheck. The EtreCheck report is at the follow PasteBin website.

    https://pastebin.com/RHv84T3N

    Here is the EtreCheck report during safe mode:

    https://pastebin.com/4PDWeZuS

    Thank you for anyone who has an idea what's going on. I'm growing concerns that the crashes are occurring daily and are going to potentially ruin my laptop.

    With sincerity,
    Anime1215
     

    Attached Files:

  2. Lunder89 macrumors regular

    Lunder89

    Joined:
    Oct 16, 2014
    Location:
    Denmark
    #2
    Just as a simple test. Try to create a new partition on your harddrive, and install macOS on it.
    If the new installation works right, the easiest thing might be to just reinstall the Mac.

    I can find several other similar crash logs around, but no solutions.
     
  3. Anime1215 thread starter macrumors newbie

    Joined:
    Apr 26, 2017
    #3
    I put the computer in safe mode last night and it did not become unresponsive and it did not require me to force restart it. What does this mean?
     
  4. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #4
    First off, Anime1215, if you're going to use this as the main thread to help solve your issue, you should put a post in the other thread with a link to this one saying this is now the thread you're going to be using.

    If you no longer have issues in safe mode, then it's likely one of the Launch Agents or Launch Daemons that's causing the issue - or just plain luck. (The only non-Apple kernel extension you have is not being loaded.) I think I mentioned in the other thread that you should take the time to find the instructions on how to remove Citrix and Malwarebytes and then do it - it's probably one of these that are causing an issue. Run the computer in a normal fashion and see if you have problems.

    There's another recent post in this forum from somebody who also has a wake from sleep issue (doesn't sound exactly the same as yours) who also had Citrix (a different version) - on a 2015 MBP. So maybe it causes an issue or there's some issue with it and certain OSX versions.
    https://forums.macrumors.com/thread...not-a-third-party-nvram-or-smc-issue.2003314/

    In looking over your EtreCheck report again, I noticed that you don't have Time Machine configured. If you're doing regular backups, you should consider doing so.
     

Share This Page