MacBook Pro USB Modem Problems

Discussion in 'MacBook Pro' started by freaky773, Jul 23, 2012.

  1. freaky773 macrumors newbie

    Joined:
    Jul 23, 2012
    #1
    I bought a brand new Macbook Pro last week, and have also bought a 3g USB modem to go with it. Plugged it in and nothing happened, didn't mount or show up in finder at all. Plugged it into my old Macbook (mid 2008, running lion) and it worked perfectly, software installed etc. I then moved back to my new Macbook Pro and plugged the modem into the Apple USB keyboard which was plugged into my Macbook Pro and it worked, software installed, connected to the internet, but it wont work if its plugged straight into the MacBook Pro.

    So essentially the modem works straight into a USB port on an old macbook, but doesn't on a new macbook pro, but does work when plugged through another USB device (I have only tested on a apple keyboard as I dont have a USB hub on me)

    Anybody got any ideas? I would love to get it working normally so i can take it travelling, no point taking a keyboard with me!
     
  2. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #2
    Use System Profiler to see what the system reads when the 3G Modem is plugged.
     
  3. freaky773 thread starter macrumors newbie

    Joined:
    Jul 23, 2012
    #3
    Doesn't show up in system profiler as far as I can tell
     
  4. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
  5. freaky773 thread starter macrumors newbie

    Joined:
    Jul 23, 2012
    #5
    Just did, they said they can't help as they wont troubleshoot accessories like this.
     
  6. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #6
    Call the manufacturer. Have you tired rebooting?
     
  7. remenechelli macrumors newbie

    Joined:
    Aug 15, 2012
    #7
    I have the same problem here, in Brazil.
    You find a solution?
    My mac OS is 10.8 (mountain Lion) and no modem in the finder or is mountain.
    Thanks!
     

Share This Page