Macbook pro won't boot.....

Discussion in 'MacBook Pro' started by godspeed, Sep 24, 2006.

  1. godspeed macrumors member

    Apr 8, 2006
    Ok, in Thailand on holiday so no Apple support help out here.

    I have macbook pro, 2.16 2gb ram and bootcamp is not installed. I put it to sleep last night having been listening to some tunes on itunes (I also watched a DVD).

    Today when I tried to start the macbook pro this is what happened.

    1) the light on the front of the macbook pro glows faintly (constant)
    2) the DVD spins (there is a movie in the mbp)

    The macbook pro does not get past these 2 stages, it does not start up, the screen stays black, the keyboard does not respond, however the processors do get warm when it is left in this state for a period of 5 minutes or more.

    I have tried the follwing,

    1) held down the power button until it beeps - it didn't beep
    2) reset the pram - nothing happened
    3) tried starting in safe mode - nothing happened
    4) tried holding down the mouse button upon starting - nothing happened
    5) held down cmd option and the other one before starting - nothing
    6) held the macbook pro up to see if the dvd would fall out - it didn't

    It seems like the keyboard is not responsive, the caps lock and num lock lights are not working. No power is coming out of the usb ports, when I try to start the mbp I plugged my ipod in and it didn't charge.

    Can anybody please help me with this one, I am in Thailand for another 3 weeks and seriously need to get this sorted. Thanks in advance.... ;0
  2. elisha cuthbert macrumors 6502a

    elisha cuthbert

    Feb 25, 2006
    take out the battery and try and start it off power and see if that works or try it visa versa
  3. godspeed thread starter macrumors member

    Apr 8, 2006
    Tried to start from mains only with battery out and vice versa. Still the same problem. Also depleted the battery fully and tried to start off mains but no success. :(

    ...... I think it is doomed, I think it is caught in some conflict after being put to sleep, I'm guessing the sleep information is stored in the pram but I am not able to flush it. I wish I has access to a usb keyboard but I doubt this would help either. Anybody know how to get a dvd out of a macbook, I heard rumor of a pinhole but could not find it on the mbp.... I think that maybe if I could get the dvd out it maight boot...

    cheers in advance
  4. NJuul macrumors 6502

    Mar 15, 2006
  5. godspeed thread starter macrumors member

    Apr 8, 2006
    Thanks mate, tried all of it. After putting a business card in the DVD tray the DVD eventually came out. This however was the only thing that was fixed, the macbook would still not boot up and just hung. Then I thought it might be the ram so I took some out and switched slots etc... but this did not work either. I am stumped... anybody else?????? please
  6. wawman macrumors newbie

    Dec 22, 2006
    I have a MBP that is doing the same thing. It will not start. When booted the front light comes on and the CD drive turns, but then hangs.

    It has done this the last two days. I have done everything mentioned above. I have been able to get it to boot twice when I have left it charge completely up it will boot.

    What might have started this was my wife got a new cell phone, a Razor w/ the mini USB plug. I plugged it into my MBP and let it charge the phone over night. The next morning I closed the lid, took it to work and it wouldn't boot.

    Godspeed, what did you finally end up doing?
  7. cokebottle macrumors newbie

    Dec 25, 2006
    Another Mac with same problem

    Hey folks. I have MacBook Pro 15"/2GHz/2GB with same problem. I tried everything, nothing helped. :(

    Any idea?
  8. BlackFrog macrumors newbie

    Feb 28, 2007
    Hi everyone!

    So I got my macbook pro back in september sometime and instead of spending $400 on 2gb of RAM from apple, I got 'macbook pro compatible' RAM made by munchkin from for about half the price. So I install the RAM and everything works great for about two months. Then I start getting the exact same problem everyone else describes. I press the power button to turn it on and I get the cd drive 'engage'-ing sound and the sleep light comes on dimly but the screen stays dark and there is no mac sound or anything. I try all sorts of crap but nothing works. Then I try removing my RAM. It just so happens I kept the original stick of 512mb that it shipped with so I try just that stick and it boots perfectly.

    Right now it's running with the munchkin ram (2 sticks of 1gb each) and booting fine. Every now an then however, it won't boot and I have to either swap one of the sticks for the apple ram (sometimes works) or replace both sticks with just the apple one (always works). So I carry around the apple RAM stick in my laptop bag just in case. I've gotten funny looks when I have to use it because I tell people I just decided to upgrade my ram and its usually at the beginning of a class.

    Anyways I've also noticed that when it won't boot, the sleep light gets brighter/dimmer as you tilt the screen more/less. With the screen almost closed, the sleep light is very dim, however with the screen fully open, it is much brighter (tho not as bright as it should be). Very, very weird, I'm just wondering if anyone else gets this too.

    BTW the machine is a MBP 15"/2.0GHz CD/2GB.

  9. BlackFrog macrumors newbie

    Feb 28, 2007
  10. ctdesing macrumors newbie

    Feb 22, 2008
    Same problem fixed

    Hi, i have been with the same problem with my Intel Macbook, I got a 2GB RAM Intel Macbook. i was reading this forum and i started to check my hardware. I swap my ram and i keept with first one, the another one, that was pre-installed by apple too, i took off my macbook. Then i turn on my macbook and i keept pressed the start button for a while. The my macbook start working correctly. Thank you all for your help. Right now i don't know what to do with my other ram, but my macbook still working without it. So thank you all for your help and i hope you still posting in this great forum.

    Macbook User.
  11. Mac-Princess macrumors newbie

    Oct 9, 2008
    MacBook Pro won't Start

    Ok, so I just got a MacBook Pro 15"/2GHz/2GB, and on the second day I saw these dark vertical line appear on the screen. From the bottom, dark then more faded towards the top.

    Sometimes it's there, other times not? I just shut down and restart. Do any of you know what's causing this?:confused:

    Also, I had my MacBook Pro on (I think) all night, without the charger. I was watchin' a DvD... so I figured that it wasn't openin' because it had no charge...anyways, I put it on the charger this morning and when I got back home it wouldn't still start up. Is there another way to start up my laptop? (the start button doesn't appear to be jammed/ stuck or anytin' )
    Thank You
  12. Ivana Machova macrumors newbie

    Jan 4, 2009
    Godspeed please help!

    Godspeed, could you please tell me how did you fix your MBP, i know it was almost 2 years ago, but do you remember what you've done. I have the same issue except, I'm not in Thailand... Thanks!
  13. ballpein macrumors newbie

    Jan 14, 2009
    I'd like to hear how this was resolved, too. From what I gather, my MBP will need service.
  14. jharju macrumors newbie

    May 3, 2005
    I also have exactly same problems that Godspeed had. My MBP is little over two years old without AppleCare so it would be great to know how problem was fixed. If it is going to cost hundreds of euros there's no idea for repairing.

    I send PM message but haven't got reply.
  15. van nilla macrumors newbie

    Feb 6, 2009
    You are right: the usb ports are all dead: I tried a usb-mouse/keyboard and even external dvi-video monitor.

    And I agree that corrupt pmu and/or pram info that cannot be reset properly may be to blame, for reasons explained below.

    There are lots of saavy yet frustratded folks on the internet with very similar symptoms finding that none of the usual fixes (pmu/smc, pram) work. One said:
  16. emheenan macrumors newbie

    Jan 15, 2008
    I too have exactly these same symptoms, and can reproduce all the same responses as in the above post.

    Right now a new MBP looks like the only option - my local Apple reseller (no Apple store in the city where I live :( ) has quoted me $100 and a three week wait just to tell me what they think is wrong with it, let alone fix it (by replacing the logic board no doubt).

    If anyone has solved the problem by less drastic means I'd love to hear from you.

    Has anyone tried disconnecting the NVRAM/PRAM (or whatever it's called) battery to force a restart? I don't have a Torx screwdriver so can't open up my MBP to try.

    Alternatively - does anyone know what the lifetime of the NVRAM/PRAM battery is? If I leave my MBP sitting without the main battery in and disconnected from the power, will the NVRAM/PRAM battery eventually go flat (and thereby reset the PRAM)? If so, does anybody have an estimate of how long that might take?
  17. buthidae macrumors newbie

    Oct 21, 2008
    This is happening for me too on my 2.53GHz unibody. I tried an SMC reset to no avail yesterday, but then a few minutes later on the phone with Applecare we did another reset and it worked.

    Today it's failing to start again, and it's Sunday, so all the shops are closed. Killer.

    edit: OK, I let it do it's thing with the light on for a while and it drained the battery. Gave it some power, and hitting the power button brought it back out of deep sleep. Every time this has happened it's booted back out of that state despite no legit reason for it to have done that... Very weird
  18. emheenan macrumors newbie

    Jan 15, 2008
    Were you having exactly the same symptoms as those described above? I.e., do you have:

    Power light on lid catch comes on.
    Power on to DVD drive and HDD, but not to LCD.
    No power from USB
    No response from Keyboard - i.e. capslock light and numlock light do not come on when pressed.
    No grey screen and no boot chime.

    I'd love to think I'm just not doing the SMC reset properly, but I've been trying for three days to no avail. It's clear that something is going fundamentally wrong in the Open Firmware, so that I can't reset the PRAM on boot. I've tried replacing the RAM, but that didn't work either. I've tried booting without the (main) battery installed (i.e. only off main power) but that didn't work. I also tried letting the battery run down to empty and booting, as you said you did, but that has done nothing either.

    What irks me is that there was absolutely nothing that predicted this - I was using my MBP like normal, it started behaving a little strangely (Safari hung and force quit wouldn't work) so I tried to Log Out - it logged most of the way out then sat there looking like it had hung, so I did an Open Apple-Option-Reset, and then nothing... It was dead.

  19. buthidae macrumors newbie

    Oct 21, 2008
    Yep, to the letter. Does your power light go to full brightness if you close the lid?

    I had another chat with Apple today but we didn't get it going again. I tried a few more things including powering cycles with an external display connected to no avail.

    I've managed to get it going again for now and I'm doing an overdue Time Machine backup before going any further! I'm not really game to put it to sleep either :D

    To get it moving again I removed the power adaptor and battery, and the harddrive as well, and then did an SMC reset by holding down the power button for >10 seconds. I then plugged the power adaptor back in and left the battery and HDD disconnected. Then I powered on while holding the power button until the sleep light turns off briefly, and then comes on and flickers rapidly, and then turns off again. It then chimed and booted to a grey screen! You may want to try that step with the option key held down as well, option+power got me going one time last night but it may have been a red herring.

    After the chime and grey screen it was going no further, but there is definitely something working, as a single tap on the power button did a clean shutdown. Several times, I then replicated this sequence of turning off and on again. Once satisfied, I removed the power plug, reconnected the battery, HDD and power, and hit the power button to a happy chime and sweet success.

    With the proviso noted above, of course ;)
    I need my laptop reliable for a couple of days but I'll see how it goes with sleeping again soon :)

    edit: Also, no Open Firmware in Intel Macs afaik - EFI replaced it's functionality :)
  20. emheenan macrumors newbie

    Jan 15, 2008
    The power light was going to full brightness when I closed the lid, so yes - I was getting that symptom too. However, I've since removed the hard disk and tried what you suggested below...

    ... but it didn't work. Without the hard disk plugged in I'm not getting any power light on the front at all. Maybe I broke something when I opened it up? Now when I hit the power button I hear the superdrive power up then nothing - no fans (and obviously, since it's been removed - no hdd)

    Option-power didn't do anything for me either.

    I've now officially written it off as cactus. I ordered a new MBP today, and will try putting the old hdd in an external case. While it's nice to have a new laptop, I'm not a very happy camper at the moment - the damn thing was only 18 months old.
  21. Coelacanth64 macrumors newbie

    Feb 9, 2009
    Syracuse, NY
    Similar but different

    My MBP won't boot; period. No lights, no spinning DVD drive. Nothing.

    However, it doesn't happen every time I push the power button. If I persist, so far it has eventually booted. But, I can find no common reason why.
    And, after it starts it runs perfectly; both in OSX & XP.

    I've reset the SMC & PRAM. I checked the battery; it's fine. And, I tried to start up both on wall power & on battery power. No difference.

    So far it has always eventually powered up. So far.

    Therefore, the questions are these:
    1.) anybody else ever have this happen?
    2.) could it be the power button itself?
    3.) has anybody ever replaced a power button? I have already upgraded my wireless card & HDD, so opening it up is no big deal.

    Any help is more than welcome.


    I went to my local Apple Store & spoke with one of their techs. Very professional.
    He suggested I replace the upper case. I can do that.

    However, after I came home I had a thought (rare enough), so I tried a little experiment. I discovered that, if I leave the machine off for 5 minutes or more, it starts just fine. Every time.

    Could this be a temperature/heat related matter? And, if so, what could the heat be affecting??
  22. buthidae macrumors newbie

    Oct 21, 2008
    Ahh, tragic. Sorry to hear that those steps didn't work for you! :(

    If anything, the best thing I could probably offer is that I found persistence to be the key in getting it to booting stage. I accidentally let it sleep again today but managed to get it booting again relatively easily.

    It really feels like something isn't getting written to EFI properly on sleep and it's freaking out the wake or power-on cycles... I'm not sure what else it could be!

    edit: I think I've managed to fix it - it was acting up again but once booted I started poking through console and removed the Cisco VPN software, which was the only thing being logged during shutdown. After that, I did a permissions repair which fixed a single file to do with CUPS, and now it seems to be behaving perfectly :D
  23. emheenan macrumors newbie

    Jan 15, 2008
    Curious - I also have/had Cisco VPN software installed...

    My 'crash' actually happened when, or after, I did a 'Logout', rather than a reboot. I don't think I'd ever done a Logout before - since I have only one user on the MBP I would normally reset or shutdown rather than logout. It hung after going to a blue screen (i.e. after closing down Aqua, or whatever it's called now) but before coming up with a login prompt. Then I did a hard reset (Command-Ctrl-Power), and it died.

    However, as I said above, I simply can't get it to start up at all, with or without the hdd. I'll give it another go tonight, but I'm not holding my breath.

    PS: Regarding my now non-functioning sleep light - when I closed up my MBP after removing the HDD, I didn't reconnect the cables at the front right of the machine to the HDD cable. I have an inkling that one of those two clips might be for the sleep light on the front of the MBP, and that's why mine isn't working?
  24. loragen macrumors newbie

    Feb 15, 2009
    macbook pro won't boot

    This is my first post, so my apologies if this has been said elsewhere. It may or may not be relevant to this thread. I have had similar (can't boot) problems with my Intel MBP (OS X 10.5.1, 2.2 Ghz Core2Duo, stock 2GB ram) for about a year. I still don't know what's wrong, but in my case, whenever it won't boot (about half the time), I can always boot it by:

    1. Continuously press the power button for 10 seconds.
    2. Release briefly, then press again briefly.

    It always boots, and gives me an error: "OSX shut down unexpectedly" even though, every time, I did a proper shutdown, sometimes logging off first, sometimes not. This suggests to me (new to Mac) that a process may have been left unterminated upon system shutdown that is preventing the system response to the "on" button until a forced power shutdown.

    If it matters, the only thing not stock about my MBP is that I have VMware Fusion loaded, but I never use it.
  25. Coelacanth64 macrumors newbie

    Feb 9, 2009
    Syracuse, NY
    Getting desperate

    I'll have to try that specific sequence.

    To date this is the situation:
    1.) Machine always starts in AM, runs fine all day; in either OSX or XP.
    2.) Machine always starts after exactly 18 minutes of shutdown.
    3.) Once started and allowed to load completely it will not shutdown via the power button.
    4.) After full boot the machine will power down normally using the keyboard or mouse click commands.

    I installed a new Seagate, 320GB HDD over Christmas, but this anomaly only began about 2 weeks ago.

    Any info is more than welcome. This is my business laptop & I'd hate to have to ship it to Apple for an extended period. I'm beginning to think that this may be more involved that a simple power button issue. Perhaps, a bad capacitor or diode?


Share This Page