Macbook stops charging after 1 minute

Discussion in 'MacBook Air' started by Jessemedcalf, Jun 21, 2016.

  1. Jessemedcalf macrumors newbie

    Jessemedcalf

    Joined:
    Jun 20, 2016
    #1
    #1
    My MacBook Air has suddenly stopped charging properly. When I plug in the charger, the light goes on, green at first for about 2 seconds, then to orange as per normal. However, after about 1 minute, the light goes off and it stops charging.
    If I unplug the charger at the wall and plug it back in, or disconnect the two halves of the power adapter and reconnect them, it starts charging again. It will once again stop after about 1 minute.
    I can do this indefinitely and the same thing happens every time, this has been going on nearly 2 weeks.
    I have tried multiple plugs and multiple chargers - same thing happens on all.
    I've reset the SMC (multiple times) with no luck.

    This is massively frustrating, please if anyone has any solutions let me know.
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    If you've tried different genuine chargers and the issue persists, the problem can only be with your Mac and likely hardware.

    As a starting point, you can try to clean the MagSafe connector on your MacBook Air with isopropyl alcohol, as they do tend to get a little grimy. However from your description I don't think this will do the trick.

    Going on the assumption that there has been no liquid or physical damage to the machine, and the battery is still in good condition with cycle count/no errors in the operating system, I suspect the DC-in board will need replacing. Luckily this is a seperate part and not soldered to the Logic Board, so the parts wouldn't cost an arm and a leg.

    If you have an Apple Store local to you, they'll be able to diagnose the issue free-of-charge and let you know the financial damage before you go ahead with anything.
     
  3. Jessemedcalf thread starter macrumors newbie

    Jessemedcalf

    Joined:
    Jun 20, 2016
    #3
    Thanks for the suggestions! Do you think there's any hope in resetting the PRAM before I go into the apple store?
     
  4. Agent47 macrumors member

    Joined:
    Jun 11, 2014
    #4
    Absolutely reset the PRAM first. This is likely what is wrong.
     
  5. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #5
    Be sure to check your connector on the MBA isn't filled with dirt or similar. You can try and clean it.
     
  6. RedTomato macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #6
    Have you tried a hardware diagnostic test? How to reboot into the low-level diagnostic system & run some tests:
    https://support.apple.com/en-gb/HT201257

    Some tips on cleaning the Macbook power port from Apple:
    https://support.apple.com/en-gb/HT203207

    Other tips - have you tried a different power outlet? Maybe at a different house?:
    http://osxdaily.com/2014/02/04/magsafe-wont-charge-mac-fix/

    This one a bit oddly suggest pre-warming the power-transformer:
    http://www.hightechdad.com/2013/12/17/macbook-air-not-charging-try-this-amazing-fix/
     
  7. deepak.miglani1995 macrumors newbie

    Joined:
    Jul 21, 2017
    #7
    Any solution man? I am facing the exact same issue.
     

Share This Page