macOS 10.12 Sierra Unsupported Macs Thread

Discussion in 'macOS Sierra (10.12)' started by redheeler, Jun 13, 2016.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. bob_s macrumors newbie

    bob_s

    Joined:
    May 14, 2017
    #4676
    I'm having troubles getting the target mac (early 2008 Mac Pro, quad-core) to boot from the USB in order to do the install. Have tried two different USB sticks, have tried 2 different Sierra installs (one from Apple store, one from the link on the dosdude site).

    In system prefs, I can set the USB drive as the startup drive, but when the Mac actually reboots, it boots from the existing El Capitan 10.11 system. If I start up with the option key, I just get my SSD and a couple of recovery disks, no USB.

    Have done the CSRUTIL disable. USB stick directly in the front panel of the Mac, no hubs in the way.

    And, this may or may not be related, but if I put one of the USB sticks (loaded with Sierra) into my MB Air already running Sierra, it seems like it hangs---doesn't want to boot. Or else it's just incredibly slow to boot.

    Both sticks were freshly formatted, GUID, journaled.

    Any ideas on what might be happening? And dosdude/collin---*please* put a "donate" paypal button on your site.
     
  2. Adrian97c, May 14, 2017
    Last edited: May 14, 2017

    Adrian97c macrumors newbie

    Adrian97c

    Joined:
    Jun 29, 2015
    #4677
    I have an early 09 mini, upgraded with OWC datadoubler SSD & 8G of ram... but this thread has 900 pages.. I randomly starting jumping to pages & found this post. What must I do to upgrade from el cap? I have stock wifi chip, so there is a way to upgrade it?

    From what I gather (very confusing thread) There are 2 diff ways to get sierra, a tool & a script? Which is the most recent easiest method? Or is it just 1 tool to get sierra, then a choice of 2 methods to get updates?
    Also, any links detailing how to upgrade my wifi card to the compatible version?
     
  3. dosdude1 macrumors 6502a

    dosdude1

    Joined:
    Feb 16, 2012
    #4678
    It sounds like the machine is not even detecting the drive at all... Are you using a USB port built into the machine (not a hub)? And check the version of your Install macOS Sierra app... It needs to be version 12.4.06 to work with the latest version of the tool.
     
  4. bob_s macrumors newbie

    bob_s

    Joined:
    May 14, 2017
    #4679
    --- Post Merged, May 15, 2017 ---
    Not in a hub, directly into the front port of the Mac Pro. I've downloaded both the latest Sierras from both the link on the dosdude site, plus directly from the store using my MB Air. I've freshly downloaded the patch software each time. Have created the USB sticks from two different machines (my Air and the target machine).

    The target mac recognizes that the thumb drive has an OS on it, and I can pick it in the system prefs to boot from. But when it actually boots, it falls back to the El Capitan system on the target machine.

    I'm stumped too... ;-)
     
  5. tribalhere10 macrumors member

    Joined:
    Sep 14, 2015
    #4680
    it show :

    Downloading "SUVMMFaker.dylib"...
    Password:
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 8656 100 8656 0 0 11448 0 --:--:-- --:--:-- --:--:-- 11449
    Backing up "com.apple.softwareupdated.plist"...
    This file already exists in the backup location. Overwrite? (y/n): y
    Continuing backup...
    Downloading "com.apple.softwareupdated.plist"...
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 2075 100 2075 0 0 4038 0 --:--:-- --:--:-- --:--:-- 4044
    Restarting softwareupdated...
    \nWould you like to refresh available updates now? (y/n): y
    Software Update Tool

    Finding available software
    No new software available.

    Operation complete.
     
  6. fischersd macrumors 68040

    fischersd

    Joined:
    Oct 23, 2014
    Location:
    Kitchener, Ontario, Canada
    #4681
    You really only need to concern yourself with the instructions referenced on page 1 of the thread - dosdude1's patched installer, running the post-install after the update is complete.
    It should incorporate Czo's software updater patch - which will allow you to get OS updates, even though an unsupported Mac.

    And you can find the BCM943224PCIEBT on Amazon to replace your network card in your '09 mini. If you have an old expired credit card kicking around, they make a good mounting bracket. While that will get you networking ability, don't expect the enhanced continuity features in Sierra to work with the card.

    @tribalhere10 - If you don't have the technical abilities to solve some of your own problems, you REALLY shouldn't be running beta software. Czo already pointed you to a page explaining how the different catalogs work for MAS/Software Updater - if you can't understand that page, you really shouldn't be running beta MacOS when you aren't actually enrolled in the beta.
     
  7. Machist macrumors newbie

    Machist

    Joined:
    Mar 9, 2016
    #4682
    Mac Pro updated to 10.12.5.
    No problems!

    You need to run NightEnabler again.
     
  8. Adrian97c, May 15, 2017
    Last edited: May 15, 2017

    Adrian97c macrumors newbie

    Adrian97c

    Joined:
    Jun 29, 2015
    #4683
    Thx for reply! So although post one has 3 diff tools listed, it's since been updated as 1 'all-in-one' solution? Cool!

    Ok so I won't be able to unlock my Mac via Apple Watch? :( ugh what other reason to have Sierra lol

    Off topic/sort of, but Few years ago Apple released airdrop on Mac/iOS, but my mini didn't allow (iPhone to 09' Mini), think it was because of Bluetooth chip... any workaround threads for that?
     
  9. evertjr macrumors newbie

    evertjr

    Joined:
    Oct 24, 2016
    #4684
    updated my macbook 5,5 to 10.12.5. No problems so far
     
  10. tribalhere10 macrumors member

    Joined:
    Sep 14, 2015
    #4685
    @fischersd , after a whole night going through czo's cat. url, finally manage to have 10.12.5 and itunes 12.6.1 download..... sorry that i'm not a IT tech person. thanks czo's for the cat.url.
     
  11. Jack Neill, May 15, 2017
    Last edited: May 15, 2017

    Jack Neill macrumors member

    Jack Neill

    Joined:
    Sep 13, 2015
    Location:
    San Antonio Texas
    #4686
    MB 5,2 Updated easily to .5, however I've lost brightness control.

    EDIT, found Brightness Slider app from MAS, it works to adjust the brightness
     
  12. nandor690 macrumors regular

    nandor690

    Joined:
    Jun 25, 2011
    #4687
    You'll have to do that after every update. I manually patched mine and just keep a copy of the frameworks in a folder
     
  13. z3rodivide macrumors newbie

    Joined:
    May 17, 2017
    #4688
    Hi guys,

    Restarted my MacBook today and the trackpad and keyboard are completely unresponsive.
    I found this repliy on this thread :
    I'm trying to reboot in Recovery to disable SIP but if I start with CMD+R the Mac stops with "prohibited" signal.

    Also, there is a way to create a usb support containing only the "post-install patch" ( without downloading the whole installation package from MAS) ?

    Thanks a lot
     
  14. alcafly macrumors newbie

    Joined:
    Dec 20, 2016
    #4689
    Hi, I also had this problem after the latest update with my MacBook Pro 2009 5,5. Touchpad & Keyboard unresponsive, CMD+R = prohibited, single user mode crashing....

    To solve it I downloaded the latest Sierra installer, the latest Sierra Patch Tool and remade the USB. I then booted from this usb (I had an issue recognising after booting so I had to unplug and replug it until it mounted). Then disabled SIP with terminal, applied patch again, and forced cache rebuild on reboot.

    Hope this helps!
     
  15. Czo macrumors regular

    Joined:
    Dec 30, 2008
    Location:
    Debrecen, Hungary
    #4690
    To make recovery bootable you need to run the patcher for the recovery only.

    The cache rebuild processes all kext on your Mac (including all 3rd party kexts (example: RS232-USB Adapter or Elgato's Eye TV and many-many 3rd party hardware)), however if you patch it again, the patch copy over the stock cache without 3rd extensions and drivers.

    So, to fix it, firstly patch the recovery, disable sip and rebuild the cache. Next time if you reset the PRAM (why?!) you need to boot only the recovery.

    Maybe, we need to modify the #1 comment to keep peoples informed about the PRAM reset and the danger behind it.
     
  16. z3rodivide macrumors newbie

    Joined:
    May 17, 2017
    #4691
    Thanks for the quick reply :)
    I'm downloading the Sierra installer to try
     
  17. thekayman macrumors 6502

    Joined:
    Oct 23, 2014
    #4692
    Had the same problem on early 2009 MBP 5,1. I created a bootable USB with latest Sierra .5 using the too in post #1, booted from the USB and simply reinstalled the system following the instructions. Problem fixed.

    This problem appeared after a SMC / PRAM resets (after installing new battery). Didn't know it's related.
     
  18. Sofad macrumors member

    Sofad

    Joined:
    Jan 24, 2006
    #4693
    Updated MacBookPro5,1 (Late 2008) to 10.12.5 (from 10.12.4)
    20 mins, no Problems
     
  19. z3rodivide macrumors newbie

    Joined:
    May 17, 2017
    #4694
    Ok, problem solved :)

    I was stuck with several usb sticks not booting (stopping to boot at half of the progress bar), the problem was the version of the Sierra installer I was using (10.12.0) with the latest version of the Patch tool (which instead requires the latest MAS released version : 10.12.5). Maybe it would be good to clear this in the first post ?

    Thanks :)

    I also have the problem with lost brightness control, but I saw other users already reported it :(
     
  20. agentkamoteh macrumors newbie

    Joined:
    May 7, 2017
    #4695
    when i clicked on the nightenabler this message shows
     

    Attached Files:

  21. Czo macrumors regular

    Joined:
    Dec 30, 2008
    Location:
    Debrecen, Hungary
    #4696
  22. foxlet macrumors regular

    foxlet

    Joined:
    Aug 5, 2016
    #4697
    Just hold the Control key, click on the item then Open, and the app should open.

    You also have to disable SIP before running it (you can enable it after).
     
  23. ersatze macrumors newbie

    Joined:
    May 19, 2017
    #4698
    Hello! Just wanted to share my experience with 10.12.5 - i have a macbook white 5,2 which worked perfectly with 10.12 this far (up to 12.4,except that trackpad issue but it wasnt that important). But when i updated,first my keyboard stopped working and the trackpad was unresponsive but it fixed itself when i rebooted. But i too have lost brightness control,and the Brightness slider app works but have to reset it every time it exits from sleep,so i created new installation and erased everything and installed 10.12.4 which for some reason did not fix the brightness problem (it was a clean install!), and now i am back at 10.11 latest and everything works perfectly:). So for now i wont be going back to 10.12. Not complaining or anything - the tool worked flawlessly and the update enabler/script too worked without a hitch,but i really need the normal brightness slider :)
     
  24. cizko, May 19, 2017
    Last edited: May 19, 2017

    cizko macrumors newbie

    cizko

    Joined:
    May 19, 2017
    #4699
    I installed 10.12.4 on an iMac8,1 from a patched stick and everything worked flawlessly. I had some minor brightness fluctuation issues of the built-in display afterwards but nothing to worry about really. Then I updated to 10.12.5 via App Store and lost audio volume control over the internal speakers afterwards. They always blast on full volume now. :D Is there any chance to re-run the patch for that issue manually? I do not have the patched stick with me here today.

    Anyway: Great job, dosdude1 (you seriously rock, dude) and also Piker Alpha and Foxlet for giving us Night Shift!
     
  25. Adrian97c macrumors newbie

    Adrian97c

    Joined:
    Jun 29, 2015
    #4700
    Guys this weekend I'm going to empty my stick & put the most recent installer(10.12.5?)/patch on it, so I can finally attempt this on my 09 mini. I'm confident I can pull it off.... silly question tho, I don't want to lose my data/settings, so this will go just like all my previous macOS upgrades right, nothing gets deleted? (I just gotta make sure I skip step 5/6).
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page