macOS Mojave (10.14.6) - Update failed. Volume is readonly and SSD is broken.

Discussion in 'macOS Mojave (10.14)' started by gaussblurinc, Aug 4, 2019.

  1. gaussblurinc, Aug 4, 2019
    Last edited: Aug 4, 2019

    gaussblurinc macrumors newbie

    gaussblurinc

    Joined:
    Aug 4, 2019
    #1
    Hi!

    Brief
    1. MacBook Pro ( Mid 2015, 15'' ).
    2. Update 10.14.5 -> 10.14.6 failed.
    3. SSD is broken ( adapter of this non-original SSD is broken ).
    4. Error - OS can't unlock partition because it thinks that this partition has FileVault protection, but there is no FileVault protection.
    5. All possible options in Recovery mode are failing.
    5.1. Recover from Time Machine. -> Failed
    5.2. Reinstall OS. -> Failed
    5.3. Erase/First Aid partition. -> Failed.
    5.4. Set startup drive. -> Failed. ( Bless can't be completed ).

    History
    I tried to install new patch 10.14.6 on my MacBook Pro ( Mid 2015, 15'' ).

    At the end of update I saw question mark folder. I looked up in Internet and saw solution in rebooting and login in into recovery mode.

    I did it and at the next restart Installer GUI showed error: "Function not implemented." I open Logs and looked for this error. OSInstallElement entry showed this error. Also I observed errors that "vm cannot be placed at path: disk is readonly".

    However, I see that this partition has title OS 10.14.6 in System Preferences -> Choose boot device.
    Also, in Logs various entries said that this volume with OS 10.14.6 is valid but it is readonly.

    My next steps in Recovery.

    1. Set startup drive - error: "bless cannot be done on this disk".
    2. Try to Recover from Time Machine - just error after I chose destination partition to restore.
    3. Try to Reinstall OS - I can't choose any device, because they are greyed and GUI suggest to choose another device.
    4. Try to Erase this APFS partition in Disk Utility - error: fsdk_apfs /dev/disk1_2 - Permission Denied. Error 66.
    5. Try to First aid this partition - unknown error.
    6. Try to First aid when this partition is disconnected - error: fsdk_apfs /dev/disk1_2 - Permission Denied. Error 66.

    What should I do in this situation?
    Could I somehow restore functionality of this SSD even with downgrade to 10.14.5?

    Service center suggests to replace my SSD ( 1 TB ) by original one. It is so expensive. I would like to know alternative solutions.

    Thanks!

    UPD
    Service center said that this SSD has adapter ( it is not original SSD ). This adapter is broken. There are two possibilities:

    1. This update will break any adapter from non-original SSD.
    2. This update broke only this adapter as an old adapter ( Previous owner uses this Mac for 3 years, so, maybe lifetime of this SSD-adapter is over.
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    Your best bet may be to find an Apple (used) "factory-original" drive, put that in, and see if you can get the MBP running again...
     
  3. Mac Hammer Fan macrumors 6502a

    Mac Hammer Fan

    Joined:
    Jul 13, 2004
    Location:
    Belgium
  4. Ruggy macrumors regular

    Joined:
    Jan 11, 2017
    #4
    Have you checked the prices of SSD recently? They were really expensive but the prices have plummeted.
    A 1tb Samsung 860 EVO costs about $150.
    And how much of the 1tb was used? Maybe it was only 40% full and a 500mb would actually be enough.
    It looks like a new SSD is the way to go considering that's what the service centre told you.
     
  5. gaussblurinc thread starter macrumors newbie

    gaussblurinc

    Joined:
    Aug 4, 2019
    #5
    No, I don't. I think that guys at service centre should do it, no? If not and it will help...

    Yes, 500 gb SSD will be enough.
    Are you talking about original SSDs? I thought they are only shipped in new Macs. ...

    Do you have experience with custom SSDs for this models (models in 2013 ... 2015 I suppose)? Are they robust?
     
  6. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #6
    Once again, I will ask:
    - do you still have the factory-original drive?
    - if so, have you tried putting it back in, and then seeing if you can revive the MBP that way?
     
  7. gaussblurinc thread starter macrumors newbie

    gaussblurinc

    Joined:
    Aug 4, 2019
    #7
    No, I don't have factory-original drive.

    I'm still waiting for a call from service centre. Their supplier will get adapters and original SSDs soon.

    1. Try adapter and this SSD.
    2. Try new custom SSD.
    3. Try original SSD. ( new or used )

    It is a plan for this MacBook for now.
     
  8. MIKX, Aug 9, 2019
    Last edited: Aug 9, 2019

    MIKX macrumors 65816

    MIKX

    Joined:
    Dec 16, 2004
    Location:
    Japan
    #8
    I fixed a friend's non-working SSD in an older MBP by replacing the SATA drive cable = common problem in older MBPs.

    The cable shown in this video.


    EDIT : I also placed some soft insulating tape under the cable as it goes over a right-angle step. These cables a a little fragile. it's about a 30 minutes job for me .. . 45 for you ( carefully ) :D
     
  9. gaussblurinc thread starter macrumors newbie

    gaussblurinc

    Joined:
    Aug 4, 2019
    #9
    Not so old :)
    I guess that I can't touch guts of MacBook Pro 2015.

     

Share This Page

8 August 4, 2019