macOS Mojave (10.14) - Bugs and bug fixes

Discussion in 'macOS Mojave (10.14)' started by xflashx, Jun 4, 2018.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. dwfaust macrumors 601

    dwfaust

    Joined:
    Jul 3, 2011
    #526
    Noticing that after the update to 10.14.3 (and watchOS 5.1.3), I can no longer unlock my iMac with my watch...

    Does anybody at Apple test this crap? True, it's not the end of the world, but remember, it's the little foxes that spoil the vine.
     
  2. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #527
    is everyone having this problem? if so, apple dropped the ball. if not... perhaps start a thread about it, ask for help. much more productive than simply complaining. or try google...

    perhaps: https://www.macobserver.com/tips/quick-tip/apple-watch-stopped-unlocking-mac-fix/
     
  3. nortonandreev macrumors 6502a

    nortonandreev

    Joined:
    Jan 11, 2016
    Location:
    Sheffield, United Kingdom
    #528
    It works here. Did you try to disable/enable this feature? I would also try to restart the watch.
     
  4. dwfaust macrumors 601

    dwfaust

    Joined:
    Jul 3, 2011
    #529
    After multiple restarts of my iMac and my Watch, it is once again working...
     
  5. Braeside macrumors newbie

    Joined:
    Feb 2, 2019
    #530
    Apologies if this question has been addressed somewhere on these forums. I have searched but couldn't find anything. I have recently upgraded to 10.14.3. I now find that I cannot install any software which does not appear on the App Store. I get the error message "Ossystem error 99999". Prior to this I have visited Sys Prefs>Security and Privacy and unlocked the lock and clicked "Open Anyway". I then get the 99999 error. I have searched online for the past few days but only one fix could be found which didn't work - sudo cp /var/db/.SystemPolicy-default /var/db/SystemPolicy (PW and Restart). I was able to use Win 7 via VMWare Fusion to use the windows version of the SW I wanted to use but this is not a practical workaround long term.

    The SW in question: makeMKV, DVD Extractor, XLD and some others I cannot now remember. However, Tag Editor from the App Store worked fine.

    There appears to be no other issues with Mojave. All works OK. I have run all available system checks and repair routines including fsck -f in Single User Mode. I have also cleared PRAM.

    I am an experienced Mac user but this problem has me stumped.
     
  6. macintoshmac macrumors 68030

    macintoshmac

    Joined:
    May 13, 2010
    #531
    How about a total reinstall? Diagnosis and isolation will probably take longer than a fresh install.
     
  7. Braeside macrumors newbie

    Joined:
    Feb 2, 2019
    #532

    Yes, this is what I was thinking of doing when I find sufficient spare time as it takes a while to do a clean install. I usually clean install major OS updates. In this case I updated my iMac from High Sierra to Mojave using software update - looks like it was a big mistake. I notice that 10.14.4 beta is in the testing phase now so I will most likely wait for that to be released and see if it fixes the problem. In the meantime I have a MacBook Pro running High Sierra which has no problem running the SW I mentioned in my original post. Such is life! Thanks for your reply...
     
  8. Leonelli macrumors newbie

    Leonelli

    Joined:
    Sep 22, 2016
    Location:
    Peru
    #533
    After the new update I can no longer download purchased books on Apple Books. Error: "Unable to download" and "1004". Already tried rebooting both the MacBook and the router but no luck. Anyone else experiencing that?
     
  9. Braeside macrumors newbie

    Joined:
    Feb 2, 2019
    #534
    Just installed the 10.14.3 supplemental update and, hey presto, no more problems with the Ossystem error 99999!!! All previously mentioned SW installs without problem provided access to 3rd party developers is allowed in Sys Prefs>Security and Privacy. The user has to manually "Allow" access which is the point at which things went pear-shaped previously. So thanks Apple for fixing a very frustrating problem.
     
  10. itsmilo macrumors 68020

    itsmilo

    Joined:
    Sep 15, 2016
    Location:
    Europe
    #535
    I cannot take screen shots on my admin user. Like it does the shutter sound but nothing appears on my desktop. On my friends 2nd (non-admin) user account it works fine. Any idea why?
     
  11. HenryAZ macrumors 6502a

    HenryAZ

    Joined:
    Jan 9, 2010
    Location:
    South Congress AZ
    #536
    Have you tried searching for "Screen Shot" to see where it is ending up? You can change the location easily enough in Terminal. I prefer mine to go into my Downloads folder:

    defaults write com.apple.screencapture location "/Users/henry/Downloads/"

    followed by:
    killall SystemUIServer
     
  12. Ritsuka macrumors 6502a

    Joined:
    Sep 3, 2006
    #537
    You can change the destination in the Screenshot app.
     
  13. Blue Hawk macrumors regular

    Joined:
    Dec 18, 2017
    Location:
    Germany
    #538
    Is it a bug that I cannot see how many space the system takes? The „About my mac“ section where you can see your storage usage is wrong too.
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page