macOS Mojave (10.14) - Bugs and bug fixes

Discussion in 'macOS Mojave (10.14)' started by xflashx, Jun 4, 2018.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. CoastalOR macrumors 68020

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #501
  2. PumpkingKing macrumors member

    PumpkingKing

    Joined:
    Nov 8, 2018
    Location:
    QLD, Australia
    #502
    I have a bug where I cannot share any photo using the in-photos sharing button or right clicking in photos to the sharing tab. Anyone else got that?
     
  3. kingspat macrumors newbie

    Joined:
    Oct 3, 2012
    #503
    Anyone else having problems with Command + H and Command + Option + H shortcuts?
     
  4. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #504
    i live & die by command-H, and working fine here on both my macs...
     
  5. vasim macrumors member

    vasim

    Joined:
    Mar 12, 2017
    #505
    After the last update my Macbook Air 2015 delays to boot more than before (it stops thinking in the middle of the bar :) ). Can you think about a fix?
     
  6. stevemiller macrumors 68000

    Joined:
    Oct 27, 2008
    #506
    came here to ask something similar. on each 10.14.x update the startup of the computer has felt quite... clunky on my 2018 MacBook Pro.

    on 10.14.0 it was an absolute mess with the login interface running at something like 5fps and worse was input blocking the password field until it finished this choppy slow animation.

    10.14.1 make this slightly less choppy? and they moved a long loading progress bar from before the login screen to after. I'm not sure what they thought that helped.

    10.14.2 they seemed to realize they're incapable of making smooth animations anymore and simply got rid of them. long login bar that bumps you to a boot-screen-style black progress bar half way through remains.

    pretty sad that this regression has happened, as I've never before seen login screen issues quite this bad, and these are supposedly super fast ssd's and a dedicated t2 chip helping the boot process. I'm pretty sure I remember 10-20s reboots from way back on my first ssd powered Mac in like 2011. and for those questioning how often you see a reboot login screen... I'd punt that question right back, as I don't go out of my way to reboot, but somehow the glitchiness of Macs these days seems to demand it.
     
  7. vasim macrumors member

    vasim

    Joined:
    Mar 12, 2017
    #507
    You are right. I am comparing my Mac mini mid 2011 with High Sierra. After the update is much faster than my MacBook on boot. What the hell is going on?
     
  8. user1234 macrumors 6502a

    user1234

    Joined:
    Mar 3, 2009
    Location:
    Sweden
    #508
    I made a separate thread but I have two annoying bugs.

    1. Mojave won't remember my second display wallpaper setting anymore (had this issue in High Sierra, then Mojave fixed it. Now I reinstalled Mojave with 10.14.2 and started fresh, and the issue is back)

    2. This
    Skärmavbild 2018-12-12 kl. 09.49.55.png
     
  9. stevemiller macrumors 68000

    Joined:
    Oct 27, 2008
    #509
    I double checked my gut and its every bit as bad as I thought:

    2011 MacBook Pro running Sierra: 20s boot to desktop
    2013 MacBook Pro running Sierra: 19s boot to desktop
    2018 MacBook Pro running Mojave: 38s boot to desktop

    and for the record I'm pretty positive it was even faster back in mountain lion days. is it the t2 chip running encryption on everything thats cutting speed in half?
     
  10. -=Hot|Ice=- macrumors newbie

    Joined:
    Sep 27, 2018
    #510
    Found a bug and what is causing it. The login battery percentage is different than what is displayed when you log into the computer. I took it to the Apple Store and the cause seems to be FileVault. The issue goes away when FileVault is disabled. It's really annoying. I hope Apple fixed this bug.

    2018 13" Macbook Pro. I have a 2015 Macbook Pro that has the same issue.
     
  11. Dr. James macrumors member

    Joined:
    Nov 17, 2012
    Location:
    Ecuador
    #511
    10.14.2, I still can't block a contact through macOS.
     
  12. AxtonRacing macrumors newbie

    Joined:
    Dec 21, 2018
    #512
    I am having the same issue; thanks for trying the 're-install the OS' option as that was my next move. I will not go through that pain now.
    Were you ever able to resolve this issue?

    I have three OSX system with only one of them using Mojave. After the Mojave update, I was not able to use iMessage on that system, but now I cannot use iMessage on any of the OSX system, only the iPhone.
     
  13. NoLoginUser macrumors newbie

    Joined:
    Dec 15, 2018
    Location:
    Belarus
    #513
    I have the same problem
     
  14. fcortese macrumors demi-god

    fcortese

    Joined:
    Apr 3, 2010
    Location:
    Big Sky country
    #514
    It may have been due to my old Apple Thunderbolt LCD Display. I got the 27 inch LG 5K display and the issue seem to resolve itself. Apple Support ran a whole bunch of tests while i was waiting for the new display to arrive and thought that something with my Apple Time Machine was triggering the kernel attacks and shutting down the computer. But once I swapped the new display for the old one, everything went away and resolved itself. A heck of an expensive way to solve the problem but I had already decided to get the newer 5K display since my. older one was getting very long in the tooth.If you call Apple Support make sure you ask immediately for a senior tech specialist. That's what I did after about the 3rd call to try to solve the problem. He had me run a special test once I showed him screen shots of the kernel attack reports.
     
  15. Rendergroup macrumors member

    Rendergroup

    Joined:
    Dec 13, 2009
    Location:
    Perú (South America)
    #515
    Instead of sending an Email signed with a personal certificate and it sends as attachment smime.p7s

    Something is wrong, never happened this in previous OSX versions.
    Hope some Apple guys take care of this.
     
  16. nortonandreev macrumors 6502a

    nortonandreev

    Joined:
    Jan 11, 2016
    Location:
    Sheffield, United Kingdom
    #516
    I’ve been having an issue for quite some time. I am not sure when it started, but probably it’s been there since 10.14.2 (and is also present on 10.14.3 beta). Sometimes, a red dot appears at edges of a window, most often when using Safari. I guess it’s an issue related to the graphics driver, but it’s present on both my MacBooks - Pro 2017 and pro 2018.
    I think I haven’t seen it on my iMac tho.
    It’s nothing major, as it disappears when I move the window, but I was wondering if anyone has noticed it.
     
  17. Mannaerts macrumors member

    Joined:
    Dec 2, 2010
    Location:
    Belgium, Antwerp
    #517
    My Mini 2018 won't detect my Acer display when it's booting up, it's connected with a USB-C to DP cable.
    So i thought that putting the mac on 24/7 without getting it into sleep mode would solve it, but now my Mac won't respond at my Magic Keyboard unless i connect it first with the cable.
     
  18. dauber, Jan 2, 2019
    Last edited: Jan 4, 2019

    dauber macrumors regular

    dauber

    Joined:
    Jan 10, 2012
    Location:
    Chicago
    #518
    Ever since upgrading my MacBookPro to Mojave, I've not been able to add my Canon MX922 (an AirPrint printer) as a printer. In the Printers & Scanners prefs, it shows up as Canon MX920 series as a Bonjour Multifunction. Bonjour is enabled on the printer. My wife can print to it remotely via her MacBook Pro running Sierra. I can print to it remotely on my iMac running High Sierra. My iPhone can print to it with no problem.

    Regardless of whether I try with USB or AirPrint, I get message saying "An error occurred while trying to add the selected device. Unable to communicate with the printer at this time."

    I've tried just about every known troubleshooting trick under the sun. I rebooted the printer. I rebooted the MacBook Pro. I even did that weird thing in the Dev Beta 6 thread that says to copy and remove the files in /usr/libexec/cups, reboot, re-add the files, reboot, unplug the printer, etc. Didn't make a difference.

    I looked at /var/log/cups/error_log, and something suspicious is happening: it's showing that it's unable to locate files that are supposed to be in /usr/libexec/cups/daemon -- because there's no such directory as daemon, actually! If I open a terminal and try to "locate", say, cups-deviced, I get a hit, saying it's in /usr/libexec/cups/daemon -- which doesn't even exist! So something is out of sync on the system.

    The upgrade, btw, was a clean install.

    For comparison's sake, I looked at my iMac running High Sierra. In /usr/libexec/cups, I'm getting apple, cgi-bin, driver, monitor, backend, daemon, filter, and notifier. On my MacBook Pro with Mojave, I'm only getting backend, driver, and filter.

    So I think the problem is in those missing directories.

    Is there a solution short of reinstalling the OS again?
    __________________________________________

    UPDATE: I copied the missing CUPS directories from a semi-recent backup, and I can now print again! It appears that CUPS doesn't always fully install in a macOS 10.14.2 clean install.
     
  19. pentool macrumors member

    Joined:
    Jul 20, 2013
    #519
    There are a lot of bugs and glitches that exhibit after I wake up the computer from sleep. Usually, the Mac has to sleep for a few hours (Apple menu > Sleep). When I wake it up, random glitches happen all over the system and in apps. Sometimes these glitches happen randomly and cannot be reproduced consistently. Some of them can be reproduced all the time. This glitches can only be solved by rebooting. These glitches show up on two machines (MacBook Pro, Mini). Both of them had a clean installation of Mojave 10.14.2.

    Examples:

    • Cookies and logins cannot be cleared in Safari.
      • Eg, close the main Safari window, but do not quit. Clear cache, cookies, history. Quit Safari. Open Safari again. Sites that you were logged in, you are still logged in. This causes various glitches with websites. Eg, on YouTube, you cannot do account related functions because even though it is indicated that you are logged in, the account dropdown has no account related menu items. You need to reboot to remedy.
    • Many times, when you receive a photo in Messages, it is not possible to save or drag it to the Desktop. If you do manage to drag it to the Desktop, it is displaying the same image. Double-clicking on an image inside Messages does not open it.
      • Eg, if you drag 2+ images to the desktop and try previewing them using Quick Look or double clicking them, they are all the same images.
    • When you preview multiple media files (audio/video) in Quick Look in full screen, the media control bar at the bottom will be cut off, due to the presence of the progress bar. This can be reproed every time without putting the Mac to sleep first.
      • Eg, select a few media files (audio or video). Press the SpaceBar to open them in Quick Look. Maximize the Quick Look window to full screen. Play the audio/video. Move the mouse to have the control bar show up. The top portion of it will be cut off.
    • Quick Look Index Sheet will not scroll in full screen mode if the mouse cursor happens to be in between images.
      • Eg, select a few images (the number of images need to be more than can be fit on a full screen window, so that they can be scrolled). Press the SpaceBar to open them in Quick Look. Maximize the Quick Look window. In the control bar, select Index Sheet. Now try scrolling the page. It won't scroll if your mouse cursor is over the background color of the window. The images only scroll if the mouse cursor is over an image. This can be reproed all the time with a mouse scroll wheel or a touchpad.
    • When you double click an image in Quick Look Index Sheet, it crashes.
      • This happens randomly and does not always happen.
    • Spotlight cannot find indexed files.
      • I have a file in my Documents folder which I constantly use. It is a Numbers document and called 'Animation Search sheet.numbers'. When I press Cmd+SpaceBar to open Spotlight and type the full name of the document, it does not show up in the search results. Even if I specify to search for file name only (name:animation search sheet) the file is not found. I have re-indexed the machine twice so far and have all Spotlight media/file types enabled in System Preferences. This can be solved after rebooting.
    • In the Mail app, the number of flagged/deleted item counts are incorrect.
      • Eg, I have 5 flagged items in the 'Flagged' folder, but the item count only indicates 1. This issue seem to date back YEARS.
    • When I select a different desktop background image, after logging in/out the original system background image will briefly flash before the selected one appears.
    • When I SINGLE clicked on the name of a file, it became editable immediately (as opposed to selecting the file first and THEN selecting its name to edit it. After editing the file name and pressing Enter, the editing did not go away. Eg, regardless how many times I pressed Enter to indicate that I am done editing the name of the file, it was still in editing mode and could not complete the editing. So the cursor was always flashing in the file name and never became hilited.

    Most of these issues can be remedied by rebooting, but I find that some of these glitches appear randomly, while some all the time, and mostly after waking up the Mac after a few hours of sleep. They are happening on my MacBook Pro early 2015 and Mac mini late 2012.

    Awful. Just awful!
     
  20. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #520
    there has to be a common denominator, since we're not all experiencing those issues (am fine on my 2 mac, both on mojave); some app you're running on both? a system enhancement-type app? see if you can break that down, to what they both have in common. it's not simply the OS.
     
  21. VelcroFace macrumors newbie

    VelcroFace

    Joined:
    May 9, 2018
    Location:
    Santa Monica
    #521
    Upgrading to Mojave caused thousands of unrelated e-mail messages to be grouped as a thread in Apple mail. In one instance, there are nearly 17,000 messages grouped as a thread. Only two of those messages are related. These messages are on my Mac, sorted into folders I created.

    I opened a case with Apple, and the technician reported that this is a known issue. I have since downgraded back to High Sierra, which entailed its own set of issues (e.g. OS updates failing, the recovery partition having been upgraded to Mojave). Has anyone else experienced this insane grouping of unrelated messages in Mojave?
     
  22. BigBoy2018 macrumors regular

    BigBoy2018

    Joined:
    Oct 23, 2018
    #522
    I dont get where some of you come up woth this stuff. I have samsung ssd’s running on a half dozen different macs, from the 840 evo series, a few 850 evo’s and also an 860 evo (4 tb).
    They all have run flawlessly for months/ years.
     
  23. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #523
    this is how it works; someone has a problem with their drive, and determines that everyone must have the problem... so boring...
     
  24. pentool macrumors member

    Joined:
    Jul 20, 2013
    #524
    As I mentioned, some issues are random and some can be reproduced all the time. What they all have in common is that they happen (when they happen) after you wake up the machine after a few hours of sleep.

    Both of my machines were clean installed from El Crapitan 10.11.6 to Mojave 10.142 on mid-December never used (High)Sierra. I don't use ANY extensions, system enhancement apps or alike.

    Both machines have 250GB SSD. One of them has 51G used, the other has 47G used, so both have plenty of free space.

    I did notice you are running 10.14.3 which is not available to the public. My experience relates to only publicly released versions (not betas or dev releases) and I am not interested in "experimenting" with beta or pre-released versions.
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page