Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

iToph

macrumors 6502
Original poster
Oct 23, 2014
362
293
Hey guys,

since last week I have some strange add-behavior on macrumors only on my iPhone. Whenever I stay in forums, after 20-30 sec comes an annoying add. Whatever I do, I get redirected to this damned site and cant go back. What is this ****? I'm on MR for years now and never had this problem before.

I totally deleted all internet data in the settings-app, tried to use cellular/other wifis nothing works.

HELP a life without MR is actually not a life anymore :p

IMG_0830.PNG
 
Last edited by a moderator:

AmazingHenry

macrumors 65816
Jul 6, 2015
1,285
527
Central Michigan
Not related to the topic, but consider using the Tapatalk app. You can access the forum quicker and get notifications when someone replies to a thread you're watching.

I can't really recommend this app as I don't use it. I just know a lot of people do.
 
  • Like
Reactions: decafjava

VSG

Contributor
Aug 9, 2014
234
230
Ah damn, those horrendous ads are still not resolved.

Had those two weeks ago, then all was good and now they've returned again (see attachment).
Dear MR-staff, if you want us to support your site by browsing it without an ad-blocker then DO something about those ads!

It's not just that they're obnoxiously annoying because you can't read a single forum post without being redirected. They're potentially dangerous as well.
Last year I became victim of such a surf-by subscription scam and anyone who hasn't disabled mobile payments via their carrier can become one as well.

So please, for the love of Christ, do something or the only way to surf your site will be with a freaking good as-blocker enabled.

Thanks,
VSG
 

Attachments

  • IMG_3476.PNG
    IMG_3476.PNG
    256.1 KB · Views: 212
  • Like
Reactions: AdeFowler

WildCowboy

Administrator/Editor
Staff member
Jan 20, 2005
17,842
1,957
Looking into this again. I assume this just randomly pops up as the bad ad comes though the rotation? Or is there a URL where you can get it to pop up consistently?
 

VSG

Contributor
Aug 9, 2014
234
230
Looking into this again. I assume this just randomly pops up as the bad ad comes though the rotation? Or is there a URL where you can get it to pop up consistently?

Actually, it is happening on all forum threads at the moment. Even this one. Opened without content-blocker and just let the site rest for 10 seconds and got redirected again.
I can't even see an ad that relates to the pop-up.

Ps: screenshot of the redirect-pop-up that happend just now. While scrolling through the site, the only ad I saw was for Lieferando (which is a legit delivery service). I'd guess the ad-provider bundles several ads with one display.
But it's still a PITA and it still makes MR unusable when browsing mobile without an ad-blocker.
 

Attachments

  • IMG_3477.PNG
    IMG_3477.PNG
    138.2 KB · Views: 198
  • Like
Reactions: Scepticalscribe

VSG

Contributor
Aug 9, 2014
234
230
The same redirects are still happening on the forums. I actually had one right now. Is anyone actually looking into this?
 
  • Like
Reactions: patrickgoe

WildCowboy

Administrator/Editor
Staff member
Jan 20, 2005
17,842
1,957
The same redirects are still happening on the forums. I actually had one right now. Is anyone actually looking into this?
We've checked with our main ad provider and they say it's not them. Our other provider is looking into it. I'll follow up for an update from them. Sorry about this... :(
 

VSG

Contributor
Aug 9, 2014
234
230
We've checked with our main ad provider and they say it's not them. Our other provider is looking into it. I'll follow up for an update from them. Sorry about this... :(

Thanks for the update!
I really hope you'll find a solution to this.

Since I'm not the only one who experiences this and I kinda doubt my carrier slips in the ad while I'm surfing, it either is something your ad-providers do - or it's a code inherent in your mobile site (and I doubt the latter).
 

PBG4 Dude

macrumors 68040
Jul 6, 2007
3,922
3,919
Geez, I was coming here to vent about all the "is your bent penis actually diseased???" ads that show on every single page, but your problem is much worse.
 

arn

macrumors god
Staff member
Apr 9, 2001
16,308
5,585
Thanks for the update!
I really hope you'll find a solution to this.

Since I'm not the only one who experiences this and I kinda doubt my carrier slips in the ad while I'm surfing, it either is something your ad-providers do - or it's a code inherent in your mobile site (and I doubt the latter).

I emailed you to follow up with some questions.

arn
 

WildCowboy

Administrator/Editor
Staff member
Jan 20, 2005
17,842
1,957
The problem ad should be gone as of a few days ago. @VSG or any other German users who were experiencing the problem, can you confirm?

Sorry it took so long to track it down.
 
  • Like
Reactions: VSG

960design

macrumors 68040
Apr 17, 2012
3,438
1,307
Destin, FL
I've notified the site admins.
Agreed. The site is nearly unusable. Load times have fallen from nearly zero to over 30 seconds:
Screen Shot 2017-06-19 at 5.12.49 PM.png


I appreciate everything this site has to offer and visit it daily. If there is anything I can assist with, please let me know.
 

VSG

Contributor
Aug 9, 2014
234
230
The problem ad should be gone as of a few days ago. @VSG or any other German users who were experiencing the problem, can you confirm?

Sorry for checking back so late, it's been a hell of a week.
I got the e-mail from your Service Provider and yes, the ad appears to be gone. :)

Thanks again for the assistance!
Best regards,
VSG
 

VSG

Contributor
Aug 9, 2014
234
230
For the sake of Christ, those obnoxious ads are back!

Twice in one session just now.

PLEASE do something about this!
 

Attachments

  • IMG_3495.PNG
    IMG_3495.PNG
    91.3 KB · Views: 250
  • IMG_3496.PNG
    IMG_3496.PNG
    178.3 KB · Views: 206

WildCowboy

Administrator/Editor
Staff member
Jan 20, 2005
17,842
1,957
This should be fixed. VSG has been helping us track down the bad ads.

Hopefully that's the end of it.
 
  • Like
Reactions: annk

LarsN.

macrumors member
Jun 14, 2017
69
19
Hi there,

I still have this Ads (Germany) just in the Forum. Its adressed to „Google User“ and very generic. Very annoying and the Forums are very hard to read.
 

WildCowboy

Administrator/Editor
Staff member
Jan 20, 2005
17,842
1,957
Are German users still seeing the bad ads ("free iPhone" ones that take over the page like the screenshots in this thread) today?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.