Magic Keyboard-Caps Lock problem

Discussion in 'macOS Sierra (10.12)' started by Growler, Nov 18, 2016.

  1. Growler macrumors newbie

    Growler

    Joined:
    Oct 15, 2011
    #1
    I already called Apple Care about this and they have no solution. My Caps Lock will not remain disabled! I have now disabled it for the fourth time in the past ~ one week.

    System preferences/Keyboard/ keyboard tab/ modifier keys button

    1st choice of the four is caps lock. I change it to “no action.” I click "OK"

    Caps Lock is off and does not work but, within 2 to 3 days… it's back working again!
     
  2. davidturner macrumors member

    davidturner

    Joined:
    Jun 10, 2015
    Location:
    Belfast, Northern Ireland
    #2
    I'm having this exact issue, except that it's happening every time I into my account. Highly frustrating. Tried removing preferences files relating to these settings, and restarting the Mac, and have (at the suggestion of local Apple Staff) preformed an NVRAM reset. Neither helped.
     
  3. Growler thread starter macrumors newbie

    Growler

    Joined:
    Oct 15, 2011
    #3
    Mine just turned itself on again 11-20-2016.

    AND AGAIN NOW!

    I wonder if it turns itself on whenever you restart your Mac?


    I will test it now.
    --- Post Merged, Nov 23, 2016 ---
    Yes!

    I again disabled Caps Lock, verified it was indeed OFF & restarted. It again reset to enabled!

    Try it.

    So, the issue is that caps lock reverts to default factory ON setting upon restart.
    Now, the issue is how to keep caps lock off despite restarting your Mac!
     
  4. iphoneuserinyyz macrumors member

    Joined:
    Oct 11, 2011
    #4
    I am experiencing exactly the same problem. Has anyone found a solution?
     
  5. dmrowley macrumors 6502

    dmrowley

    Joined:
    Aug 4, 2010
    Location:
    Dortches, NC
    #5
    I am glad it is not just me. As a very bad typist, I hate the caps lock. Disabling it is one of the first things I do when setting up a new Mac...
     
  6. Growler thread starter macrumors newbie

    Growler

    Joined:
    Oct 15, 2011
    #6
    This did not happen in my 2007 24” iMac which ran; Leopard, Snow Leopard & finally Mavericks. It happens every. single. time. on my new 27” iMac whenever I restart.


    I think more people are not complaining about this bc they are good typists who have no need to disable CL.
     
  7. bsc macrumors newbie

    Joined:
    Jun 14, 2011
    #7
    This happens to me every time after it goes into standby (not sleep). It's not just Caps Lock. I tried changing Control and it changes back after my Mac wakes up from standby. It looks as if the modifier keys get reset after reboot or waking from standby. This only started with 10.12.
     
  8. KoolAid-Drink macrumors 65816

    Joined:
    Sep 18, 2013
    Location:
    California
    #8
  9. 1024724 macrumors member

    1024724

    Joined:
    Apr 4, 2016
    #9
    Been happening consistently for me on two of three machines as well. The Mac mini retains the setting while the Mac Pro and MacBook Pro don't. Mac mini has an OEM Apple keyboard attached permanently but so does the MacBook Pro in a way ;). Does anyone that posted above have Spotlight disabled?
     
  10. Growler thread starter macrumors newbie

    Growler

    Joined:
    Oct 15, 2011
    #10
    10.12.4 update fixes this issue!
     
  11. KoolAid-Drink macrumors 65816

    Joined:
    Sep 18, 2013
    Location:
    California
    #11
    Confirmed: finally fixed in 10.12.4!
     
  12. 1024724 macrumors member

    1024724

    Joined:
    Apr 4, 2016
    #12
    Woohoo! First thing I checked after the update.

    Here's to 10.12.5 breaking it again.
     

Share This Page