Magic Mouse 2 paint/wear

Discussion in 'Mac Accessories' started by blythy, Jun 23, 2017.

  1. blythy macrumors member

    Joined:
    Jun 9, 2005
    Location:
    UK
    #1
    Hi, having just bought a new iMac this is my first experience of the Magic Mouse 2.

    Does the silver paint suffer from the same 'wear' problem as the original Magic Mouse (i.e. over time the silver paint wears off where your finger and thumb rest)? And if so - has anybody found a way of preventing this?

    Thank you
     
  2. ctrlzone macrumors regular

    ctrlzone

    Joined:
    Feb 9, 2017
    #2
    what paint? its aluminium, never heard of this issue.
     
  3. myrtlebee macrumors 68020

    myrtlebee

    Joined:
    Jul 9, 2011
    Location:
    Baltimore-Washington Metro Area
    #4
    That's really strange. I assumed there was no coating at all. I mean, nobody has this issue with other silver aluminum Apple products that I know of. Great, another issue with Apple's material quality to worry about...
     
  4. dwfaust macrumors 68040

    dwfaust

    Joined:
    Jul 3, 2011
    Location:
    I am here => [•]
    #5
    I've been using the Magic Mouse (v1 and v2) since they were first released. I've never had an issue with any finish ("paint" or otherwise) rubbing off of any of them, nor have I heard from any reputable source that there even was an issue.
     
  5. blythy thread starter macrumors member

    Joined:
    Jun 9, 2005
    Location:
    UK
    #6
    I have personally owned two first-gen Magic Mice; both suffered from some form of wear or marking to the finish in the spot your fingers and thumb rest. It cannot be removed and happens after about a year to 18 months of use. Where I work we have 4 or 5 magic mice, all of them have the same problem.

    There are plenty of people reporting it on this very forum: https://forums.macrumors.com/thread...-aluminum-finish-resolved-kinda.875861/page-2
     
  6. dwfaust macrumors 68040

    dwfaust

    Joined:
    Jul 3, 2011
    Location:
    I am here => [•]
    #7
    I never said that it wasn't happening... I sad that I've not experienced, nor have I heard of it. I have 4 of them here (1 MM2, 3 MM1), and no issue.
     
  7. ctrlzone macrumors regular

    ctrlzone

    Joined:
    Feb 9, 2017
    #8

Share This Page