Mail app not receiving new Exchange mails

Discussion in 'macOS High Sierra (10.13)' started by Mollium, Sep 27, 2017.

  1. Mollium macrumors newbie

    Joined:
    Sep 27, 2017
    #1
    Since updating my MacBook Pro to macOS High Sierra, I'm having troubles with my Mail app.

    My work mail, which uses the Exhange feature, does not receive any e-mail while the app is already open.
    All my other mail accounts like Gmail and iCloud work like they always do.
    I have to manually stop the app and re-open it to receive mails on the Exchange account, after which I won't receive any other mails that are sent while it's open.

    Sending them isn't a problem, but earlier today I had an issue where my Mail app would crash if I sent an email with the Exchange account. The mail would still be sent, but the Mail app kept crashing until I turned off the Exchange account in system preferences. This issue has been magically solved and I don't know how I or my system did this.

    If anyone knows what's up, please feel free to leave a comment here.

    Thanks in advance!
     
  2. Mollium thread starter macrumors newbie

    Joined:
    Sep 27, 2017
    #3
  3. IndyBob macrumors member

    IndyBob

    Joined:
    Sep 23, 2012
    Location:
    Indianapolis
    #4
    We are having the same problem with receiving new emails after updating to High Sierra. We use Microsoft Exchange 2010. Worked fine before the upgrade.
     
  4. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #5
    There were a few reports of Mail & exchange issues through the betas, but nothing much has been reported since High Sierra officially dropped. The only upissues I’ve seen folks reporting are of Mail crashing altogether.

    Perhaps it’s server settings? Maybe try completely deleting/disabling those accounts from your machine and then adding them back after a restart of the app & machine?

    Here’s the official Apple support page for EWS accounts in Mail:
    https://support.apple.com/en-us/HT201951
     
  5. iMi macrumors 65816

    iMi

    Joined:
    Sep 13, 2014
    #6
    I had problems with the Mail app on my MacBook. It would quit unexpectedly. Other problems were popping up as well, so I did a clean install. I can report that everything is fine and Exchange email accounts now work for me, but the font size issues persist with the newest version of mail.
     
  6. greezychicken macrumors member

    Joined:
    Apr 23, 2005
    #7
    I'm having numerous issues with Exchange post High Sierra update as well. Mail is slow to download to my work account which is on Exchange and a simple thing such as flagging or unflagging an email takes quite a while to commit changes. Navigating folders also seems sluggish and sending basic emails from the Exchange account takes a while to actually go through to send. None of these issues were present with Sierra and Apple Mail was humming along fine on the previous OS.
     
  7. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #8
    Perhaps delete and rebuild mailbox?
     
  8. Mollium thread starter macrumors newbie

    Joined:
    Sep 27, 2017
    #9
    I made a post about this on the official Apple macOS High Sierra forums. Someone suggested that I tried to setup the same Exchange account on a new user.

    Multiple times I tried to enter my credentials and go through the dialogue of creating such account, but it always gives me certificate-related notifications. I made sure to always trust them, but when I open the Mail app on the fresh user account, there is a triangle with an exclamation mark besides the name of the account folder. When clicked, it keeps telling me something about the certificate and I can click "details", "cancel" and "continue". All three options lead to the same result: nothing changes and I keep getting the certificate notification window.

    On my proper account, the normal Mail app doesn't receive new emails when I'm at work (where the mail server is located) without forcefully closing and re-opening the app. At home, the Mail app doesn't even connect to the server so I don't receive my mails outside of work.

    I installed an alternative application for my mails called "Spark", and with the same credentials etcetera I can now receive my mails again. It's a pity though that I have to download a third-party app to have a fully working mailing program. On macOS Sierraeverything worked like a charm, but after the macOS High Sierra update everything about the Mail app started failing. Hopefully Apple fixes it as a whole, because I loved working with it.

    I really hope there is a solution on the way for this.
     
  9. ingenious macrumors 68000

    ingenious

    Joined:
    Jan 13, 2004
    Location:
    Washington, D.C.
    #10
    Mail on iOS 11 now authenticates accounts with Microsoft, which seems to alleviate many of the issues I was having. I had to downgrade to Sierra using a Time Machine backup in order to get my Exchange account to work again in Mail on my MacBook Pro (under High Sierra, it refused to authenticate). I'm hesitant to upgrade again until I read that High Sierra has incorporated the authentication scheme used in iOS 11.
     
  10. lveryeri macrumors newbie

    Joined:
    Oct 26, 2017
    #11
    I have the same problem. Only rebuilding the inbox or closing and re-opening the Mail app fetches new mail.
     
  11. DaveBromley macrumors newbie

    Joined:
    Dec 13, 2017
    #12
    I'm having the same issue, I have deleted the acct and then reinstalled it into the Mac Mail app, and that worked for a couple of days, but now back to receiving no new mail. This is infuriating!

    Dave
     
  12. Malbers macrumors newbie

    Malbers

    Joined:
    Mar 5, 2018
    #13


    I have the exact same problem. mail.app on sierra with 2 work email systems (one on prem exchange) the other is office365, and a 3rd email with outlook.com - all worked perfect. Love the use of the Mail Drop.

    As soon as I 'upgraded' to high sierra last week, mail.app stopped working, stops 'downloading'. It's useless. I had to install the outlook for mac app to get my corporate email working again, but I don't like using Outlook.

    It's a shame that 11.2 Mail.app doesn't work - complete shame.
     
  13. adamh10 macrumors member

    adamh10

    Joined:
    Mar 20, 2009
    Location:
    Bradford, ON, Canada
    #14
    Are you still looking for a solution to this?

    For my personal small business I use Office 365 for Business with Exchange email, and my solution for the Mail app was simple - enable 2-step verification and create an app password in the Office 365 Admin Portal. It took some tweaking to work properly, but it absolutely works. I'm not sure why it wouldn't work without 2-step on, but as soon as I turned on 2-step verification I was able to get it to work flawlessly. You may also need to make sure your domain settings are configured appropriately in the Office 365 Admin Portal (for those using Office 365 Business) to direct Exchange Mail appropriately. There are many guides on how to do this.

    My other business email account - that I don't manage, but is from the company I work for that uses their own Exchange Server - I also was able to set it up as an Exchange Account in Mail by entering my company's server settings just like I would in Outlook and voila! It works as it should. Perhaps your company needs to enable third party apps - maybe they had made a change to the permissions they provide, for those having issues after upgrading to HS? That is, if it isn't your business/you manage your Exchange server yourself.

    If you have difficulties, I would suggest making a Genius Bar appointment? They do support assistance with setting up email, including Exchange.

    One thing to note - if your business uses G Suite (Google Apps) for Exchange, you cannot set up the email as "Exchange" in macOS - you can only do that in iOS. In macOS, G Suite email users must set it up simply as a "Google" account and utilize an app password (if 2-setp verification enabled) to do so. Sadly, G Suite/Google do not support Exchange email outside of mobile devices.

    Cheers!
     

Share This Page

13 September 27, 2017