Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Sweener88

macrumors 6502
Original poster
Apr 27, 2006
426
1
Im EVERYWHERE!
Hi everyone!
Im having an issue with Mail. Iv had it set up to receive my hotmail emails however after i upgraded to leopard it wont remember the password. ill type in the correct one and even check "remember this in keychain" yet 2 minutes - a few days later it will ask for it again. its incredibly annoying as sometimes it asks for it repeatedly every few minutes!

Any ideas?:confused:
 

colourfastt

macrumors 6502a
Apr 7, 2009
989
896
Hi everyone!
Im having an issue with Mail. Iv had it set up to receive my hotmail emails however after i upgraded to leopard it wont remember the password. ill type in the correct one and even check "remember this in keychain" yet 2 minutes - a few days later it will ask for it again. its incredibly annoying as sometimes it asks for it repeatedly every few minutes!

Any ideas?:confused:

I have 3 hotmail accounts and am having the same problem. I don't think it's a Snow Leopard problem as this just started happening a couple of weeks ago and I upgraded to SL as soon as it came out, hence more a problem with the Live service. Anyone have any ideas yet?
 
Comment

Jolly Jimmy

macrumors 65816
Dec 13, 2007
1,357
3
Changing the frequency mail checks for new mail from 5 to 15 mins fixed it for me.
 
Comment

Aniday

macrumors regular
Jan 27, 2009
145
3
Changing the frequency mail checks for new mail from 5 to 15 mins fixed it for me.

Do you have to enter the password every 15 minutes? >_>

But yeah. I’ve had the same problem. It used to be where it would ask when I start up mail and it would remember it until I quit again... now it just randomly asks multiple times a day. Annoying as hell.
 
Comment

Macnoviz

macrumors 65816
Jan 10, 2006
1,059
0
Roeselare, Belgium
It's not a snow leopard problem, I haven't upgraded yet and I started getting this problem a few days ago. It's annoying as hell, but I don't really want to give up the 1-minute e-mail check frequency. It's nice to be able to get mails in almost real-time. But if the problem persists and there are no other options, I guess I'll have to go to 15 minutes.
 
Comment

XheartcoreboyX

macrumors 6502a
Jul 3, 2007
753
0
I get that a lot myself, it's set to 1 minute check, for the same reason Macnoviz mentioned.

I sometimes get it with gmail as well..

btw leopard.
 
Comment

cmcbridejr

macrumors 6502a
Sep 28, 2007
509
1
Alpharetta, GA
Glad to know I'm not alone.

This just started happening to me and I can't seem to find a resolution anywhere.

Mail keeps reporting that the password is being rejected, though it is the correct password. My guess is that Mail is trying to provide the password before the server responds.

Any ideas?
 
Comment

colourfastt

macrumors 6502a
Apr 7, 2009
989
896
Glad to know I'm not alone.

This just started happening to me and I can't seem to find a resolution anywhere.

Mail keeps reporting that the password is being rejected, though it is the correct password. My guess is that Mail is trying to provide the password before the server responds.

Any ideas?

My guess is that microshaft set their servers to reject mail calls more frequent than 15 minutes to reduce server traffic now that they allows free POP access for everyone.
 
Comment

colourfastt

macrumors 6502a
Apr 7, 2009
989
896
would it be possible to adjust the e-mail check frequence for just the hotmail account without changing the other accounts?

I'm using Mail and all I can find is a way to adjust the checking times for all the accounts (it's a global setting).
 
Comment

cowells

macrumors newbie
Jan 14, 2009
1
0
Hi, same issue - changing to 15 mins solves it and another forum says that Apple are looking at the problem...
 
Comment

bunnyhero

macrumors member
Nov 4, 2008
30
8
my mail.app check mail frequency is set to 30 minutes, and i still get the issue once in a while :(
 
Comment

Sweener88

macrumors 6502
Original poster
Apr 27, 2006
426
1
Im EVERYWHERE!
mine was adjusted to 15 and 30min and same problem on each. SO annoying lol especially when it asks you like SECONDS after you've just given it again!
 
Comment

madog

macrumors 65816
Nov 25, 2004
1,273
1
Korova Milkbar
First, head into your applications/utilities folder and open up the Keychain.app. Find any Mail.app saved passwords related to your hotmail account and delete them and quit the app. Then, head into the Mail.app and retype the password in the account settings, exit that window and save your changes.

This is assuming it is a conflict issue with the password already saved in the Keychain.app, whether it was correct or not to begin with, and is the most likely cause.
 
Comment

jauntymcgoo

macrumors newbie
Sep 24, 2010
1
0
Uncheck "Include when automatically checking ..."

would it be possible to adjust the e-mail check frequence for just the hotmail account without changing the other accounts?

I'm using Mail and all I can find is a way to adjust the checking times for all the accounts (it's a global setting).

I kept my global settings at 5 minutes, then click over to my hotmail account and unchecked the box marked "Include when automatically checking for new messages".

You have to hit "check mail" to get your hotmail, but it's a helluva lot better than having to input your password every time.
 
Comment

lozion

macrumors regular
Jan 12, 2006
205
35
Montreal, Canada
I kept my global settings at 5 minutes, then click over to my hotmail account and unchecked the box marked "Include when automatically checking for new messages".

You have to hit "check mail" to get your hotmail, but it's a helluva lot better than having to input your password every time.

Da$%! It works. Finally... :eek:
 
Comment

Tapori

macrumors newbie
Jul 10, 2008
4
0
Try this...

I was having the same sort of problem w/HOTMAIL accounts always get asked for passwords. If I went into Mail preferences it would not save the passwords. I checked out the keychain and it didn't have any of my mail passwords saved. Tried to enter them manually into keychain and it wouldn't work.

Then in the Keychain Access menu (top left next to the apple menu) there is a menu item called "Keychain First Aid". I ran this and everything is now working perfectly. Not getting asked for passwords anymore. Mail preferences remembers the passwords and keychain is storing them.

Hope this solves your problems!
 
Comment

Schipperenzot

macrumors newbie
Mar 3, 2009
12
0
Thanks man!

I was having the same sort of problem w/HOTMAIL accounts always get asked for passwords. If I went into Mail preferences it would not save the passwords. I checked out the keychain and it didn't have any of my mail passwords saved. Tried to enter them manually into keychain and it wouldn't work.

Then in the Keychain Access menu (top left next to the apple menu) there is a menu item called "Keychain First Aid". I ran this and everything is now working perfectly. Not getting asked for passwords anymore. Mail preferences remembers the passwords and keychain is storing them.

Hope this solves your problems!

Problem solved! :p
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.