Mail Signature Issues

Discussion in 'Mac Apps and Mac App Store' started by Jake21, Jun 28, 2016.

Tags:
  1. Jake21 macrumors newbie

    Joined:
    Jun 28, 2016
    #1
    I have several email accounts in Mail, with signatures for each. All are set up in exactly the same way. Account ABC, for some reason, will not accept a signature. Any signature. The sig I created for ABC can be applied to other accounts. Other signatures can go to ABC. But one particular sig cannot go to one particular account. Huh? I even tried deleting the account and setting it up again. Same problem.




    OSX Yosemite

    Mail 8.2
     
  2. Cineplex macrumors 6502a

    Cineplex

    Joined:
    Jan 1, 2016
  3. Jake21 thread starter macrumors newbie

    Joined:
    Jun 28, 2016
    #3
    It's an IMAP account to my own domain.
    --- Post Merged, Jun 28, 2016 ---
    Thing is - and I forgot to mention this earlier - same IMAP account on my laptop, the signature works.
     
  4. Cineplex macrumors 6502a

    Cineplex

    Joined:
    Jan 1, 2016
    #4
    So in the Mail app preferences under signatures it should be showing "All Signatures" and then a list of all the accounts, including the one in question, correct? I am assuming there are some signatures in all signatures and then one for that account as well. If that is the case the app should have automatically generated the signature select box for that account in a new mail window.

    To try and isolate the issue a bit and rule out the account itself (which it shouldn't be)...try this. Create a new user account on the Mac, then setup mail only with that account with the new login. Does it work ok then? Maybe add the other accounts you have and see if all is well. Depending on the results we can nail it down a bit. It sounds like there may be a plist or something somewhere with some bogus info it in.
     
  5. Jake21 thread starter macrumors newbie

    Joined:
    Jun 28, 2016
    #5
    OK, I did that, set up new admin account, set up the same account, using a signature for it. Worked fine.
     
  6. Cineplex macrumors 6502a

    Cineplex

    Joined:
    Jan 1, 2016
    #6
    Great so the problem is with your home directory...probably the mail preferences file. Is everything you use local or on the server? If it is on the server...I would remove all the mail related items from ~/Library/Preferences/ and ~/Library/Application Support (if there is anything in there anymore). If things are locally stored, it will be a bit more complicated....but not difficult. Let me know and I'll try to find the related files to remove (not in front of a Mac at the moment). I think I know which they are....but I want to be sure.
     
  7. Jake21 thread starter macrumors newbie

    Joined:
    Jun 28, 2016
    #7
    I download to the Mac and erase from the mail server. BTW, really appreciate this help. If it's relevant, I am running OSX 10.10.2 and Mail 8.2 (2070.6)
     
  8. Cineplex macrumors 6502a

    Cineplex

    Joined:
    Jan 1, 2016
    #8
    Sorry for the delay......the wife had the Mac with here while she was away.

    Okay try this....
    -Close Mail.
    -In the Finder use the "Go" menu and select "Go to folder..."
    -Type in (without quotes) "~/Library/Mail"
    -then go into the V labeled folder in there (like V3)
    -Go into "MailData"
    -Delete the "Signatures" folder.
    -reboot

    Now once you recreate the signatures you should be good.
     
  9. Jake21 thread starter macrumors newbie

    Joined:
    Jun 28, 2016
    #9

    Thanks, that did it .... sort of. I also had to delete the sigs within the app, no big deal. Strangely, it didn't work at first. I have four accounts in my inbox in mail. The one with the problems was at the bottom of the list. I moved it to the top. It works. The one that is now fourth in the list - is working as it was before. Not sure why all that happened, but the problem was solved. Thanks for your help.
     
  10. Cineplex macrumors 6502a

    Cineplex

    Joined:
    Jan 1, 2016
    #10
    There must have been a cache file somewhere that I didn't see. Well at least it is solved.

    Have a good night!
     

Share This Page