Mavericks has placed the Finder on an infinite crash loop

Discussion in 'OS X Mavericks (10.9)' started by agahno, Oct 23, 2013.

  1. agahno macrumors newbie

    Joined:
    Oct 23, 2013
    #1
    Hi there.

    I installed Mavericks on a late 2012 iMac previously on Mountain Lion this afternoon and half an hour into using the new osx a strange problem unfolded:

    1. All the Folders, the HD icon, and the ability to click on the desktop suddenly disappeared. The dock is still there, the menu bar only appears when i click on an app, and spotlight still allows me to find and open things which are on my HD, such as documents and pictures.

    2. The following message is on an infinite crash loop and repeats each time OK is pressed:

    Process: Finder [37072]
    Path: /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder
    Identifier: Finder
    Version: ???
    Code Type: X86-64 (Native)
    Parent Process: launchd [3802]
    Responsible: Finder [37072]
    User ID: 501

    Date/Time: 2013-10-23 00:31:58.002 -0700
    OS Version: Mac OS X 10.9 (13A603)
    Report Version: 11
    Anonymous UUID: 487C41C5-20B3-25FF-2B9D-AAB4355CA8EA


    Crashed Thread: 0

    Exception Type: EXC_CRASH (Code Signature Invalid)
    Exception Codes: 0x0000000000000000, 0x0000000000000000

    VM Regions Near 0x7f7fb970ed30 (cr2):
    VM_ALLOCATE 0000000107d31000-0000000107d32000 [ 4K] rw-/rwx SM=ALI
    -->
    STACK GUARD 00007fff544c8000-00007fff57cc8000 [ 56.0M] ---/rwx SM=NUL stack guard for thread 0

    Thread 0 Crashed:
    0 dyld 0x00007fff649a1028 _dyld_start + 0

    Thread 0 crashed with X86 Thread State (64-bit):
    rax: 0x000000000000000d rbx: 0x0000000000000000 rcx: 0x0000000000000000 rdx: 0x0000000000000000
    rdi: 0x0000000000000000 rsi: 0x0000000000000000 rbp: 0x0000000000000000 rsp: 0x00007fff584c7d70
    r8: 0x0000000000000000 r9: 0x0000000000000000 r10: 0x0000000000000000 r11: 0x0000000000000000
    r12: 0x0000000000000000 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x0000000000000000
    rip: 0x00007fff649a1028 rfl: 0x0000000000000201 cr2: 0x00007f7fb970ed30

    Logical CPU: 0
    Error Code: 0x020000f4
    Trap Number: 133


    Binary Images:
    0x7fff649a0000 - 0x7fff649d3817 dyld (???) <D1DFCF3F-0B0C-332A-BCC0-87A851B570FF> /usr/lib/dyld

    External Modification Summary:
    Calls made by other processes targeting this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
    Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
    Calls made by all processes on this machine:
    task_for_pid: 233
    thread_create: 0
    thread_set_state: 0

    VM Region Summary:
    ReadOnly portion of Libraries: Total=288K resident=260K(90%) swapped_out_or_unallocated=28K(10%)
    Writable regions: Total=8492K written=0K(0%) resident=12K(0%) swapped_out=0K(0%) unallocated=8480K(100%)

    REGION TYPE VIRTUAL
    =========== =======
    STACK GUARD 56.0M
    Stack 8192K
    VM_ALLOCATE 8K
    VM_ALLOCATE (reserved) 48K reserved VM address space (unallocated)
    __DATA 252K
    __LINKEDIT 80K
    __TEXT 208K
    mapped file 6068K
    shared memory 4K
    =========== =======
    TOTAL 70.5M
    TOTAL, minus reserved VM space 70.5M


    Model: iMac13,1, BootROM IM131.010A.B05, 4 processors, Intel Core i5, 2.9 GHz, 8 GB, SMC 2.9f5
    Graphics: NVIDIA GeForce GT 650M, NVIDIA GeForce GT 650M, PCIe, 512 MB
    Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x02FE, 0x45424A3431554638424455352D474E2D4620
    Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x02FE, 0x45424A3431554638424455352D474E2D4620
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xF4), Broadcom BCM43xx 1.0 (5.106.98.100.22)
    Bluetooth: Version 4.2.0f6 12982, 3 services, 23 devices, 1 incoming serial ports
    Network Service: Ethernet, Ethernet, en0
    Serial ATA Device: APPLE HDD HTS541010A9E662, 1 TB
    Serial ATA Device: APPLE SSD SM128E, 121.33 GB
    USB Device: Hub
    USB Device: Hub
    USB Device: BRCM20702 Hub
    USB Device: Bluetooth USB Host Controller
    USB Device: Hub
    USB Device: FaceTime HD Camera (Built-in)
    Thunderbolt Bus: iMac, Apple Inc., 23.4

    3. I've attempted to change users, and create new users, but the issue persists on each of these.

    4. A hardware test on startup reveals the following issue:

    error: 4HDD/30/40000005: SATA (0,0)

    5. I'm unable to start the computer in safemode. Pressing down shift opens the start-up progress bar on the gray screen, but after that finishes the computer merely restarts and loads in regular mode.

    6. The only additional install I did today outside of Mavericks was a third-party software called Docker which allows you to change the appearance of the dock.

    Really confused and frustrated as to what to do, and would be extremely grateful for any help or advise any one has. Thanks kindly in advance! Agahno.
     
  2. thanachai macrumors member

    Joined:
    Dec 2, 2008
    #2
    Hey Agahno,

    I thought I was losing my mind with this infinite finder crash with Mavericks. I also have Docker installed. I'm at work right now but the first thing I'm going to do is uninstall it when I get home. Let me know if you find a solution.

    Thanks
     
  3. estebatron, Oct 23, 2013
    Last edited: Oct 23, 2013

    estebatron macrumors newbie

    Joined:
    Feb 24, 2009
    #3
    OK, so it IS Docker. Same problem. I performed the hardware test but it all came back normal though, no found errors.

    I cannot get out of the crash loop. Safe boot gets a crash as well. If I had created another user, would I have been able to get in? I thought safe boot would have been at system level, not user, but I still had to log in to my account.
     
  4. thanachai macrumors member

    Joined:
    Dec 2, 2008
    #4
    You just have to give admin access to the new user. Any luck removing Docker?
     
  5. estebatron macrumors newbie

    Joined:
    Feb 24, 2009
    #5
    If I am stuck in the loop though, is there any way to create a new user?

    ----------

    As far as removing Docker, I can't access anything because of the finder crash loop. I was able to access my drive from another Mac though. In a curious and dangerous panic I tried to see if I could delete Docker from there but the operation could not be completed, error code -8072.
     
  6. guitarman777 macrumors regular

    guitarman777

    Joined:
    Sep 15, 2005
    Location:
    Orlando, FL
    #6
    I had a very similar issue when I installed my SSD and accidentally removed a directory from the Library that caused the same thing. My only option was to restore from a Time Machine backup.
     
  7. cleverless macrumors newbie

    Joined:
    Oct 23, 2013
    #7
    Same problem

    Hi there,

    I was so happy to discover the new osx, except this ********** white dock... I just wanted to paint it black :D

    Now I've got the same problem as you, looking for a solution since 1pm.
    I've got a Early 2011 MacBook Pro.

    Hope it will be resolved soon.
     
  8. lensieUK macrumors newbie

    Joined:
    Oct 23, 2013
    Location:
    Torquay, UK
    #8
    The Fix For Me

    Hi, 1st time posting here :)

    Had the same Finder crash loop and I also had Docker installed.

    Hope this works for you guys with this problem.



    Before you remove Docker, open it in Terminal...

    Paste this in Terminal (No Quotes)

    "cd /applications/"

    Press Return

    Then Paste This (No Quotes)

    "open Docker.app"

    Then reset all to Apple Defaults in kiosk and menu bar options.

    Then re-download the Mavericks update from the AppStore and install it.

    All data and apps still there!

    Then uninstall Docker, use AppCleaner to remove all files.

    I believe its just Docker's incompatibility with Mavericks


    Let me know if this helped ;)
     
  9. estebatron macrumors newbie

    Joined:
    Feb 24, 2009
    #9
    lensieUK, I was finally able to get the dock to come up and through there access to menu bar, System Prefs, Terminal, Launchpad, and others. I am able to get to Docker, but I'm curious, why reinstall Mavericks before removing Docker?
     
  10. cleverless macrumors newbie

    Joined:
    Oct 23, 2013
    #10
    Hi Lensie,

    Unfortunately, I already uninstal Docker from my Mac and when I try to re-download Mavericks, nothing happends. I begin to be really confused...
     
  11. lensieUK macrumors newbie

    Joined:
    Oct 23, 2013
    Location:
    Torquay, UK
    #11
    In regards to removing docker estebatron,

    I believe its when Docker is triggered to remove menu bar or any dock actions (that's what happened on my machine), removing it without Finder is quite difficult, so resetting to apple defaults and reinstalling Mavericks should do the trick, then its much easier to uninstall Docker completely.

    cleverless, How far do you get? When you press download Mavericks in the AppStore it should say you already have it but press continue to re-download anyway then run it by going to your Applications (hopefully in your dock) and follow the procedure.

    I can source the procedure to reinstall Docker through Terminal, hopefully it won't come to that, Mavericks reinstall should do the trick.
     
  12. cleverless macrumors newbie

    Joined:
    Oct 23, 2013
    #12
    I tried to download it from the App store, it told me I already got it blablabla, then I click "Continue" but nothing happends. Nothing in the App screen (same thing as on the iPhone, I can't remember the real name) and nothing in Spotlight.

    Also, I can't find anything about Docker, in Magican.
     
  13. lensieUK macrumors newbie

    Joined:
    Oct 23, 2013
    Location:
    Torquay, UK
    #13
    The installer goes into the Applications folder when it is downloading, is it not there, do you have a progress bar on the Applications icon in your dock?
     
  14. cleverless macrumors newbie

    Joined:
    Oct 23, 2013
    #14
    Absolutely nothing. Should I format everything and start overnew or should I wait for Apple to give a solution ? I absolutely need my computer for school.
     
  15. lensieUK macrumors newbie

    Joined:
    Oct 23, 2013
    Location:
    Torquay, UK
    #15
    Do you have a TimeMachine backup?

    If you don't and the Mavericks update wont download then it you may have to wipe and start again, I am not a expert though please don't use my word as final.

    Make sure you are absolutely certain Mavericks update isn't downloading somewhere.
     
  16. cleverless macrumors newbie

    Joined:
    Oct 23, 2013
    #16
    No, I haven't any Time Machine save... I tried to install File Buddy but I can't even open a .dmg :(

    Anyway, thank's for your help !
     
  17. lensieUK macrumors newbie

    Joined:
    Oct 23, 2013
    Location:
    Torquay, UK
  18. estebatron macrumors newbie

    Joined:
    Feb 24, 2009
    #18
    lensie, first thank you for all that info today! you really gave hope where there was was none.

    I wanted to update where I am so far with this and see if anyone else might be on the same boat here.

    I was unable to set Docker back to Apple defaults through the terminal, it said the object did not exist, or through the app itself where I got a "NilObjectException was not handled. Application must shut down" error. I feel like in one of my panicked fueled attempts to remove it i might have unfortunately been partially successful?

    I was able to create a new admin and have been using it to download Mavericks again as I was unable to do so with my original admin user. cleverless, it seemed a lot like what you were going through.

    So as I wait for the download to finish, any suggestions on whether I should go on to reinstall using Mavericks with Docker there or at least sort of there (if that even works since I might not be able to access/run the Mavericks Installer).
     
  19. lensieUK macrumors newbie

    Joined:
    Oct 23, 2013
    Location:
    Torquay, UK
    #19
    Does Docker run at all? If it doesn't use a app called AppCleaner

    If you havn't got it you can download it at...
    http://www.freemacsoft.net/appcleaner/

    (I use this app to uninstall any app, you can drag any app into it to uninstall, it gathers up all the bits the app has left in different places, be careful with the app in general as it also targets the installer/.dmg it came from)

    Open AppCleaner up (We will have to use terminal)

    Open up Terminal & paste this command

    cd /Users/yourname/Downloads

    This is ashuming you use the Downloads folder for your browser.

    For saving to the Desktop paste this command

    cd /Users/yourname/Desktop

    Then paste

    unzip AppCleaner_2.2.zip

    Then paste

    open AppCleaner.app


    In AppCleaner


    Click 'Applications'

    Tick 'Docker'

    Then Press 'Search'

    And delete all the Docker files.

    Then empty your trash from the dock.



    We may have to reinstall Docker if this doesn't work.

    I feel that the re-install of Mavericks should do the trick though... hopefully (fingers crossed)

    Hope all goes well buddy :)
     
  20. estebatron macrumors newbie

    Joined:
    Feb 24, 2009
    #20
    It runs but it seems like when I try to set back to defaults I get that nilobjects error. It's also missing images for the tab/sections. I'll try AppCleaner and then installing Mavericks either way. I'll let you know! Thanks again.:cool:
     
  21. lensieUK macrumors newbie

    Joined:
    Oct 23, 2013
    Location:
    Torquay, UK
    #21
    Ok great!

    Best of luck, I'm off to bed.

    Will be back on tomorrow.
     
  22. thanachai macrumors member

    Joined:
    Dec 2, 2008
    #22
    Solution for me (at least)!

    Hi all,

    I removed Docker from Terminal.

    cd /applications

    sudo rm –f docker.app

    Restarted and pressed cmd-r to reinstall Mavericks

    Everything is good now. Good luck!
     
  23. estebatron macrumors newbie

    Joined:
    Feb 24, 2009
    #23
    AppCleaner removed Docker just fine and Mavericks reinstalled with no problems. Thank you lensie. I'm glad that worked for you too thanachai. And to think that this morning I thought I would be trying to figure out how to properly display on a rotated second display on Mavericks, ha!
     
  24. agahno thread starter macrumors newbie

    Joined:
    Oct 23, 2013
    #24
    Phew. I'm glad I wasn't alone in this and even gladder it seems to have been resolved for everyone. LensieUK, you're a total marvel :), thank you; I think you've averted several minor breakdowns and grey hairs with those of us affected today.

    Anyone coming to this page with the same issue, I used the same recipe provided by LensieUk as the others to get out of the crash.

    I've also notified Docker of the issue and so hopefully a fix can be found.
     
  25. lensieUK macrumors newbie

    Joined:
    Oct 23, 2013
    Location:
    Torquay, UK
    #25
    Great :) Happy days!

    Could be worth making a Time Machine backup now incase any other apps do crazy things.

    Although it does seem we're out of the woods!
     

Share This Page