serge94

macrumors newbie
Original poster
Feb 6, 2020
14
9
Europe
Hi everyone,

I have a 16" 2019 MBP (i9 2.4, 32GB RAM, 5500M 8GB) that I just updated to 10.15.6 last week. I was using the dedicated graphics almost always as I had it enabled in Chrome and I use Chrome all the time so this issue might have been from even prior versions of the OS. I have since disabled hardware acceleration in Chrome and it's now using the integrated graphics 99% of the time.

However, whenever I open an app that needs the dedicated graphics such as Adobe Photoshop, Sketch, Adobe Premier Pro or Final Cut Pro X, the mouse freezes and the screen goes black either for half a second or 2-3 full seconds. I'm guessing while it switches to the dedicated graphics. It's kind of the same thing that happens when you plug an external monitor in. Everything works ok after, except a few visual bugs in Photoshop which I think are due to Photoshop itself. I even got a "graphics driver issue" error in Adobe Photoshop one time.

Wondering if anyone else is experiencing this or just me? I may have a lemon graphics card. I already had a logic board replacement due to sleep wake kernel panics.

Thanks.
 
Last edited:

Cerbero

macrumors newbie
Jul 28, 2020
2
1
Yep, and I didn't find this mentioned anywhere except here by you. Weird, I noticed it right away after installing 10.15.6.

I have almost the same MacBook (i9 2.3 instead of 2.4, everything else the same as yours) and I am have the exact same issue.

For me it happens with Adobe Lightroom and Affinity Photo, but I have iStat Menus that shows me what graphics card is active and you are right, it happens during the switch to the dedicated card.

I'm gonna send feedback to Apple, but given that we already are at 10.15.6 I hope they take care of it before Big Sur, maybe with a supplemental update.
 
  • Like
Reactions: serge94

Lopes

macrumors 6502
Jun 23, 2003
271
118
Started happening here too just in the last week. It isn't all the time when switching graphics cards, and a restart fixes it...but it's a new issue for me too. I have the exact same MBP 16" as the OP.
 

AMP12345

macrumors member
Nov 21, 2016
70
91
This started happening to me a few days ago, but only when Chrome is open. I’m on macOS 11 beta so I’m not sure if it’s a mac bug or a chrome bug.
16” 2.3 GHz i9 32GB 5500m 8GB
 

Cerbero

macrumors newbie
Jul 28, 2020
2
1
This started happening to me a few days ago, but only when Chrome is open. I’m on macOS 11 beta so I’m not sure if it’s a mac bug or a chrome bug.
16” 2.3 GHz i9 32GB 5500m 8GB

Chrome is often using the dedicated graphic card. Did you try other graphic intensive software like Photoshop or Final Cut?
I'm getting slightly better graphic performances and slightly lower temperatures, so I think it's a new faster but not-so-stable radeon graphics driver included in macOS 10.15.6 and 11 beta.
 

costinvlad

macrumors newbie
Aug 19, 2020
1
0
I also have this problem with the same config as u Serge except for the 32 gb or ram ! Happends some times when switching from integrated to dedicated ! Catalina has been a disater full of bugs, let's hope Big Sur will be properly tested before launch !
 

ultrakyo

macrumors member
Apr 12, 2015
88
44
Just to note, Photos app also uses dGPU but I haven't notice any black screen during the switch and also it did not happen when I open AutoCAD. Perhaps the issue is link to certain softwares?
 

DFP1989

macrumors 6502
Jun 5, 2020
319
174
Melbourne, Australia
Noticed this on my MacBook Pro a few days ago after a full reinstall of 10.15.6 (was scrapping the Big Sur beta).

My spec:

Screen Shot 2020-08-30 at 3.19.17 pm.png
 

ght56

macrumors 6502a
Aug 31, 2020
807
765
I am experiencing this. It's kind of wild how many software issues this computer has. It has UI lag on the iGPU, excessive heat when using an external display on the dGPU, and now iGPU-->dGPU blinking tendencies...all of which seem completely software related. Such great hardware but wow...it's been one zinger after another for me lol
 

DFP1989

macrumors 6502
Jun 5, 2020
319
174
Melbourne, Australia
I am experiencing this. It's kind of wild how many software issues this computer has. It has UI lag on the iGPU, excessive heat when using an external display on the dGPU, and now iGPU-->dGPU blinking tendencies...all of which seem completely software related. Such great hardware but wow...it's been one zinger after another for me lol

You're not alone. I swear there was a time not so long ago when Apple had their stuff together, on both the hardware and software front. These days, it's a bit of a mess.
 

Vitaly333

macrumors newbie
Sep 30, 2020
1
0
Same issue with 5300M. Version 10.15.7 didn't help. This issue does not reproduce after a reboot until I connect an external monitor. I disabling auto graphics switching when software needs dGPU like Lightroom, current power savings begin switching iGPU and dGPU back and forth and you just see a flickering screen when try to scroll photos in Lightroom.
 

Felipe Bazo

macrumors newbie
Oct 16, 2020
2
0
Happening to me too the last two weeks. 16in MBP, i7 base model, 5300M with 10.15.7 OS.
Clearly only happens when the dGPU kicks in, when Lightroom or Photoshop are started (also recieved a message today of a display driver error, just after the screen turned on again). Note: I tried ticking off the Automatic Graphics Switching on System Preferences->Energy Saver and it stopped happening.
 

Attachments

  • PS_ErrorMessage.jpg
    PS_ErrorMessage.jpg
    72.9 KB · Views: 116

Poee

macrumors newbie
Nov 4, 2020
1
0
Clearly a Mac problem that isn't fixed, it occurs randomly when switching graphics with a lot of different apps : chrome, java applications, ....
Really annoying, hope Apple is going to fix it....
 

aburtnett3

macrumors newbie
Nov 16, 2020
1
0
I too am having this issue, I have been having it since I got it and it seems to have been made worse by the 2021 adobe apps. I have iStat and have noticed that this happens pretty reliably when switching to the GPU, I have even had my computer go black and bring me back out to the user login screen due to a GPU switch before.
 

nimrweb

macrumors newbie
Oct 16, 2020
2
0
MacBook Pro i9 2.3 Gpu Switch Black screen and sleep freeze ((Solved)) After Update 11.1
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.