MBP 2017 TP: Dead USB-C port

Discussion in 'MacBook Pro' started by underattack, Oct 2, 2017.

  1. underattack macrumors member

    Joined:
    Oct 15, 2008
    #1
    One of my USB-C ports appears to be "dead". The left front one no longer works. Devices I plug into it are not recognized, and it will not even charge via the port. After an SMC reset, it came back briefly, but only to turn itself "off" shortly after. A simple reboot will not bring it back.

    I first recognized it after upgrading to High Sierra. Is it possible that High Sierra caused this? Anybody else seeing this issue? Or was the issue that I plugged the power supply as well as the thunderbolt docking station (via USB-C -> Thunderbolt adapter) both into the left side? That appeared to have triggered the shutdown after the SMC reset. (but I didn't yet get around to reproduce this)
     
  2. bartvk macrumors 6502

    bartvk

    Joined:
    Dec 29, 2016
    Location:
    The Netherlands
    #2
    I've had the same. Brought it back to the store, and when they got around to testing it (a couple of days later), the problem had apparently solved itself. Have you used a charger from a disreputable brand?
     
  3. Ries macrumors 68020

    Joined:
    Apr 21, 2007
    #3
    Try a plastic / wood tooth pick and check the connector for lint.
     
  4. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #4
    It's still under warranty.
    Take it to an Apple Store and have them check it out.
     
  5. underattack thread starter macrumors member

    Joined:
    Oct 15, 2008
    #5
    will probably end up bringing it to the store. The only problem is that I won't be home for another 4 weeks (traveling through various countries). How long does a repair typically take?
    --- Post Merged, Oct 3, 2017 ---
    seems to be a bit hit and miss what works / doesn't work. I just connected an Avotech usb-c "hub" device (network card / USB-A ...) and it looks like it works. Charging, via the Apple power supply, still doesn't work. :/
     
  6. PortableLover macrumors 6502a

    Joined:
    Apr 14, 2012
    Location:
    england
    #6
    Recommend seeing if anything is stuck inside, or any dirt.
     
  7. underattack thread starter macrumors member

    Joined:
    Oct 15, 2008
    #7
    I cleaned the port with folded piece of paper and nothing notable was stuck in it. Seems to be working so far as a “regular” USB port but not for charging
     
  8. bartvk macrumors 6502

    bartvk

    Joined:
    Dec 29, 2016
    Location:
    The Netherlands
    #8
    Usually not more than a week.
     

Share This Page

7 October 2, 2017