MBP 2018 does not want to show non-AC 5Ghz WiFi

Discussion in 'MacBook Pro' started by M.Rizk, Sep 16, 2018.

  1. M.Rizk macrumors 6502

    M.Rizk

    Joined:
    Apr 20, 2015
    #1
    I have got two routers/access points where I live. One of which is an old one that only offers 802.11n over 5Ghz and not 802.11ac. I notice that when trying to connect to it, iOS devices usually show it last even when standing next to it but it works fine on all my devices.

    Today I received my 2018 MBP and no matter what I do, or how long I wait, it never shows this specific WiFi network. It shows the 2.4 GHz network from the same router without an issue.

    I tried changing the WiFi channel, name, etc but nothing helps. I tried changing the SSID name to be same as the 802.11ac one I have to force the mac to connect to it and that did it, but I do not want them to have the same name to know which is which...
     
  2. Howard2k macrumors 6502a

    Howard2k

    Joined:
    Mar 10, 2016
    #2
    Please can you post a screenshot of the router wifi configuration page.

    Which router is it? Is it possible that it’s draft-n? Does the router have the latest firmware?
     
  3. jerryk macrumors 68040

    Joined:
    Nov 3, 2011
    Location:
    SF Bay Area
    #3
    You might what consider upgrading your router to one that support 802.11 ac on 5ghz. The throughput is much better with AC, especially if there are walls or you are some distance from the AP.

    Also, are you saying the 5GHz and 2.4 GHz nets use the same SSID? Ours are difference and we never have any issues with them any devices.
     
  4. M.Rizk thread starter macrumors 6502

    M.Rizk

    Joined:
    Apr 20, 2015
    #4

    I have an AC router that I keep close to my office room and living room. I just use the older router in areas with no much speed demands as the kitchen, entrance, garage, etc.

    I use a different SSID for 2.4, and 5. Also different for each router to know which I am connected to.

    I am not sure if it is draft-n or not but all my other devices including the 2011 MBP have no issue connecting to it. Even the 2018 MBP connected to it but only when I gave it the same SSID as the AC WiFi and went out of the AC WiFi range.

    I am using Linksys EA4500 (N900). Nothing special regarding configs.

    [​IMG]
     
  5. Howard2k macrumors 6502a

    Howard2k

    Joined:
    Mar 10, 2016
    #5

    Thanks.

    So I'm not sure it's totally adding, up, but maybe you can clarify.

    Your MBPro cannot see the BerryVerse Ext network (5GHz 802.11n) but if you rename the 5GHz 802.11n network to match your 802.11ac network, it will connect. Not to ask a stupid question, but to ask a stupid question, how do you know that your MBPro is connecting to the 802.11n network and not the 802.11ac network if the names are the same?

    The EA4500 is proper 802.11n, not draft, so you should be ok. I would check the firmware all the same. If you're in the US it looks like it should be 3.1.7.

    I would also force the network mode to 802.11n (not mixed), and set the channel and channel width manually. Just pick a channel at this point, doesn't matter which, can be adjusted later. And set the channel to 20MHz. Ideally you want 40MHz, but let's try 20.

    So:

    1 - check firmware version, should be 3.1.7 I think.
    2 - set channel specs to 20Mhz and specify a channel, and set it to 802.11n only, not mixed.

    And then let me know how you determined whether it connected if it had the same name.

    WRT your other devices working, yeah different chipsets in the other devices, they will behave differently. Looks to me like this SHOULD work though.

    Thanks



    EDIT: Last throw of the dice, making a note of this now in case I forget for later - rename your 802.11ac to Berry Verse Ext and make this connect to the 802.11ac network. Then it will connect to either, if I understand your comments correctly. Turn off the wifi on the MBPro, and rename the 5GHz 802.11ac network back to the current name. You will then have made you MBPro connect to the 802.11ac network called Berry Verse Ext and if I understand your other comments about the 802.11n connection, this might fool it into work when you turn it back on - because turning on the wifi it is looking for a Berry Verse Ext network in 5Ghz and the 802.11ac network no longer exists with that name. Again, I'm not sure I'm understanding that part of your explanation correctly, and again, last throw of the dice. I'd try the other stuff first. :)
     
  6. M.Rizk, Sep 16, 2018
    Last edited: Sep 16, 2018

    M.Rizk thread starter macrumors 6502

    M.Rizk

    Joined:
    Apr 20, 2015
    #6
    1. Regarding the Edit. I understand you want me to go through this to have the MBP save the SSID details so it auto connects. It already does as it pulled the entire known WiFi list from my iPhone (iCloud) and BerryVerse Ext (802.11n) is already set to highest priority yet it never connected to it but once during the setup.

    2. I have the first revision of the hardware so the latest firmware is 2.1.42.183584

    3. I tried many different configs over the night, from 20 only, 40 only, all available channels and nothing. The MBP just hates this router for some reason.

    4. I am not quite sure it was connected to the 802.11n. All I know is that I clicked Options(alt)+WiFi icon in menu bar and it said it was connected to a 802.11n network with a decent signal when I was at a far distance from the AC router. (In the past day I noticed the MBP will connect to the AC router on 802.11ac regardless of signal strength even if it ends up with a slower sync speed than using 2.4 GHz.

    I will try to reflash the firmware on the router again and re-do everything hopefully it gets more friendly with the 2018 MBP.

    Update: No matter what I do, the MBP will never detect the 802.11n or connect to it automatically. I ended up renaming the 802.11n to use the same name as the 2.4 GHz WiFi and when I tried to connect to the SSID it used 2.4 GHz in the first few seconds then switched over to 5 GHz (see screenshot attached).

    [​IMG]

    I think I got my hands tied and this is the best setup for now.
     
  7. jerryk macrumors 68040

    Joined:
    Nov 3, 2011
    Location:
    SF Bay Area
    #7
    Sounds like it is time to upgrade to a more recent router or if possible dedicated Access Point(s).

    How is your network setup? Do you have Ethernet cable running between the two router/Access points? Or something else?

    And I feel your pain, I experienced the same issues if finally said enough is enough.

    After years (actually decades) of messing with router/access point flakiness, a couple of years ago we dumped all the Netgear dual purposed router/access points and installed a dedicated Ubiquiti router on the home internet connection, a dedicated switch, and ran Ethernet cables to Access points under cabinets, in closets, and on a ceiling. Since then everything has been working great. No more dropped Wifi. 5GHz and 2.4 all the way out the backyard and into the garage.

    If I put any value on the time I spent messing with the older gear, the costs of the new gear and wiring has been covered several times over.
     
  8. M.Rizk thread starter macrumors 6502

    M.Rizk

    Joined:
    Apr 20, 2015
    #8
    I really don’t feel like upgrading when it is just one device throwing a tantrum. The router can still offer 1/2 to 3/4 of the 300 Mbps plan I am subscribed to without an issue. Even to the 2018 MBP after I decided to use same name for both bands.

    Linksys EA4500 is an access point not a modem. I also have EA6400 which is really good and working perfectly with the new MBP. Both of them connected to the Fibre ONT with Cat5e Ethernet cables.

    If I ever upgrade I will probably get an ASUS though, I got one in my home country (RT-AC56U) and it is a really amazing router. Perfect signal, delivers more than my plan (100 Mbps) and can do 5 parallel VPN connections.
     

Share This Page