MBP extremely slow, HDD cable replaced, what next?

Discussion in 'MacBook Pro' started by TitoPartija, Jul 19, 2017.

  1. TitoPartija macrumors newbie

    Joined:
    Jul 19, 2017
    #1
    Hello!

    A week ago or so, my beloved sturdy workhorse (Macbook Pro model A1278 mid-2012) became suddenly and unreasonably slow, freezing constantly and beachballing while performing even the easiest tasks. However, before I managed to assess the situation, the infamous flashing question mark on boot appeared, warranting the change of the HDD cable as per these instructions:

    MacBook Pro 13" Unibody Mid 2012 Hard Drive Cable Replacement - iFixit

    After successfully replacing the HDD cable, I was relieved to see that my files were intact, but the laptop was still running extremely slow, albeit semi-reliably and not crashing no more. Since I used it pretty much every day for past five years, I'd say that installing SSD (or maybe even upgrading RAM) would be in order and would appreciate any inputs on what should I be doing next. Here's an EtreCheck report, it took 35min which reinforces my "waning HDD" theory:


    EtreCheck version: 3.4 (420)

    Report generated 2017-07-19 13:11:51

    Download EtreCheck from https://etrecheck.com

    Runtime: 35:11

    Performance: Poor


    Problem: Computer is too slow

    Description:

    Computer is too slow, beachballing occurs while running and using pretty much any program, replaced the HDD cable saving the computer from perpetual flashing question mark.


    Hardware Information:

    MacBook Pro (13-inch, Mid 2012)

    [Technical Specifications] - [User Guide] - [Warranty & Service]

    MacBook Pro - model: MacBookPro9,2

    1 2,9 GHz Intel Core i7 (i7-3520M) CPU: 2-core

    8 GB RAM Upgradeable - [Instructions]

    BANK 0/DIMM0

    4 GB DDR3 1600 MHz ok

    BANK 1/DIMM0

    4 GB DDR3 1600 MHz ok

    Bluetooth: Good - Handoff/Airdrop2 supported

    Wireless: en1: 802.11 a/b/g/n

    Battery: Health = Normal - Cycle count = 1880


    Video Information:

    Intel HD Graphics 4000 - VRAM: 1536 MB

    Color LCD 1280 x 800


    Disk Information:

    APPLE HDD TOSHIBA MK7559GSXF disk0: (750,16 GB) (Rotational)

    [Show SMART report]

    EFI (disk0s1 - MS-DOS FAT32) <not mounted> [EFI]: 210 MB

    (disk0s2) <not mounted> [CoreStorage Container]: 749.30 GB

    Recovery HD (disk0s3 - Journaled HFS+) <not mounted> [Recovery]: 650 MB


    HL-DT-ST DVDRW GS31N ()


    USB Information:

    USB20Bus

    hub_device

    hub_device

    Apple Inc. Apple Internal Keyboard / Trackpad

    Apple Computer, Inc. IR Receiver

    Apple Inc. BRCM20702 Hub

    Apple Inc. Bluetooth USB Host Controller

    USB20Bus

    hub_device

    Apple Inc. FaceTime HD Camera (Built-in)

    USB30Bus


    Thunderbolt Information:

    Apple Inc. thunderbolt_bus


    Virtual disks:

    Macintosh HD (disk1 - Journaled HFS+) / [Startup]: 748.93 GB (106.23 GB free)

    Physical disk: disk0s2 749.30 GB Online


    System Software:

    macOS Sierra 10.12.5 (16F73) - Time since boot: less than an hour


    Configuration files:

    /etc/sudoers, File size 1302 but expected 1563

    /etc/sysctl.conf - File exists but not expected


    Gatekeeper:

    Mac App Store and identified developers


    Clean up:

    /Library/LaunchAgents/com.avast.secureline.update-agent.plist

    /Library/Application Support/AvastSecureLine/components/update/com.avast.secureline.update-agent

    Executable not found!

    /Library/LaunchDaemons/com.wdc.WDPrivilegedHelper.plist

    /Library/PrivilegedHelperTools/com.wdc.WDPrivilegedHelper

    Executable not found!

    ~/Library/LaunchAgents/com.spotify.webhelper.plist

    ~/Library/Application Support/Spotify/SpotifyWebHelper

    Executable not found!

    3 orphan files found. [Clean up]


    Kernel Extensions:

    /Library/Extensions

    [loaded] at.obdev.nke.LittleSnitch (3.7 - SDK 10.11) [Lookup]

    [loaded] com.kairos.driver.DuetDisplay (1.1.2 - SDK 10.11) [Lookup]


    /System/Library/Extensions

    [not loaded] com.ZTE.driver.ZTEUSBCDCACMData (ZTEDriver_MacV1.3.33) [Lookup]

    [not loaded] com.ZTE.driver.ZTEUSBMassStorageFilter (ZTEDriver_MacV1.3.33) [Lookup]

    [not loaded] com.driver.JRDMassStorageDriver32 (1.0.3) [Lookup]

    [not loaded] com.driver.JRDMassStorageDriver64 (1.0.3) [Lookup]

    [not loaded] com.driver.JRDUSBModemData32 (1.0.1) [Lookup]

    [not loaded] com.driver.JRDUSBModemData64 (4.0.8) [Lookup]

    [not loaded] com.focusrite.driver.usb2audio (1.8 - SDK 10.6) [Lookup]

    [not loaded] com.paceap.kext.pacesupport.master (5.9 - SDK 10.6) [Lookup]

    [not loaded] com.wdc.driver.1394HP (1.0.11 - SDK 10.4) [Lookup]

    [not loaded] com.wdc.driver.1394_64HP (1.0.1 - SDK 10.6) [Lookup]

    [not loaded] com.wdc.driver.USBHP (1.0.11) [Lookup]

    [not loaded] com.wdc.driver.USB_64HP (1.0.0 - SDK 10.6) [Lookup]

    [not loaded] com.zte.driver.cdc_ecm_qmi (1.0.23) [Lookup]

    [not loaded] com.zte.driver.cdc_usb_bus (1.0.23) [Lookup]


    /System/Library/Extensions/PACESupportFamily.kext/Contents/PlugIns

    [not loaded] com.paceap.kext.pacesupport.leopard (5.9 - SDK 10.4) [Lookup]

    [not loaded] com.paceap.kext.pacesupport.panther (5.9 - SDK 10.-1) [Lookup]

    [loaded] com.paceap.kext.pacesupport.snowleopard (5.9 - SDK 10.6) [Lookup]

    [not loaded] com.paceap.kext.pacesupport.tiger (5.9 - SDK 10.4) [Lookup]


    System Launch Agents:

    [not loaded] 6 Apple tasks

    [loaded] 183 Apple tasks

    [running] 93 Apple tasks


    System Launch Daemons:

    [not loaded] 39 Apple tasks

    [loaded] 172 Apple tasks

    [running] 107 Apple tasks


    Launch Agents:

    [running] at.obdev.LittleSnitchUIAgent.plist (Objective Development Software GmbH - installed 2016-10-02) [Lookup]

    [failed] com.avast.secureline.update-agent.plist (? 4f732c42 0 - installed 2015-06-16) [Lookup] - /Library/Application Support/AvastSecureLine/components/update/com.avast.secureline.update-agent: Executable not found!

    [loaded] com.oracle.java.Java-Updater.plist (? c3a2a448 be93c7fb - installed 2016-11-16) [Lookup]

    [running] com.rosettastone.rosettastonedaemon.plist (Rosetta Stone Ltd. - installed 2016-10-02) [Lookup]

    [loaded] org.macosforge.xquartz.startx.plist (Apple Inc. - XQuartz - installed 2012-09-27) [Lookup]


    Launch Daemons:

    [loaded] PACESupport.plist (Shell Script ab6b5614 - installed 2012-07-11) [Lookup]

    [not loaded] PT.updd.plist (? 0 ? - installed 2016-11-15) [Lookup]

    [running] at.obdev.littlesnitchd.plist (? 4ffc17c9 249815ba - installed 2016-10-02) [Lookup]

    [loaded] com.adobe.fpsaud.plist (? 2afb3af7 a0305b84 - installed 2017-06-14) [Lookup]

    [loaded] com.apple.aelwriter.plist (Apple, Inc. - installed 2013-05-30)

    [running] com.apple.qmaster.qmasterd.plist (Apple, Inc. - installed 2010-08-25)

    [running] com.freemacsoft.appcleanerd.plist (? f7188468 7d92d211 - installed 2013-05-19) [Lookup]

    [loaded] com.microsoft.office.licensing.helper.plist (? 6d8cb30e afb3bef0 - installed 2010-08-25) [Lookup]

    [loaded] com.microsoft.office.licensingV2.helper.plist (Microsoft Corporation - installed 2016-04-11) [Lookup]

    [running] com.nordvpn.NordVPN.Helper.plist (TEFINKOM & CO S.A - installed 2017-02-28) [Lookup]

    [loaded] com.oracle.java.Helper-Tool.plist (Shell Script e3fefdd2 - installed 2016-09-22) [Lookup]

    [running] com.paceap.eden.licensed.plist (? 31c2e993 dfd5a873 - installed 2013-06-08) [Lookup]

    [running] com.prey.agent.plist (Shell Script 714c4ad6 - installed 2017-03-02) [Lookup]

    [loaded] com.sfr.sfr3g.plist (? 3439e71 86bdc726 - installed 2013-06-30) [Lookup]

    [loaded] com.surteesstudios.Bartender.BartenderInstallHelper.plist (Surtees Studios Limited - installed 2016-12-24) [Lookup]

    [loaded] com.wdc.WDPrivilegedHelper.plist (? 9f7f4405 0 - installed 2016-10-02) [Lookup] - /Library/PrivilegedHelperTools/com.wdc.WDPrivilegedHelper: Executable not found!

    [loaded] org.macosforge.xquartz.privileged_startx.plist (Apple Inc. - XQuartz - installed 2012-09-27) [Lookup]


    User Launch Agents:

    [loaded] com.dropbox.DropboxMacUpdate.agent.plist (Dropbox, Inc. - installed 2017-07-19) [Lookup]

    [loaded] com.google.keystone.agent.plist (Google, Inc. - installed 2017-03-28) [Lookup]

    [failed] com.spotify.webhelper.plist (? b76f297e 0 - installed 2014-07-17) [Lookup] - ~/Library/Application Support/Spotify/SpotifyWebHelper: Executable not found!

    [loaded] com.valvesoftware.steamclean.plist (? cd870406 f03ac3b1 - installed 2017-07-02) [Lookup]


    User Login Items:

    CheatSheet Programm

    (/Applications/CheatSheet.app)

    NordVPN Programm

    (/Applications/NordVPN.app)

    iTunesHelper Programm (? 0 - installed 2017-05-16)

    (/Applications/iTunes.app/Contents/MacOS/iTunesHelper.app)

    Flux Programm

    (/Applications/Flux.app)

    Dropbox Programm

    (/Applications/Dropbox.app)

    AppCleaner Helper Programm (? 0 - installed 2013-05-19)

    (/Applications/AppCleaner.app/Contents/Library/LoginItems/AppCleaner Helper.app)

    WDDriveUtilityHelper Programm

    (/Applications/WD Drive Utilities.app/Contents/WDDriveUtilityHelper.app)

    Alfred 2 Programm

    (/Applications/Alfred 2.app)

    Actions Server Programm

    (/Applications/Actions Server.app)


    Internet Plug-ins:

    FlashPlayer-10.6: 26.0.0.131 (installed 2017-06-17) [Lookup]

    QuickTime Plugin: 7.7.3 (installed 2017-07-10)

    Flash Player: 26.0.0.131 (installed 2017-06-17) Outdated! Update

    JavaAppletPlugin: Java 8 Update 111 build 14 (installed 2016-11-16) Check version

    SharePointBrowserPlugin: 14.0.0 (installed 2010-08-25) [Lookup]


    Safari Extensions:

    [enabled] AdBlock - BetaFish, Inc. - https://getadblock.com (installed 2015-10-19)

    [enabled] WikiWand - WikiWand - http://wikiwand.com (installed 2017-02-20)

    [enabled] Zotero Connector - Center for History and New Media - http://www.zotero.org/ (installed 2015-09-29)


    Audio Plug-ins:

    DVCPROHDAudio: 1.3.2 (installed 2013-06-08)

    Hear: 1.1.3 (installed 2014-12-08) [Lookup]

    BartenderAudioPlugIn: 1.0.0 (installed 2016-09-14) [Lookup]


    3rd Party Preference Panes:

    Flash Player (installed 2017-06-14) [Lookup]

    Java (installed 2016-11-16) [Lookup]


    Time Machine:

    Skip System Files: NO

    Mobile backups: ON

    Auto backup: YES

    Volumes being backed up:

    Macintosh HD: Disk size: 748.93 GB Disk used: 642.70 GB

    Destinations:

    Time Machine Backup [Local]

    Total size: 999.86 GB

    Total number of backups: 2

    Oldest backup: 23.12.16, 09:15

    Last backup: 10.07.17, 08:50

    Size of backup disk: Too small

    Backup size 999.86 GB < (Disk used 642.70 GB X 3)


    Top Processes by CPU:

    6% WindowServer

    4% kernel_task

    2% mdworker

    1% ps

    1% Little Snitch Agent


    Top Processes by Memory:

    786 MB kernel_task

    176 MB Dropbox

    168 MB Google Chrome

    125 MB Finder

    122 MB mds_stores


    Top Processes by Network Use:

    Input Output Process name

    177 MB 8 MB openvpn

    231 KB 212 KB mDNSResponder

    56 KB 18 KB Dropbox

    4 KB 4 KB netbiosd

    0 B 184 B SystemUIServer


    Top Processes by Energy Use:

    7.64 WindowServer

    3.68 AddressBookSourceSync

    0.94 Google Chrome

    0.88 accountsd


    Virtual Memory Information:

    3.83 GB Available RAM

    950 MB Free RAM

    4.17 GB Used RAM

    2.91 GB Cached files

    512 KB Swap Used


    Software installs:

    Microsoft OneNote: 15.35.1 (installed 2017-06-19)

    OneDrive: 17.3.6916 (installed 2017-06-24)

    OneDrive: 17.3.6919 (installed 2017-07-02)

    Wunderlist: 3.4.7 (installed 2017-07-10)


    Install information may not be complete.





    Many thanks in advance and have a great day!!

    T
     
  2. jerryk macrumors 68030

    Joined:
    Nov 3, 2011
    Location:
    SF Bay Area
    #2
    An SSD will make it a new machine. I did the swap on my 2011 13 MBP. App launches that used to take 15 seconds took 2 seconds. Everything was just so much faster.
     
  3. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #3
  4. Audit13 macrumors 65816

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #4
    Where did you get there replacement cable? The machine is running at the same speed it was before the cable failure?

    The Samsung 850evo and crucial mx300 are great drives and will do wonders for your Macbook speeds.
     
  5. TitoPartija thread starter macrumors newbie

    Joined:
    Jul 19, 2017
    #5
    Glad to hear that, it fills me with hope!

    I'm trying to determine weather the problems will persist even if I swap the HDD with a new SSD. Thanks for your swift reply and have a good one!
    --- Post Merged, Jul 19, 2017 ---
    Hi, thank you very much for your inputs!

    1) Thanks! Any particular SSDs you would recommend?
    2) Yeah, that definitely saved my bacon, however the computer remains slow and I fear I'll need to get SSD right away.
    3) SU (thanks for the link) reports no total errors, 13.777 power on hours and an overall SMART status PASSED. I will run First Aid after I reply to the first batch of suggestions.

    P.S.
    I love your Filosofem avatar, I haven't listened to that masterpiece in years!
    --- Post Merged, Jul 19, 2017 ---
    Hi, this is the replacement cable, it had by far the best reviews in regard to the number of reviews and products price:

    https://www.amazon.com/gp/product/B...ue&ref_=ox_sc_act_title_1&smid=A3TKISGA3JDK5K

    The machine is running definitely slower than before the cable failure, and it still freezes/"beachballs" and acts wonky. For comparison, before I was running multiple video editing programs for work and sometimes two browsers all at the same time, right now I'm using the lightest browser and it still hiccups once I open a new tab or run another program.

    Thank you for your SSD recommendations and have a great day!
     
  6. Audit13 macrumors 65816

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #6
    I used there cheapest cable I could find on Amazon.ca to fix a 13" 2010 Macbook Pro and a 15.4" 2009 Macbook Pro. In both cases, the cable got rid of all issues with respect to beach balling, lag, and stuttering.

    Sounds like the replacement you received may be partially defective?
     
  7. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #7
    Any SSD at all! Personally I'd recommend Samsung or Crucial as they're good brands. But any at all will work fine.

    Wow, courteous and a Filosofem fan. Don't see that often around here. Drop me a PM if you're ever in the UK>Newcastle upon Tyne and we'll go for a few drinks.

    Have a great evening!
     
  8. TitoPartija thread starter macrumors newbie

    Joined:
    Jul 19, 2017
    #8
    My issues were indeed somewhat solved; I could boot my computer successfully and access all the files. However, it may indeed be the case that the replacement cable is partially defective, or, what other users said, that my HDD is slowly giving up on itself (it is five years old after all).

    So, instead of ordering new cable and repeating the aforementioned process, I will simply swap the old HDD with a new SSD and report here in a couple of days. Thank you for your inputs and have a great weekend!
    --- Post Merged, Jul 20, 2017 ---
    Thank you so much for your tips, I will definitely look up some solid state drives and backup and swap my HDD with a new SSD. That's very kind of you, I always wanted to visit Great Britain and would love to buy a drink or two to a person whose inputs will probably save my computer (*fingers crissed*).

    I will report here in a couple of days, so that the others with a similar issue could benefit from it.

    Thanks again and have a great weekend!
     
  9. RickyB macrumors regular

    Joined:
    Oct 28, 2007
    #9
    Sorry to hijack this thread, but I am having similar issues to the OP, and replacing the HDD and installing an SSD hasn't worked for me. I used this HDD cable - https://www.amazon.co.uk/gp/product/B019VZGT7C/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1 - not an official apple part, but it worked in the past. The power light which I think is connected to this cable has stopped working, however.

    I used this SSD - https://www.amazon.co.uk/gp/product/B01F9G43WU/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

    When it it working properly. it is incredibly fast, but I get regular beachballs, hangs, restarts etc. These happen most often when I am downloading large files or installing things. I thought it was due to the fact I had used migration assistant to restore from my previous hard disk but it also happens when I set it up as a completely new Mac.

    Any ideas? Thanks.
     
  10. BLUEDOG314 macrumors regular

    BLUEDOG314

    Joined:
    Dec 12, 2015
    #10
    Not going to individually quote questions to get peoples' attention but generally here are a few things I wanted to respond to. If using a backup and migrating from time machine to a SSD after replacing the hard drive, if issues persist it is almost certainly software related. Now potentially the replacement bracket cable is an issue, but if smart utility shows no CRC errors this is probably not the case.

    Since the machines we are speaking of are at newest 2012 models, there is no point in spending a premium on a SSD. a reliable brand and good price is what I would shoot for. I went with an MX300 in my early 2011 13" and its great.

    In my experience Disk Utility is largely useless. Yes, it can identify some issues but can rarely fix directory issues beyond the basics. If you have another Mac and are equipped to do target disk mode between the two, DiskWarrior is by far the best option for repairing software directory issues.

    If taking the time to install an SSD I would also do two things. First, do yourself a favor and take the time to do a clean OS install, manually drag and drop your content like pictures, music, docs, etc, then cleanly reinstall all programs. Second, when done the clean install as soon as you're at the desktop, go to terminal and enable TRIM by typing "sudo trimforce enable" without quotes. Third party SSDs will not use TRIM by default.
     
  11. RickyB, Aug 20, 2017
    Last edited: Aug 20, 2017

    RickyB macrumors regular

    Joined:
    Oct 28, 2007
    #11
    Thanks very much. In my case, I have done a clean install and have enabled TRIM. I hadn't heard of SMART Utility, and when I ran a short test is completed without error. When I rang a long test, however, I get "Interrupted (host reset)". Any ideas what this might mean? Is it an issue with the drive or the cable?

    Thanks.

    EDIT: Just did a Long Test and it has passed without error. I should say that the computer has been working perfectly for the past couple of days, so I will probably just leave it for now. If it becomes temperamental again, I'll have to look into in further.
     
  12. TitoPartija thread starter macrumors newbie

    Joined:
    Jul 19, 2017
    #12
    It took me more than 'a couple of days', but in case somebody stumbles upon this thread in the future, I'd like to offer a quick review of things how they happened, maybe it will be of some help:


    1. After replacing the HDD cable; HD worked, but was still extremely slow and unresponsive
    2. I replaced my original HD with a Samsung SSD - however the problem explained above persisted even with a new HDD cable and a new SSD
    3. Returned the replacement HDD cable, ordered three different ones off the Internet and one out of three did the trick!
    4. Returned three (yes, three!) replacement HDD cables that didn't work, the laptop runs smoother and faster than ever.


    If there is a bottom line to my little adventure, it'll probably be the fact that the HDD (now SSD, wohoooo!) cables are most obvious culprit for flashing question mark issue and that the first one you order might not be working properly. It could also be due to the fact that I did something wrong in my attempt to replace the cable, but snooping some more around the forums made me realize that is sadly a common issue. Good luck and thank you all once again!
     

Share This Page