MBP Keyboard Lights

Discussion in 'MacBook Pro' started by nburwell, Jan 15, 2009.

  1. nburwell macrumors 68030

    nburwell

    Joined:
    May 6, 2008
    Location:
    PHL
    #1
    Long story short - I took my MBP to my local Apple store to have the trackpad fixed since it was coming up from the casing. Anyway, I haven't extensively used my MBP until tonight when I noticed that my keyboard lights no longer work. Yes, I shut off all the lights in my room, and even installed Lab Tick, but to no avail. I'm going to be really disappointed if Apple caused this and I have to be without my laptop again for almost a week.

    Is there anything else to suggest that I can do before I have to bring my MBP once again back to Apple? Thanks in advance.
     
  2. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #2
    Did you use F6 key to turn up the backlit setting? F6 is turn light on and F5 is turn it down. Check that.

    Protip: Just cover your iSight camera horizontally with your thumb to make the MBP think its in the dark.
     
  3. nburwell thread starter macrumors 68030

    nburwell

    Joined:
    May 6, 2008
    Location:
    PHL
    #3
    I just tried both F6 and covering up the iSight camera, and still nothing. Thanks for the suggestions though.
     
  4. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #4
    Covering the iSight is not deal, covering the ambient light sensor is, which is next to the iSight. Sorry, didn't explain that part.

    If nothing works, call Apple Care. Arrange everything on the phone and avoid an Apple Store. I have by experience learned that Applecare is waaaaay better than service at a store.
     
  5. EvryDayImShufln macrumors 65816

    EvryDayImShufln

    Joined:
    Sep 18, 2006
    #5
    You have a 2.2ghz MBP as per your signature? The ambient light sensor is on both sides inside the speaker grills.
     
  6. iJesus macrumors 6502a

    iJesus

    Joined:
    Jun 30, 2007
    Location:
    Reno, Nevada
    #6
    Also make sure it's turned on in system preferences...
     

    Attached Files:

Share This Page