Resolved Media Buttons not working IN iTunes

Discussion in 'macOS Mojave (10.14)' started by GigaWarTrex, Apr 17, 2019.

  1. GigaWarTrex, Apr 17, 2019
    Last edited: Apr 18, 2019

    GigaWarTrex macrumors newbie

    GigaWarTrex

    Joined:
    Apr 8, 2017
    Location:
    Germany
    #1
    SOLUTION: The media keys IN iTunes are for some odd reason (or maybe a bug) internet bound. No internet means they don't work in iTunes but just fine for every other Media Player etc. I will contact Apple and ask if I have the time in the near future. If something substantial is said I will update this post.

    Hi everybody,

    so I ran into this problem on a car trip today but I can track it back to 2 scenarios that probably caused it. More about that later.

    Since macOS (High) Sierra there were a few problems with the media keys... and they are pretty popular as I found out on Google.
    Whatever, from time to time my media keys would not work anymore.
    Steps like
    -NVRAM/PRAM reset
    -SMC reset
    -Safe Boot Mode for fixing
    -Resetting Keyboard shortcuts
    -Checking and unchecking how function keys are used etc.
    worked for me at that time, but not anymore.

    When l'm at my desktop and press the >= (Play) key, iTunes opens up normally. But after that not one key, be it << (Previous), >= (Play) or >> (Next) works anymore. I can simply not use them.
    BUT, if I use VLC or MediaPlayer to play a movie or music file I can use my media keys just fine to control them (VLC / MP) even if thy are in the background.
    I think this is normal macOS behavior to bind the last used media program to the media keys.
    So, I confirmed that my media buttons are not broken, I tried many things I knew or Google told me and am now at the point where I believe that it might be a serious OS problem that I can only fix with a fresh installation of macOS :(
    I hope someone in this forum maybe knows a fix to my problem.

    Some other stuff I noticed:
    In the Notification Center a Widget named "Now playing" exists. If I press it's play button it also opens iTunes but can't do any more. If I start playing a song in iTunes it also doesn't show me this in the widget. This let's me believe it may be a more serious software problem.

    Now about what I think maybe caused the Problem:
    1) I updated to the newest macOS Mojave 10.14.4 . Before this I did not have any problems. I always am sure to have the newest stable software releases. So it wasn't a huge software jump that maybe could have caused a problem.
    2) A few days ago I connected a bluetooth Keyboard to my MacBook. It was a Mouse + Keyboard combo that connected to a USB antenna that I plugged into my MBP. During the setup of the keyboard Layout (where you have to press a few buttons so Mac can identify the Layout) there was a weird glitch and the setup failed... did not try it again after that.

    Every help is much appreciated, thanks to you all! Good day!

    Specs:
    macOS Mojave 10.14.4
    iTunes 12.9.4.94
    MBP (Retina, 15", Mid 2015)
    - i7 QuadCore, 16GB RAM, 512SSD, AMD and Intel Graphics Card
     
  2. crjackson2134 macrumors 601

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #2
    The media keys don't work properly when you have an internet connection. Possibly also when iTunes isn't properly signed in. I haven't test the iTunes thing, but it IS internet-bound.
     
  3. GigaWarTrex, Apr 18, 2019
    Last edited: Apr 18, 2019

    GigaWarTrex thread starter macrumors newbie

    GigaWarTrex

    Joined:
    Apr 8, 2017
    Location:
    Germany
    #3
    THAT could really be a thing! At the moment I am out of house and have absolutely no access to Internet (on my MBP). Will test and reply when I am back at home. Thanks a lot.

    EDIT / SOLUTION: Thank you VERY MUCH good sir! This exact thing was the problem. I just had a few spare minutes and hooked my MBP up to a Hotspot I hosted with my iPhone. I can now control iTunes normally again (even if it is in the background). If I cut the Hotspot this functionality immediately goes away :mad: .
    Very very stupid feature / bug imo but at least I now know that software wise everything is working "normally".
    Good day y'all!
     
  4. crjackson2134 macrumors 601

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #4
    You’re welcome. I’m not crazy about the way it works either.
     

Share This Page

3 April 17, 2019