Messages not syncing to watch

Discussion in 'Apple Watch' started by JWalker1995, Apr 24, 2015.

  1. JWalker1995 macrumors regular

    Joined:
    Mar 5, 2011
    #1
    Hi All,

    After setting up my watch, going into the messages app shows no messages and when i send a message, it sends mine but the watch app shows "unable to send message" is this a known bug with the first software? I have tried resetting the watch.

    (Please do not comment with "this is only version 1 chill out". I work as an iOS developer for a living so know how this works, just want to know if its a known bug)

    Thanks
    James
     
  2. segrobja macrumors regular

    Joined:
    Sep 20, 2013
    Location:
    NYC
  3. spoa94 macrumors 6502a

    spoa94

    Joined:
    Oct 12, 2011
    Location:
    New Orleans, LA
    #3
    Same exact issue. If you have two factor identification (or whatever its called) then you need to do an extra step to get messages working. You need to log into your Apple ID page and under security and passwords you need to create an app specific password. Call the app Messages. Restart the watch. Then you will be prompted to enter you iCloud password on your phone. Instead of the normal password you need to type in the one created for Messages specific. DONE.
     
  4. JWalker1995 thread starter macrumors regular

    Joined:
    Mar 5, 2011
    #4
    You Sir are a genius!! Much Apple love to you <3:apple:
     
  5. lewisd25 macrumors 6502a

    Joined:
    Jul 6, 2007
    #5
    Ok...I have this exact issue, but I don't use 2-factor authentication. Any help?
     
  6. JWalker1995 thread starter macrumors regular

    Joined:
    Mar 5, 2011
    #6
    Try following the steps? Turn watch off, turn watch on, open messages app with iPhone unlocked and see what happens?
     
  7. kmichalec macrumors 6502a

    Joined:
    Aug 14, 2010
    #7
    I was having the exact same issue. It was the 2 step authentication for me. Followed Spoa94's suggestion. Worked like a charm. Thank you!!!
     

Share This Page