MineCraft Wont Open In Mac OSX

Discussion in 'Mac and PC Games' started by MunkeyMac, Aug 8, 2011.

  1. MunkeyMac macrumors newbie

    Aug 8, 2011
    Hi Crafters....

    so i finally downloaded Minecraft Beta 1.7.3 (the latest one)

    i downloaded the zip file extracted the folder with the .app file inside it and click it to run minecraft, the usual messages about when it was downloaded came up like with all software but when after that the app closed itself.

    I tried several times to get it to work but nothing would happen, it would appear in the dock for a slit second and then close.

    i looked in the Application Support folder and there wasn't any minecraft folder there as suggested in other forums, the only way i could get it to run was to go to the minecraft app and "show package contents" then filter through the folders to the "MinecraftLauncher.jar" file and run it using that, which opens "net.minecraft.MinecraftLauncher.jar" in my dock.

    This put the required folders into the application support folder but im assuming that this isn't the correct way of installing it as now there isn't any sound in game, all settings are on and my Java is on the latest version, apple update has nothing to install and the only way i can continue to run minecraft is by using that .jar file mentioned above.

    could you please explain what is it im doing wrong, im going to start from scratch again from a fresh install so all suggestions given will be for a fresh install and hopefully this time it will work.

    I have a:
    MacBook Pro
    Snow Leopard 10.6.8
    2.8 GHz Intel Core 2 Duo
    4GB 1067 MHz DDR3

    everything is up to date and Java is running the latest version, i tired a reinstall of Java but still doesn't work.

    thank you in advance.
  2. MunkeyMac thread starter macrumors newbie

    Aug 8, 2011
    Theres a fix ! ! !

    its ok fixed now...

    i got a suggestion on another forum and it worked like a charm.

    for any others that get this problem here is the fix.....

    Most likely minecraft does not have permission to launch. Put the Minecraft.app on the Desktop an type (or copy/paste) the following in Terminal

    chmod +x ~/Desktop/Minecraft.app/Contents/MacOS/JavaApplicationStub
  3. extacyz macrumors newbie

    Sep 14, 2011
    thank you it worked i just bought the game and i thought it was just a waste of money but it works now thanks :):):):):):):):)
  4. Jaecobae25 macrumors newbie

    Nov 26, 2012
    Mincraft For Mac os x

    what is the "terminal" ?

Share This Page