Missing Underscan Slider

Discussion in 'Mac mini' started by Acronyc, Sep 25, 2011.

  1. Acronyc macrumors 6502a

    Jan 24, 2011
    Last week I found a great deal on a 2009 mini in really good condition so I picked it up to use as an HTPC. After adding 4GB of RAM, a reformat, clean install of SL and then Lion it’s running like a champ. The only problem I’m having is solving an overscan/underscan issue. When I have it plugged in to my 32” 720p TV through Mini DP -> HDMI, if I have the overscan option selected the edges get cut off, but if I don’t have it selected the entire image is very small. I have messed around with the options on my TV and the Mini and no matter what I do, I can’t get it to display at the right resolution. I tried SwitchResX as well, but I could never get it to work right. The Mini looks great when connected via Mini DP -> VGA, but that defeats the purpose of what I want to use it for, as I can’t play any of my HD iTunes content due to HDCP.

    I think the problem is that my Mini is missing the underscan slider in the display preferences. When I connected my 2010 11” MBA to my TV I had the same problem as my Mini, but the MBA has a nifty little underscan slider that can solve the problem of the cut off edges. This slider is not on my Mini, however, and I’ve hooked it up to two other monitors and it never shows up even though it’s there on my MBA. After a little bit of searching online I found that this slider seems to have been new to SL and solved a lot of the overscan issues, but it is completely missing from my system. Does anyone have any idea as to why the underscan slider is missing? Is there a way to enable it? Or is my only option SwitchResX? Thanks in advance for any help!
  2. Detrius macrumors 68000

    Sep 10, 2008
    Asheville, NC
    Generally if something like that is missing, it's because the hardware doesn't support it.

    For example: the "detect displays" button. It was added a long time ago, but when it was added, it was only supported by newer graphics cards, and it was missing on older machines.
  3. organik macrumors member

    Jun 30, 2007
    Had the underscan, ML update and now I don't. Any ideas?
  4. philipma1957, Jan 5, 2013
    Last edited: Jan 5, 2013

    philipma1957 macrumors 603


    Apr 13, 2010
    Howell, New Jersey
    go to your backup and run the older version of osx. the last time I gave this as an answer the poster must have said f u to me more then 100 different ways. ( he had no back up and perceived my answer as that of a wise guy.)

    My answer is not nasty or sarcastic. My answer is hopeful that you have a back up. if you don't there are other ways to fix it. but they will be slow. every way I have to fix it involves going to the older version of os one way or another. you can google mac under scan program and see what you get.
  5. Darby67, Jan 6, 2013
    Last edited: Jan 6, 2013

    Darby67 macrumors 6502

    Jul 5, 2011
    the corner of Fire and Brimstone
    Are you connected to a TV via HDMI or a computer monitor? What brand and type? There are settings in many TVs that may need to be changed.
  6. sno1man macrumors regular

    Oct 24, 2011
    I have the opposite issue- but have a workaround

    Before you go to what would be a lot of work to restore from back up, try this first.

    I have the opposite problem as you with my 2012 mini. When my dell monitor is plugged in, the mini sees it as a TV instead of a monitor and shows the under scan slider.

    This creates issues with maximum and minimum white levels among other issues.

    The workaround I found is annoying but effective. In my case, I simply make sure that the mini is fully booted BEFORE I plug the monitor in to it. When I do that, it sees the display properly. The giveaway was that when it's failing, the displays control panel reports it as a generic display, but when I do this it properly identifies the brand and model.

    My guess is that the "handshaking" that occurs doesn't work right if the monitor is already plugged in and powered on when the mini boots.

    One additional step that was needed to keep from having to do this again if the system goes to sleep was to set the energy saver control panel to "never" on system sleep.

    Hopefully Apple will fix this with an update. I reported the issue and they were able to replicate it.

    Hope that helps

Share This Page