MMS doesn't work

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Shag88, Apr 6, 2011.

  1. Shag88 macrumors member

    Joined:
    Jul 9, 2008
    #1
    I have an iPhone4, and was previously running 4.2.1, jailbroken with greenpois0n. At some point (not sure when), MMS stopped working - I can't send or receive MMS.

    I just tried restoring to 4.3.1, and loading my backup, but the problem persists. I've also tried resetting my network settings multiple times. Any idea how I can fix this? I'm wondering if it's something in my backup, but I *really* don't want to lose all my data (txts, game saves, etc)...
     
  2. wordoflife macrumors 604

    wordoflife

    Joined:
    Jul 6, 2009
    #2
    Did you turn off cellular data (under network settings) by accident?
     
  3. TruckdriverSean macrumors 6502a

    Joined:
    Feb 28, 2009
    Location:
    Texas, US
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    I would also stop by my carrier's store and have a quick chat about your plan. They do goof up on their end occasionally.
     
  4. Shag88 thread starter macrumors member

    Joined:
    Jul 9, 2008
    #4
    Cellular data is definitely enabled. I've also tried disabling wifi and 3G, but no change.

    I talked with AT&T when I was on 4.2.1, and they confirmed that my plan was fine. They suggested the upgrade to 4.3, as they claimed there were some MMS bug fixes in that release. Guess I have to call them again - ugh...
     
  5. OMGbrandon macrumors 6502

    OMGbrandon

    Joined:
    Jun 29, 2010
    Location:
    Miami, FL
    #5
    Restore and leave it set as new, and check if MMS works.
     
  6. Shag88 thread starter macrumors member

    Joined:
    Jul 9, 2008
    #6
    Doesn't even work when I restore and set it up as a new phone. WTF?
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    Yep, its gotta be on AT&T's end.
    Dont let them brush you off saying its a bug with 4.3.1
    That's BS, MMS works fine. If the rep just tries to get rid of you hang up and call again and you will speak to someone different. Ask them to transfer you to tech support if they cant or are unwilling to help you.
     
  8. nunes013 macrumors 65816

    nunes013

    Joined:
    May 24, 2010
    Location:
    Connecticut
    #8
    This happened to my mom on 4.3.1. I did a hard reset and it's good now. Maybe try that. Hold down sleep and home button together until you see the apple logo show up.
     
  9. Shag88 thread starter macrumors member

    Joined:
    Jul 9, 2008
    #9
    After a while on the phone with AT&T again, it turned out to be an issue with AT&T. They eventually re-registered my phone on the network, which resolved the issue...
     

Share This Page