Mobile site doesn't always work on my iPhone

mrsir2009

macrumors 604
Original poster
Sep 17, 2009
7,505
156
Melbourne, Australia
Hi,

When I visit Macrumors.com on my iPhone it sometimes comes up with the mobile version of the site, but sometimes it comes up with the desktop version. I have no idea why, I've tried restarting Safari and reloading the page and that... Has this happened to anyone else?
 

robpow

macrumors regular
Feb 10, 2007
226
8
Yep, same here. Started the other day. I closed all tabs and Safari, cleared the cache and the mobile site came back. Until today. Now I'm stuck with the desktop version.
 
Last edited:

mrsir2009

macrumors 604
Original poster
Sep 17, 2009
7,505
156
Melbourne, Australia
I wish we didn't have to rely on MacRumors to detect what sort of device we're using. Why not have macrumors.com for the desktop site and m.macrumors.com for the mobile site? Thats what lots of others do.
 

arn

macrumors god
Staff member
Apr 9, 2001
15,266
3,409
Hi,

When I visit Macrumors.com on my iPhone it sometimes comes up with the mobile version of the site, but sometimes it comes up with the desktop version. I have no idea why, I've tried restarting Safari and reloading the page and that... Has this happened to anyone else?
Yep, same here. Started the other day. I closed all tabs and Safari, cleared the cache and the mobile site came back. Until today. Now I'm stuck with the desktop version.
That's strange. You guys toggle to the desktop version sometimes?

If you are on the desktop version, you can tap on the Mobile Link on the footer. iPhone safari caches aggressively, so once you hit that link, you might have to reload the page for it to "take".

arn
 

SandboxGeneral

Moderator emeritus
Sep 8, 2010
26,482
9,986
Detroit
Hmmm.. I'm not having any issues with the mobile site loading on my iPhone. And I do keep a Safari page open for the mobile site and another one for the full site. I keep the full site so I can see if there are any quote notifications and then usually use the mobile one to read/reply to threads when I'm not at my computer.
 

mrsir2009

macrumors 604
Original poster
Sep 17, 2009
7,505
156
Melbourne, Australia
I restarted my iPhone (well, it ran out of battery actually) and I was presented with the mobile version of MR when I visited the site. I went down to the bottom and hit "go to desktop site" to test if I could get back the same way. As soon as I clicked the link MR went into desktop mode. So I scrolled down to the footer and clicked on the "go to mobile site" button, and it reloaded with the desktop version again. I reloaded the page several times, clicked the link again, then reloaded it several more times, but to no avail.

It seems that I can get to the desktop site from the mobile site perfectly fine, but getting to the mobile site from the dektop site is inconsistant.
 

robpow

macrumors regular
Feb 10, 2007
226
8
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

Seems fixed now, I consistently get the mobile version again on the iPhone.

I did toggle to the desktop version and then back but switching back to mobile didn't do anything at the time, it still loaded the full version.

All is well now though.
 

Zxxv

macrumors 68040
Nov 13, 2011
3,558
1,102
UK
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A406 Safari/7534.48.3)

I get the mobile version but tons of page load errors. So I can only see One or two subjects or one or two posts.
 

arn

macrumors god
Staff member
Apr 9, 2001
15,266
3,409
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A406 Safari/7534.48.3)

I get the mobile version but tons of page load errors. So I can only see One or two subjects or one or two posts.
Can you send a screenshot to tips@macrumors.com

arn
 

Zxxv

macrumors 68040
Nov 13, 2011
3,558
1,102
UK
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A406 Safari/7534.48.3)

arn said:
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A406 Safari/7534.48.3)

I get the mobile version but tons of page load errors. So I can only see One or two subjects or one or two posts.
Can you send a screenshot to tips@macrumors.com

arn
Done :)
 

adcx64

macrumors 65816
Nov 17, 2008
1,227
42
Philadelphia
I have sorta the same problem. Sometime the mobile version will open randomly on my iPad. Is the iPad supposed to default to the desktop or mobile version? I like the desktop one..l
 

robpow

macrumors regular
Feb 10, 2007
226
8
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

I started getting the full site on my iPhone again today. I went to the forum page and clicked Log Out which restored the mobile view. Funnily enough I was still logged in on the mobile site.
 

Zxxv

macrumors 68040
Nov 13, 2011
3,558
1,102
UK
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A406 Safari/7534.48.3)

I'm getting more and more page load errors. All different.
 

mrsir2009

macrumors 604
Original poster
Sep 17, 2009
7,505
156
Melbourne, Australia
I have sorta the same problem. Sometime the mobile version will open randomly on my iPad. Is the iPad supposed to default to the desktop or mobile version? I like the desktop one..l
If you go down to the bottom of the page and choose the desktop version it should stay that way on your iPad until you reset Safari or something.
 

Zxxv

macrumors 68040
Nov 13, 2011
3,558
1,102
UK
Mobile site pretty much useless for me. When I goto read a forum or topic I only get 1-3 topics/posts
 

SandboxGeneral

Moderator emeritus
Sep 8, 2010
26,482
9,986
Detroit
Wirelessly posted (iPhone 4S: Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

Zxxv said:
Mobile site pretty much useless for me. When I goto read a forum or topic I only get 1-3 topics/posts
On the very bottom of the mobile page, go to Home, then My Prefs, then Post Options. You can have it display up to 30 posts per page. Do the same for Thread Options, you can have up to 30 threads display at a time.
 

Zxxv

macrumors 68040
Nov 13, 2011
3,558
1,102
UK
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A406 Safari/7534.48.3)

SandboxGeneral said:
Wirelessly posted (iPhone 4S: Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

Zxxv said:
Mobile site pretty much useless for me. When I goto read a forum or topic I only get 1-3 topics/posts
On the very bottom of the mobile page, go to Home, then My Prefs, then Post Options. You can have it display up to 30 posts per page. Do the same for Thread Options, you can have up to 30 threads display at a time.
Sorry but your not understanding. I get error messages. The owner knows and asked me to send screens shots. But still getting the errors.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.