Mojave install failed miserably - no wifi or magic devices

davidjmarks

macrumors newbie
Original poster
Jul 24, 2015
11
1
Trappe, PA
Anybody seen this?

I have a late 2017 iMac 18,2 with 16gb memory and 1tb fusion drive. I have three outboard drives, an outboard USB hub, and two displays.

Installed Mojave by downloading from app store. After logging in got "No Wifi Hardware Installed." Magic Mouse and Magic Keyboard would not connect. Connected USB mouse and keyboard. System runs sluggishly.

Pulled power cable from wall and reboot. No change.

Booted to recovery mode and reinstalled Mojave. Same result.

Called Apple.

First thing to try was to reset SMC on reboot. That caused the boot up to hang with the apple logo and progress bar all the way done.

Next reinstall Mojave from recovery mode. Rebooted and still no wifi or magic mouse or keyboard.

Next reset NVRAM and PRAM. Same result as when resetting SMC. Hang on bootup.

Next boot with D for hardware diagnostics. No hardware problems.

Apple then tells me to reinstall from backup (revert to High Sierra) and wait for Mojave 10.14.1. Then do an install. High Sierra works just fine.

WTF?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.