Most Applications Won't Start

Discussion in 'iOS Apps' started by Kaeonadai, Jul 11, 2008.

  1. Kaeonadai macrumors newbie

    Joined:
    Feb 27, 2008
    #1
    I bought a few apps on my old iPhone yesterday. I bought an iPhone 3g today. I finally got it working, but none of my apps will launch. They show the opening screen, then kick me back to the home screen.

    Is anyone else having this problem?
     
  2. SheepNutz macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Kantuckee
    #2
    I had the same problem earlier (using yesterday's firmware, not today's official firmware). My phone was acting sluggish, so I restarted it. Upon restart, I got the connect to itunes screen! I did a hard reset, and my phone restarted fine, but 3 of my apps (holdem, monkey ball, and the dice poker game) would show the first screen then crash. I turned my phone off and left it off for 5 minutes (to drain the capacitors) and that fixed the problem.
     
  3. greenmymac macrumors 6502a

    greenmymac

    Joined:
    Oct 25, 2007
    Location:
    Tulsa, Ok
    #3
    I had the same problem then I restored my phone to todays firmware
     
  4. xjames macrumors member

    Joined:
    Feb 12, 2008
    Location:
    Brazil
    #4
    Had the problem. Turn the iphone (16gb, not-3g) off and on, and it solved the problem for good.
     
  5. mrl72 macrumors regular

    Joined:
    Apr 20, 2008
    #5
    I had the same problem after syncing with my mac. The only way I could get the apps to work was reinstall them all.
     
  6. heathnat Guest

    #6
    Same issue - apps won't launch after install/sync/restart

    I have the same issue - I've had my iPhone 3G for two weeks now and every time I restart, sync, or update the iPhone's software (I just went to 2.0.1) all of my App Store (ie non-native) apps will only open with the front page, then exit. No error message, no nothing, they just disappear. I used to be able to reset the iPhone one more time and that would fix it. Now after updating to 2.0.1 That doesn't even do it - I have to reinstall every app. :-(
     
  7. digbyp macrumors regular

    Joined:
    Jul 10, 2008
    #7
    I have had the problem twice. In my case, it seemed to be caused whilst updating apps from the App store on iPhone whilst using Edge, updating more than 1 app at the same time.

    So for now, (have upgraded to v2.0.1), when there are more than 1 updates, I will update seperately and wait until finish, before I update the next one.
     
  8. cocky jeremy macrumors 68040

    cocky jeremy

    Joined:
    Jul 12, 2008
    Location:
    Columbus, OH
    #8
    Double check that you aren't on 1.1.4 because i restored and accidently restored to 1.1.4 and somehow still had the App Store, and they would crash as soon as i'd try to open them.. oooooops. lol.
     
  9. Silver-Fox macrumors 65816

    Silver-Fox

    Joined:
    Jan 8, 2007
    Location:
    England
    #9
    Try just turning it on and off thats what i did and it worked fine
     
  10. arn macrumors god

    arn

    Staff Member

    Joined:
    Apr 9, 2001
    #10
    as people have said, it can be various problems.

    The steps are

    1) Turn iPhone off and on

    2) If not fixed, delete apps from iphone and reinstall (redownload or resync)

    3) If still not fixed, restore firmware.

    arn
     
  11. okrelayer macrumors 6502a

    Joined:
    May 25, 2008
    #11
    everyone should open iTunes, click on the store pannel (up by file, edit ect) press authorize computer!

    then delete the apps manually off of the phone, re-sync them from your computer to the phone.

    that SHOULD cure it. I had the same problem when i first got the phone. It got to the point where i did not sync ANY of my apps, and only kept them/and downloaded them unto the phone. Doing that allowed the apps to work. However, doing the authorization aswell as the delete/resync should cure all of the issues.
     
  12. lmanton macrumors newbie

    Joined:
    Aug 6, 2008
    #12
    It works!

    Just wanted to say a huge thanks, it worked a treat.

    Cheers


     

Share This Page