Most of my Steam Games don't work...Help!!

Discussion in 'Mac and PC Games' started by aeolyn5601, Oct 7, 2010.

  1. aeolyn5601 macrumors member

    aeolyn5601

    Joined:
    Jun 18, 2010
    #1
    Hey guys. I have a 13" Macbook Pro (2009) and I have Steam. I bought the Orange Box and had all the games working great. I got CS:S and it worked fine. a few weeks ago I tried to play HL:2 (after redownloading it) and it didn't work. Then I bought Garry's Mod and it didn't work, specifically it would open the window hl2_osx like it does for all Steam games for Mac that I use. I redownloaded Portal, HL:2 eps 1 & 2 and they didn't work either. The only games that work for me are TF2 and CS:S. Oh and I bought L4D2 and it doesn't work either. I talked with Steam support and they had me try 9 different things before telling me to restore my system and only installing Steam and downloading the games, which I really can't do since I can't find my restore discs. Anyone else have this problem and know what to do? I really don't want to have to boot into my Windows partition every time I want to play my Steam games. Thanks guys!

    Edit: So last night I moved to a new hard drive, and since I can't find my OS restore disk, can't get the drivers. I guess I won't be playing my other games for now! Oh Boy!
     
  2. cluthz macrumors 68040

    cluthz

    Joined:
    Jun 15, 2004
    Location:
    Norway
    #2
    Some information please?

    Which OS version do you have?
    "Not working" is a pretty general term, do they start at all? crashing? any error messages?

    Which 9 things have you already done?
     
  3. Hastings101 macrumors 68000

    Hastings101

    Joined:
    Jun 22, 2010
    Location:
    K
    #3
    Honestly, it sounds like you might need to reinstall your system - something definitely does not sound right. Sucks that you don't have the discs :(
     
  4. frikork macrumors newbie

    Joined:
    Dec 7, 2010
    #4
    i have Garry's Mod on my mac, but when I tried to play multiplayer. I couldn't
    play on the different servers because map was missing. So I went Garry's Mod.org and tried to downloads maps, but I don't know how to open the maps in Garry's Mod. Can someone please help me??
     
  5. Huntn, Dec 7, 2010
    Last edited: Dec 7, 2010

    Huntn Suspended

    Huntn

    Joined:
    May 5, 2008
    Location:
    The Misty Mountains
    #5
    Has the OP corrected the problem? I assume so, but what I would have done is reinstall Steam. As part of the process, Steam Content may of had to be downloaded.

    * Trash the Steam application.

    * In the Library folder>Application Support folder, there is a Steam Folder with Steam settings and the SteamApp folder where game content is stored. This is where there are some choices. Copy this folder to another location, then trash both the Steam app and this Steam folder. The reason for doing this is to reinstall Steam and try to avoid downloading all of your game content from scratch. The problem with this strategy is that you may end up reintroducing the problem back into Steam.

    * Resintall Steam and see if it will run. Then what I would do is take the new Steam folder (the one in the Application Support folder) and copy/save it to another location. This is so you can restore it if the following does not work. Then take only the SteamApps folder from the original Steam folder (the one you moved) and put it back into the new Steam folder replacing the new SteamApp folder. Now see if the games in question work.
    * If they don't work, you might as well revert to the new install by putting the new Steam folder back into your Application Support Folder and after verifying that Steam will run, start downloading your games from scratch.
     
  6. frikork macrumors newbie

    Joined:
    Dec 7, 2010
    #6
    i have tried what you said now and now I am just downloading Garry's Mod. So I hope I can play the different servers on multiplayer without the message: missing map rp downtown v2
     
  7. frikork macrumors newbie

    Joined:
    Dec 7, 2010

Share This Page