My iPhone sound is not working all of sudden >:|

forza69

macrumors 6502a
Original poster
Jan 30, 2010
761
79
San Diego, CA
So yeah, I just got home from work and I noticed that my phones sounds aren't working properly. By that I mean, the volume is super low and it sounds staticky :confused: It was working fine yesterday and this morning. I haven't dropped it or anything. And I keep getting a message saying that this accessory is not compatible with this iPhone and it may interfere with signal strength, or something like that. I don't have any accesories near it! Anyone know the cause of this, or that has had this happen to them? Please help!
 

Block

macrumors 6502a
Jun 28, 2007
843
1
Just restart your iPhone to see it fixes the problem (Hold the sleep button at the top of the phone until a restart slider appears, and then slide it). The sound on the iPhone isn't that great to start with though....
 

forza69

macrumors 6502a
Original poster
Jan 30, 2010
761
79
San Diego, CA
Just restart your iPhone to see it fixes the problem (Hold the sleep button at the top of the phone until a restart slider appears, and then slide it). The sound on the iPhone isn't that great to start with though....
I already rebooted the phone. I know what my phone sounds like, and it didn't sound like this. I can't hear anything when I use speaker phone, only if I put the speaker right to my ear. And yes, the volume is all the way up and the speaker selection on my voicemail is on, and speaker is on when on a call. Still can't hear it.
 

Block

macrumors 6502a
Jun 28, 2007
843
1
Plug a pair of headphones into the headphone jack and play a little bit of music and then unplug it. Do it 2-3 more times and then tell me if the audio improves.
 

iSaxon

macrumors 6502a
Jun 19, 2010
710
19
Pittsburgh, PA
Also try plugging it into your computer... Since it is saying Accessory not Compatible, I figured it is something with the port on the bottom...
 

forza69

macrumors 6502a
Original poster
Jan 30, 2010
761
79
San Diego, CA
Plug a pair of headphones into the headphone jack and play a little bit of music and then unplug it. Do it 2-3 more times and then tell me if the audio improves.
Sounds fine with earphones, still really really really low when I remove them.
 

forza69

macrumors 6502a
Original poster
Jan 30, 2010
761
79
San Diego, CA
Also try plugging it into your computer... Since it is saying Accessory not Compatible, I figured it is something with the port on the bottom...
It's plugged into my computer right now, the message hasn't appeared anymore but the sound is still s***
 

rotobadger

macrumors 65816
Sep 18, 2007
1,272
158
Try a hard reset. Hold down home button and sleep/wake at the same time until phone shuts off.
 

tokiidokii

macrumors regular
Feb 23, 2008
122
0
i guess you can try a full restore and see if that fixes it. also when you restore, set it up as a new phone and not from back up.

but yea that is really weird :confused:
 

pound4pound30

macrumors 6502
Nov 22, 2009
431
0
i guess you can try a full restore and see if that fixes it. also when you restore, set it up as a new phone and not from back up.

but yea that is really weird :confused:
yea i tried a restore as back up and it didnt work. I am going have to try it again and set it up as a new phone
 

forza69

macrumors 6502a
Original poster
Jan 30, 2010
761
79
San Diego, CA
Well it looks like the sound is coming back, I just started blowing air into the speaker. I guess it was dirty or something, but it still sounds staticky >_> I guess I'll keep blowing it.

But now I noticed that the SMS tones aren't working at all. >_>

Ok did another hard reset and the SMS tones are back. Still, the sounds are grainy, but at least I can hear them now.
 

RiceRacerDX

macrumors 6502
Jan 31, 2009
386
0
Check your headphone jack and your dock slot thing. You may want to blow air into there and see if there isnt something that's touching or causing it to say that there is something plugged into there that it recognizes as an accessory. Also, if you have a can of air that you are blowing into the headphone jack, do so gently, as you don't want to cause damage to that component.
 

Wrathwitch

macrumors 65816
Dec 4, 2009
1,303
55
the sound on my iphone 4s isn't working but i put my headphones the sound is working
:confused:
:mad:
Some users have noted a small flaw in the iphone wherin a user unplugs their ear phones and it doesn't trip the sensor in the hole that tells the phone that the head phones are out so it doesn't work.

The general fix for this is to gently fornicate your phone speaker port with the headphone jack so that it trips back to where it should be. Or blow it out a bit if there is any dust on the contacts within the port.

Good luck.
 

Mgrispino

macrumors newbie
Aug 20, 2014
4
0
I wven tried to restart my phone to see if it will work then but it didnt. My sound just isnt working.
Any suggestions anybody??##
 
Last edited:

Mgrispino

macrumors newbie
Aug 20, 2014
4
0
Is the silent switch on the side of the phone switched to mute?

Also make sure the volume is turned up all the way using the side volume buttons.
Both of them r on and up all the way. Also wen i click the side volume buttons it doesnt show that the volume is going up. It just shows up without the white cubes that show the volume is up.