My Macbook Pro Won't Let Me Re-install OS

Discussion in 'MacBook Pro' started by tiqkfk, Aug 25, 2013.

  1. tiqkfk macrumors newbie

    Joined:
    Aug 25, 2013
    #1
    Hello,

    I am not sure if this is a common issue or has been answered in this forum before, but any comment of advice would be greatly appreciated.

    My Macbook Pro had a logic board failure about a month ago, so I had to get it repaired through Powerbookmedic.com

    I received it back without any acknowledgement from the website whether it was actually fixed or not; regardless, they charged me $400 for it. When I hit the power button to turn it on, it displayed the usual white screen with the Apple symbol background as usual (And the start-up sound). Then, it would just immediately shut itself off after about 10 seconds instead of taking me to the log-in screen.

    I tried both SMC and PRAM resets to no avail. So I tried powering it up with Command, P, R keys pushed in, which took me to the Mac OS X Utilities screen. (On this screen, the Disk Utility option is on the bottom)

    Once I got in there it let me choose my hard drive on the menu. It had Verify Disk and Repair Disk options. I started with Verify Disk which resulted in a message saying:

    "The volume Macintosh HD was found corrupt and needs to be repaired
    Error: This disk needs to be repaired. Click Repair Disk."

    When I hit Repair Disk it ran its own diagnosis for a few minutes and this message popped up:

    "Error: Disk Utility can't repair this disk..., and restore your backed-up files."
    (Photo attached)

    So basically the Repair Disk function under the Disk Utility is no good.

    I inquired the Powerbookmedic.com about it, they said it's possible that HDD had failed. They suggested I try re-installing the OS (Lion) onto the HDD. So I brought up the Utility Disk menu again (Command, P, R) and clicked Install Mac OS X. It launched a Safari window with a message saying:

    "To download and restore Mac OS X, your computer's eligibility will be verified with Apple."

    I hit Continue with Installer Log from the Safari Tab up. As soon as I hit Continue, an Installer Log window popped up saying:

    "localhost Unknown[331]: 2001-02-01 Install Mac OS X Lion[363:11707] Couldn't find app store version, falling back to hardcoded"
    "localhost Install Mac OS X Lion[363]: Can not connect to /var/run/systemkeychaincheck.socket: No such file or directory"

    I waited out to see if this so-called "eligibility check" actually did anything, but nothing happened. (I waited as long as 2 hours before I shut it off)

    At this point, I am completely lost as to what's wrong with my Macbook. Is this a continuation of the logic board issue? Or, my HDD did fail? I couldn't really get further assistance from Powerbookmedic.com.

    Any assistance would be greatly appreciated.
     

    Attached Files:

  2. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #2
    The disk may well be damaged. You'll very likely need to buy a new one. If you are within the US, I can give you a site that is well known, respected and offer great deals on HDDs.
     

Share This Page