My macbook won't read discs? Just spits them out?

Discussion in 'MacBook' started by cootersgarage6, Jan 16, 2011.

  1. cootersgarage6, Jan 16, 2011
    Last edited by a moderator: Jul 25, 2011

    Joined:
    Nov 6, 2010
    #1
    Recently my macbook has been not reading discs. Now, when I put the disc in, it makes the normal weird loud sounds that the older Macbook's make when you put a disc in them, but after about 4 minutes, it just spits it out.... I didn't know if there was any trouble shooting I could go through inside the machines utilities or not...

    Thank You!
     
  2. duke2k7 macrumors newbie

    Joined:
    Oct 2, 2010
    Location:
    UK, Midlands
    #2
    Hi,

    If you go to the system profiler and check the model of your drive, then you can check to see if there is a new firmware available from www.rpc1.org but firstly, try resetting the P RAM and SMC, that worked for me...

    If I remember correctly, make sure that your macbook is charged, then unplug the power, and shut the unit down. Take out the battery, and then hold the power button for 5 seconds. Then replace the battery and turn on.

    If that doesn't work, try shutting the unit down, then hold the apple key and the one to its left (alt key on mine with a bracnhing off line) and the p ley anf the r key, then power on, keep holding down whilst is chimes, itll shut down again and restart, let go of the keys.

    You have now reset the PRAM and the SMC, like I said this worked for me.

    Ironicall the drive in my macbook is now dead after applying the superdrive 2.1 update so dont apply that, or has the unit only started playing up after you applied this update?

    Hope that helps.

    if all else fails, you can get a cheap replacement UJ-857C drive for $39 from www.eeshops.com

    Good luck.
     
  3. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #3
    Are the disks scratched when spitted out?
     
  4. aymarp macrumors newbie

    Joined:
    Sep 4, 2012
    #4
    Hello !

    I was reading this thread since my MBP has been spitting out cds in the same way, however YES they are also scratched upon being ejected. I know this for sure because I tried inserting a brand new blank DVD as well.

    My System Configuration is as follows :


    Model Name: MacBook Pro
    Model Identifier: MacBookPro5,5
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.53 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 3 MB
    Memory: 4 GB
    Bus Speed: 1.07 GHz
    Boot ROM Version: MBP55.00AC.B03
    SMC Version (system): 1.47f2
    Serial Number (system): W89253LK66E
    Hardware UUID: E8E4A5C0-4EFA-5862-91FD-759C8FBE7DD0
    Sudden Motion Sensor:
    State: Enabled

    Disc Burning :

    HL-DT-ST DVDRW GS23N:

    Firmware Revision: SB00
    Interconnect: ATAPI
    Burn Support: Yes (Apple Shipping Drive)
    Cache: 2048 KB
    Reads DVD: Yes
    CD-Write: -R, -RW
    DVD-Write: -R, -R DL, -RW, +R, +R DL, +RW
    Write Strategies: CD-TAO, CD-SAO, CD-Raw, DVD-DAO
    Media: To show the available burn speeds, insert a disc and choose View > Refresh


    DO let me know if you have any suggestions / advice

    Thanks in advance !

    Cheers.
     

Share This Page