My Mini not reconnecting wifi after wake-ups.

Discussion in 'Mac mini' started by QuantumLo0p, Aug 18, 2011.

  1. QuantumLo0p macrumors 6502a

    QuantumLo0p

    Joined:
    Apr 28, 2006
    Location:
    U.S.A.
    #1
    I recently moved my Mini to a different area of my house and decided to try wireless before I string another gigabit cable. At first all seemed well, the Mini saw the network and connected to it right away. However, it will not reconnect to the wireless router after waking up. In network preferences the network does not show up at all. If I restart the router then the Mini seems to see it just fine but then I still have to go through the motions of specifying the network name and also the password which isn't a doable scenario to me. Any ideas?

    My Mini is a 2010 running SL.
    Router is a Linksys wrt54gx4.
    (I prefer my wrt54 with dd-wrt firmware but it's borrowed out atm)
    I think the channel is set to automatic; perhaps I should chose one?
    It's set to mixed; perhaps I should go G only?
    I have tried wpa personal and wpa2 personal; same results.
    I wonder if wep would work any better?

    I know neither wep nor wpa is secure and can be cracked in a couple minutes by an 8 year old but I don't want to leave it wide open. My other option is to run a cable which isn't a big deal because the sub-basement is still wide open but I'd like to do wireless if it's an option.

    Any ideas would be greatly appreciated.
    :)
     
  2. QuantumLo0p thread starter macrumors 6502a

    QuantumLo0p

    Joined:
    Apr 28, 2006
    Location:
    U.S.A.
    #2
    Um, got it. Settings needed a bit of tweaking.
     
  3. krburrell macrumors regular

    Joined:
    Dec 5, 2007
  4. mikochu macrumors member

    Joined:
    Jul 24, 2011
    #4
    I'm having a similar issue, but on boot-up. A window pops up on startup saying that it can't connect to any preferred wifi networks, but lists my preferred network in the available network list. What gives? :(
     
  5. QuantumLo0p, Aug 19, 2011
    Last edited: Aug 19, 2011

    QuantumLo0p thread starter macrumors 6502a

    QuantumLo0p

    Joined:
    Apr 28, 2006
    Location:
    U.S.A.
    #5
    I don't know but I will post back if I have an answer...

    Bad news, it reverted back to non-connecting again. I really thought I had it stable; everything was set to basic, more or less. I even went back to G-only and the lowly, infamous wep standard. I tested it using sleep, restarts and shutdowns but this morning I found it without a connection when I logged in. About the only thing left I can think of is maybe a user lease time setting in the router.

    I am definitely more of a physical connection kind of person so I am definitely not a wifi expert by any means. I could very well be missing something but I suppose it is possible there is something in my old router the Mini simply doesn't like.

    There really isn't much more to change around so I will try a couple more settings and hopefully I can find a solution. I will post my result back here; perhaps it will help someone else as well. :)

    Plan B is to to go back to using gigabit cabling which definitely works and is much faster between nodes anyway. I heavily rely on this computer so if I cannot make a solid wifi connection then a cable is my only solution. *sighs*
    :rolleyes:
     
  6. kteboyle macrumors newbie

    Joined:
    Jul 21, 2011
    #6
    I have been having the same issue.

    Update your OS as a first step. It was a known issue with lion, and the latest release supposedly improved the wifi connection issues. I just updated lion yesterday, but I haven't had the opportunity to test it out yet.
     
  7. mikochu macrumors member

    Joined:
    Jul 24, 2011
    #7
    The issue started happening after I updated to 10.7.1 lol.
     
  8. QuantumLo0p thread starter macrumors 6502a

    QuantumLo0p

    Joined:
    Apr 28, 2006
    Location:
    U.S.A.
    #8
    At the moment I am running Snow Leopard and it is updated. I may have an opportunity soon to try out Lion.
     
  9. QuantumLo0p thread starter macrumors 6502a

    QuantumLo0p

    Joined:
    Apr 28, 2006
    Location:
    U.S.A.
    #9
    So this is what is working for me at the moment.

    On my Linksys WRT54GX4...
    Wireless network mode: G only
    Channel: Auto
    Adaptive channel: Auto
    Security mode: WPA and WPA2
    Encryption: TKIP and AES
    Group key renewal: 3600

    On my Mini (2010 running 10.6.8) in the advanced Airport settings I have "Remember networks this computer has joined" checked and "Disconnect when logging out" unchecked. By the way here it is saying the security is WPA2 Personal.

    I know wpa2 and tkip is a bit better than wpa and aes but I used these settings to get up and running. I will try to tie it down better but for now it is working, thank God. Profiler is also saying it's using wpa2.

    I think a big part of my problem is my router settings were not taking effect until I rebooted it, even though I saved each page of settings. I should've thought of that in the first place. The firmware in my other access point allows rebooting while from a browser, which is super nice.

    At any rate, this is what's working for me at the moment. I hope it helps out someone.
    :)
     
  10. handheldgames macrumors 6502a

    handheldgames

    Joined:
    Apr 4, 2009
    #10
    Give it 30 secs to 2 mins... It's a issue with 10.7. May have been fixed in 10.7.1. Have similar issues wired on macro
     
  11. QuantumLo0p thread starter macrumors 6502a

    QuantumLo0p

    Joined:
    Apr 28, 2006
    Location:
    U.S.A.
    #11
    Went back to wired.

    I don't know if it's the old G router or Apple doesn't/can't play well with it but I still can't maintain a stable connection. Too bad because the signal strength is high, too. It is staying connected for a longer period of time but will eventually disconnect at some point and then I have to reboot the router for my Mini to connect. I have never had to do anything like that before.

    Like I said in a previous post, I am currently using a Linksys GX4 router and not my preferred wap that is running dd-wrt firmware so perhaps I could still get it running. Perhaps I'll try a different router with N.
     
  12. shortcut3d macrumors 65816

    Joined:
    Aug 24, 2011
    #12
    This issue should have been resolved in Lion 10.7.1 update. However, after the update you may experience similar behavior, but give the computer time to reconnect. For example, my iMac returns from sleep instantaneously, so depending on the network specified DHCP IP address expiration time it will either reconnect or renew the connection. On reconnect, if i click Safari immediately after sleep it will beat the network adapter. Giving it 15 secs and clicking refresh in Safari will work. This behavior indicates the original problem has been resolved and is not to be confused. The original issue requires repairing the internet connection to in order to resume normal operation. A PRAM reset and SMC reset after the 10.7.1 update did help the AirportExtreme acquire the network faster.
     
  13. QuantumLo0p thread starter macrumors 6502a

    QuantumLo0p

    Joined:
    Apr 28, 2006
    Location:
    U.S.A.
    #13
    I am still running SL at the moment. I have purchased Lion and even have an install disk but just haven't got around to doing it. Trying to decide if I want to keep using pop mail or bail and go to web mail.

    At any rate, I am running 10.6.8 and it's updated. When it can't reconnect it will not reconnect until the router is restarted. At this point I think I'm going to stop trying until I install Lion.
     

Share This Page