My WEP password won't work on iPhone...

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Mpalmieri1203, Jul 4, 2007.

  1. Mpalmieri1203 macrumors member

    Jul 4, 2007
    My network is running on 128-WEP. My password works on all other devices including my PS3. It keeps saying that my password is incorrect on the iPhone. I cant figure out what the problem is. Any help? Does lower case and capitals matter?
  2. Eraserhead macrumors G4


    Nov 3, 2005
    I suspect case does matter. Though WEP is flawed in that it can be hacked in 60 seconds and it causes problems like this. Can you switch your network to WPA security? All computers running XP/Vista or OS X 10.3 or better support it.
  3. arn macrumors god


    Staff Member

    Apr 9, 2001
  4. freeflydrew macrumors member

    Feb 6, 2004
    Sometimes, putting a $ sign in front of the password will make it connect
  5. ctapia macrumors newbie

    Jul 4, 2007
    Interesting, I'm having similar problems, but slightly different. If I set to hex if tells me "Unable to joing XXX (my wireless) network. If i set it to Wep password, it appears to take it, however the lock remains on the iphone and therefore explains why I cant' get connected via wifi (my wireless network). I've trippled check my wep key and it is correct. I"m lost..:confused:

    Update.. I just added the "$" symbol as freeflydrew suggested and it makes no difference.
  6. ericld macrumors member

    Jul 3, 2007
    Mine did the same thing and I couldn't connect, although it didn't tell me my wep key was wrong. i deleted the wifi by hitting the "forget this" button and re-added.

    All worked fine.

    I do recommend switching the WPA ad simply typing a password.
  7. ctapia macrumors newbie

    Jul 4, 2007
    From what I've tried, if you type the an incorrect password, you won't get any error messages and the only way you know is that the "lock" symbol remains next to the wireless network.
    I have now verified that I can connect to my work wireless, but I can't connect to my home network. The "lock" symbol stays on.
  8. Cadence macrumors member

    Jul 17, 2004
    Los Angeles, CA
  9. CybrMike macrumors member

    Mar 16, 2006
    had to change mine from 128bit to 64bit 10 digit before it would work.

Share This Page