MyWi (4.5.1) Bluetooth tethering not working with MacBook Air?

Discussion in 'Jailbreaks and iOS Hacks' started by Mazda 3s, Feb 10, 2011.

  1. Mazda 3s macrumors 6502

    Mazda 3s

    Joined:
    Oct 29, 2006
    #1
    OK, I have a 13" MacBook Air (2010) and the latest version of MyWi (4.5.1) on my iPhone 4 (4.2.1/greenpois0n jailbreak).

    I was able to complete the initial pair with my iPhone 4 and my MacBook Air, but whenever I then try to initiate the connection from my MacBook Air to my iPhone 4 after that, my laptop says says "The Bluetooth network is unavailable".

    No matter what I do, after the initial pairing I can't connect at all. And of course, Bluetooth tethering is toggled on in MyWi. I even tried going to the Advanced Bluetooth settings in MyWi to change the Bluetooth Bridge DHCP Network to no avail.

    USB and Wi-Fi tethering work just fine.

    Any ideas?
     
  2. awfulcat macrumors newbie

    Joined:
    Feb 10, 2011
    #2
    I have really same problem with you on my JBen iPhone 4 and White MacBook.
    I was thinking if my setting was something wrong.
     
  3. mjenk430 macrumors newbie

    Joined:
    Feb 8, 2011
    #3
    I have also tried to do the same thing with no success. Someone smarter than us please help!! :)
     
  4. Mazda 3s thread starter macrumors 6502

    Mazda 3s

    Joined:
    Oct 29, 2006
    #4
    I was beginning to think I was the only one! :) Hopefully someone can help us out. I don't see a way to contact the author of MyWi though...
     
  5. dmrowley macrumors 6502

    dmrowley

    Joined:
    Aug 4, 2010
    Location:
    Dortches, NC
    #5
    I have the exact same issue. Sent a note to the developer on the website, no response so far.
     
  6. achacon macrumors newbie

    Joined:
    Feb 12, 2011
    #6
    My Wi 4.51 not working with Blue toot teathering

    Some one please help.
    bluetooth teathering stopped working after I upgraded to MYWI 4.5.1
     
  7. mattsb macrumors newbie

    Joined:
    Mar 3, 2008
    #7
    me too - having the same issue.
     
  8. AuroraProject macrumors 65816

    AuroraProject

    Joined:
    Feb 19, 2008
    Location:
    Right there
    #8
    Wirelessly posted (iPhone 4: Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    I was under the impression the Bluetooth tether ability was removed from MyWi. Check out Intelliborns website, click support and look at the faqs for MyWi. It states Bluetooth was removed as wifi is easier.
     
  9. mattsb macrumors newbie

    Joined:
    Mar 3, 2008
    #9
    I saw that too, but that makes no sense to me because it *is* in the app. I think that FAQ is old or something.
     
  10. Mazda 3s thread starter macrumors 6502

    Mazda 3s

    Joined:
    Oct 29, 2006
    #10
    Exactly. If it not functioning at all, why the hell would it be featured so prominently in the UI.
     
  11. Artey macrumors member

    Joined:
    Feb 16, 2011
    #11
    I have exactly the same problem. When I try to connect via Bluetooth, I do get the tether bar come up for half a sec and then it goes away again. Also get the "network not available" error on my mac. The Bluetooth activation button in MyWi is not very responsive either, it sometimes just hangs when I try to turn it off.
    USB cable and Wifi work fine, but as I understand, creating a hotspot uses more battery power than bluetooth.
     
  12. Mazda 3s thread starter macrumors 6502

    Mazda 3s

    Joined:
    Oct 29, 2006
    #12
    Exactly, which is the main reason why I want to use Bluetooth. Bluetooth speeds are fine for tethering... no need to burn up your battery if you don't have to.
     
  13. jwilson25 macrumors regular

    jwilson25

    Joined:
    Aug 25, 2009
    #13
    Same problems here as well. Worked just fine in the older MyWi 4.12, upgrade to 4.5 that included their new OnDemand feature seems to have broken the BT tethering to my laptops, both Mac and Windows. Sent them a note twice, zero response :mad:

    Also, as a side note, I tried this on both 4.1 and 4.2.1, exact same results.
     
  14. xxRONNIExx macrumors regular

    xxRONNIExx

    Joined:
    Jun 7, 2008
    Location:
    California
    #14
    Hmmm, thats really weird, mines is working just fine. I also have a new MBA. Im also using wi-fi hotspot
     
  15. damienvfx macrumors regular

    damienvfx

    Joined:
    Jul 28, 2006
    Location:
    Los Angeles, CA
    #15
    Worked on 4.1, not on 4.2.1

    This was working for me yesterday on pwnage 4.1 jailbreak, but when I updated yesterday to pwange 4.2.1, I can not seem to pair bluetooth anymore.

    Let us know if anyone hears anything from the developer!
     
  16. jdaniel macrumors 65816

    Joined:
    Mar 21, 2009
    Location:
    Ottawa, Canada
    #16
    I have the cracked app... i am assuming that i will use my Mac's bluetooth connection wizard, i pair it up everything seems fine then when i try and connect, it doesnt work
     

    Attached Files:

  17. Artey macrumors member

    Joined:
    Feb 16, 2011
    #17
    Sent them a mail but haven't heard back yet. It's very strange that some people have no problems with this and others do...
     
  18. Mazda 3s thread starter macrumors 6502

    Mazda 3s

    Joined:
    Oct 29, 2006
    #18
    That's the exact same message that I get... but I'm not using the cracked app. $20 is a small price to pay for the functionality provided.
     
  19. jdaniel macrumors 65816

    Joined:
    Mar 21, 2009
    Location:
    Ottawa, Canada
    #19
    Yes but its not working innit... so thats $ down the drain.
     
  20. Mazda 3s thread starter macrumors 6502

    Mazda 3s

    Joined:
    Oct 29, 2006
    #20
    Well, USB tethering works and Wi-Fi tethering works, so it's not like we can't use the program...
     
  21. Dmunjal macrumors 65816

    Joined:
    Jun 20, 2010
    #21
    Yes, 4.51 breaks bluetooth tethering when they included the OnDemand feature. It not only breaks Mac/PC but also breaks iPad with iTether. So, the only way I could get this to work is to pay another $5 for OnDemand.

    No response to email either.
     
  22. jdaniel macrumors 65816

    Joined:
    Mar 21, 2009
    Location:
    Ottawa, Canada
    #22
    Yeah thats not cool esp for people who paid for the service and app.

    What do you mean by "break"
     
  23. awfulcat macrumors newbie

    Joined:
    Feb 10, 2011
    #23
    Do you mean that I can get work BT if I buy the OnDemand addon?

     
  24. Dmunjal macrumors 65816

    Joined:
    Jun 20, 2010
    #24
    When I start iTether, it pairs, handshakes but terminates the session immediately. This exact config worked fine before I upgraded to 4.51.

    Yes, BT from iPad to iPhone has been working fine for me when I used MyWi OnDemand.

    This doesn't help those with Macs or PCs.
     
  25. jdaniel macrumors 65816

    Joined:
    Mar 21, 2009
    Location:
    Ottawa, Canada
    #25
    Hmmm i wonder if theres a older cracked version out there
     

Share This Page