MyWi & USB Tethering Problem

Discussion in 'Jailbreaks and iOS Hacks' started by HDJulie, Oct 12, 2010.

  1. HDJulie macrumors demi-goddess

    Joined:
    Jun 13, 2008
    Location:
    Little Rock, AR
    #1
    Prior to the 4.1 release, my husband & I both jailbroke our phones using the jailbreakme website. We both installed MyWi & it worked great. My husband purchased the app but I decided to wait until after the 4.1 upgrade & jailbreak. So, my phone has 4.1 & his phone is a jailbroken 4.0. In the meantime, I built new pc's for both of us. MyWi still works fine on his. I jailbroke last night using the limera1n method, installed Cydia, installed MyWi & cannot get the app to tether to my pc using USB. It did work as a WiFi hot spot -- my husband was able to see the hotspot on his phone & connect to it -- I just can't get it to work with USB & my pc has no wireless adaptor. Both of us have the same hardware & Windows 7 64-bit pc's. As I said, his phone will tether through USB on his pc but my phone won't tether through USB to my pc. When I downloaded MyWi back when it was on Rock, I had to also download a couple of other packages. I didn't see any indication that this was needed for the Cydia version of MyWi. Is that right? From what I can tell, my pc recognizes the phone as a network adaptor but can't figure out what kind of network it is. Anyone else have that problem?
     
  2. MikePA macrumors 68020

    MikePA

    Joined:
    Aug 17, 2008
  3. HDJulie thread starter macrumors demi-goddess

    Joined:
    Jun 13, 2008
    Location:
    Little Rock, AR
  4. jlussow macrumors newbie

    Joined:
    Oct 12, 2010
    #4
    Same here. Looks like MyWi USB is not compatible with 4.1

    WiFi tethering works fine, though.
     
  5. himni macrumors regular

    Joined:
    Sep 24, 2009
    #5

    I am using MyWi usb tether right now to post this so I know it works.

    First do you have the USB tether set to on in MyWi?

    second under advanced USB menu in MyWi do you have it bridged to 3G and not WiFi?

    If it still doesn't work I would try restart your iPhone.
     
  6. HDJulie thread starter macrumors demi-goddess

    Joined:
    Jun 13, 2008
    Location:
    Little Rock, AR
    #6
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    Yep, yep, & did that :-(. Thanks for the suggestions & since it works for you (I assume you are on the new jailbreak) then it must be a driver problem
     
  7. himni macrumors regular

    Joined:
    Sep 24, 2009
    #7
    Yeah I used limera1n and did it Sunday.
     
  8. PetitBourgeois macrumors member

    Joined:
    Jun 19, 2010
    #8
    I've done all that and USB tethering isn't working on my MacBook Pro (mid-2010). Not that it's a big problem, though - I'm just using wifi tethering instead.
     
  9. Cinemagic macrumors 6502

    Joined:
    Sep 26, 2007
    #9
    Was the limera1n version you used the RC or beta? If it was the beta, you might want to try to restore then re-jailbreak with the latest limera1n version. See if that helps the problem. You can also first try to reset network settings.
     
  10. HDJulie thread starter macrumors demi-goddess

    Joined:
    Jun 13, 2008
    Location:
    Little Rock, AR
    #10
    I'm the one with the problem & I jailbroke yesterday evening. I'm not sure what version of Limera1n was out at that time. How do you reset network settings on the phone?
     
  11. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #11
    Settings/general/reset/reset network

     
  12. HDJulie thread starter macrumors demi-goddess

    Joined:
    Jun 13, 2008
    Location:
    Little Rock, AR
    #12
    Ok, reset the Network settings & still no luck. Thanks, though.
     
  13. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #13
    Hope they put an update for it soon. USB tethering while charging the phone is great.
     
  14. HDJulie thread starter macrumors demi-goddess

    Joined:
    Jun 13, 2008
    Location:
    Little Rock, AR
    #14
    For me, USB tethering is the only option for my PC -- it has no wireless. I use the tethering as an alternative to the crappy satellite internet that we have. But, I also like the option of being able to have wireless tethering available which is why I want to stick with MyWi.
     
  15. Flyinb macrumors member

    Joined:
    Jan 22, 2010
    #15
    I have JB iPhone 4, Limera1n beta 4 and MyWi works fine via wifi or usb on both my Mac and PC. Sorry your having problems it sounds like its your computer.
     
  16. jlussow macrumors newbie

    Joined:
    Oct 12, 2010
    #16
    It is weird that it works for you and hundreds if not thousands are having issues. I am thinking about re-jailbreaking with Greenpois0n to see if things go better. No luck here at all. Cydia doesn't show available updates, either. I just was going to reinstall MyWi and a new version was available. I installed it but still no love.
     
  17. Resevdog macrumors regular

    Joined:
    Jul 5, 2007
    #17
    I'm currently usb tethered to my macbook with mywi and an i4 running 4.1 and a greenpo1son jb. It works bridged to 3g and wifi both. I suspect you are right re: drivers.

    I know when I jb'd last night on my bootcamp windows 7 partition, the drivers were a bit screwy until I updated iTunes.

    UPDATE: Sure enough, when I just started Cydia, there is an update to Mywi today which includes a "Fix for 4.1 USB users".
     
  18. airtron macrumors newbie

    Joined:
    Jul 5, 2010
    #18
    I updated last night to 4.1 via greenpois0n and am now unable to USB tether with MyWi as well.
     
  19. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
  20. cougar11 macrumors member

    Joined:
    Jul 13, 2010
    #20
    CORRECT...

    Update 5 : Version 4.8.1 released !
    v4.8.1
    Fix for 4.1 USB users
    Fix for when WiFi is powered off prior to turning on MyWi
    Improved UI Switch on/off response
     
  21. airtron macrumors newbie

    Joined:
    Jul 5, 2010
    #21
    I do have the newest version and have reinstalled it without having any success.
     
  22. jplusc macrumors 6502a

    Joined:
    Jul 5, 2010
    #22
    mine stopped working after the update as well. USB tethering was working fine before it. Now every PC I try it on get stuck acquiring the network address. Wifi tethering works.
     
  23. DaffyDuck macrumors 6502

    Joined:
    Jun 18, 2007
    #23
    Same problem here on Windows 7 64. I email support with no response yet.
     
  24. HDJulie thread starter macrumors demi-goddess

    Joined:
    Jun 13, 2008
    Location:
    Little Rock, AR
    #24
    Both of the machines I've tried on & can't get to work are Windows 7 64-bit. I have a netbook with Windows 7 32-bit so I'll try USB on it. Then I have an old toughbook with Windows XP Tablet -- I'll try that too.
     
  25. jplusc macrumors 6502a

    Joined:
    Jul 5, 2010
    #25
    i've tried it on XP 32-bit and 7 32-bit with no luck.
     

Share This Page