Need help turning off the sms

Discussion in 'MacBook Pro' started by cake90036, Jul 7, 2011.

  1. cake90036 macrumors regular

    Joined:
    Jan 7, 2008
    #1
    I did the steps that apple provided and i still hear clicking

    In Terminal, which should still be open from the previous step, you can disable the Sudden Motion Sensor by typing sudo pmset -a sms 0 and pressing Return (changing the setting to a zero disables the module).
    Type your administrator password when you are prompted and press Return.
    Type the sudo pmset -g command again to be sure that the setting has been applied.

    When I did the last step... the sms had a 0 next to it.
    For the record I have a 2011 15'' macbook pro and the reason i want it off is that 1 its annoying and 2 I installed an ssd (smokin fast):cool::cool:

    With that being said can anyone help me out.. maybe im doing something wrong.

    Thanks.
     
  2. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #2
    "0" is the setting you want, if you want the Mac SMS disabled. If that's what -g reports, you should be good to go, as far as the Mac's SMS goes.

    I'm going to assume you have both a SSD and HDD installed, otherwise there's nothing that can click. If you still have a HDD, it could have built-in SMS (it's called different things, depending on the make).

    Even with SMS enabled, you should never hear a head unload click due to motion detection unless you physically move the Mac - and move it briskly (though, there have been reports of very loud sounds triggering it - like live (loud) music).

    Some drives have a noticeable click as part of their power management.
     
  3. cake90036 thread starter macrumors regular

    Joined:
    Jan 7, 2008
    #3
    Thanks for the fast response!
    I only have an ssd no hdd.
    This is the profile that comes up after putting in the last step
    Active Profiles:
    Battery Power -1*
    AC Power -1
    Currently in use:
    halfdim 1
    sms 0
    hibernatefile /var/vm/sleepimage
    gpuswitch 2
    disksleep 10
    sleep 10
    hibernatemode 3
    ttyskeepawake 1
    displaysleep 2
    acwake 0
    lidwake 1

    The sound comes around anytime the computer moves, basically when its not on a table top which it isnt most of the time, that is why I am trying to turn it off asap.
     
  4. cake90036 thread starter macrumors regular

    Joined:
    Jan 7, 2008
  5. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #5
    The only other things I can think of is some part of the optical drive moving, or, maybe, loose fan bearing, if it's an older MB (I believe all Unibody models have magnetic bearings, so I don't think they'd be able to make any sound).

    Another thought (seems kinda basic, in hindsight): move the MB when it's already sleeping or, better yet, off. This would eliminate any question about SMS being responsible for the sound.

    The SMS sensor is solid-state, so there's nothing that can make noise when moved either.
     
  6. cake90036 thread starter macrumors regular

    Joined:
    Jan 7, 2008
    #6
    Nope I tried that. Isnt the sms a sensor that is separate from the hard drive so even tho i have an ssd it would still work if tilted. Has anyone one on this message board turned off the sms in a 2011 mbp. It is too sensitive and it is really annoying. IT MUST BE TERMINATEDDDD:cool: <--- terminator lol
     

Share This Page