NetaTalk for iPhone - Mac not seeing iPhone in Finder

Discussion in 'Jailbreaks and iOS Hacks' started by domerdel, Aug 28, 2008.

  1. domerdel macrumors newbie

    Joined:
    Aug 15, 2007
    #1
    I've activated AppleTalk through Ethernet > Advanced, it's still not finding my iPhone. Also note, there is no NetaTalk app icon. Is there a setting i'm missing?
     
  2. ThunderSkunk macrumors 68020

    ThunderSkunk

    Joined:
    Dec 31, 2007
    Location:
    Colorado & Ontario
    #2
    Same here. Turned everything on on the iMac, even disabled all encryption & whatnot, but I gets no iPhone in finder. :(

    Not sure what to make of it.
     
  3. edtorious macrumors 65816

    edtorious

    Joined:
    Aug 14, 2007
    Location:
    San Diego, California
    #3
    it should say localhost under shared drive. :confused: click on it and connect and login as

    login: mobile
    pass: alpine
     
  4. andr nimm macrumors newbie

    Joined:
    Aug 29, 2008
    #4
    edtorious, is that Leopard-only?

    Sorry for this question - shared disks do not show up automatically in the Tiger's sidebar, right? I've seen screenshots of that on Leopard, does it deal with shared disks differently?

    All the how-to Netatalk for Iphone screenshots, by Saurik, were in Leopard.
     
  5. ignus graius macrumors regular

    Joined:
    Dec 4, 2005
    #5
    You're correct. I'm on Tiger and to use this app I just manually entered my IP address. Just go to Finder, click on Go>Connect to Server then enter:

    afp://192.168.1.x (or whatever your iPhone's IP is)

    It might also work if you just browsed your Network, but I removed it from my sidebar so I'm not sure.
     
  6. The General macrumors 601

    Joined:
    Jul 7, 2006
    #6
    That makes NO sense. Why does it ask for mobile and then the root password?

    WTF.
     
  7. andr nimm macrumors newbie

    Joined:
    Aug 29, 2008
    #7
    yo ignus
    that is great! totally worked. thank you for your response.

    General: I believe the name "mobile" and the password above are arbitrary and written into saurik's adaptation of netatalk for the iPhone. When you install netatalk, it sets up your phone so it can be accessed with that name and that password by any other computer on that AppleTalk network. (right guys?)

    now I'm going for broke with my stupid questions. is there a way to connect via AppleTalk protocol on the USB connection?

    and is there a way to change the password?
     
  8. karlakracht macrumors newbie

    Joined:
    Sep 14, 2006
    #8
    strange.... i have an ipod touch and with netatalk i could easily connect with the default passwords. after updating to the latest iphone firmware 2.0.2 my ipod keeps on appearing and disapearing in the finder and in itunes.....

    when i try to connect it via finder it seems not to do anything, and comes then up with this error message:

    Connection failed
    The server may not exist or it is not operational at this time. Check the server name or IP address and your network connection and try again.
     
  9. ignus graius macrumors regular

    Joined:
    Dec 4, 2005
    #9
    I think to use AppleTalk you need to connect via WiFi or Ethernet. I haven't used USB before with the phone--are you wanting speedier transfers than are available with WiFi?

    I found the instructions for changing the password in Cydia. Download the MobileTerminal app and launch it (it will be called simply "Terminal"). Obtain root access by executing "su root" and entering the password (default password is "alpine").

    Run "passwd" and then enter your NEW password twice.
    Change the mobile password by running "passwd mobile" and entering that new password twice.

    Not sure if it's a good idea but I used the same password for both mobile and root.
     
  10. andr nimm macrumors newbie

    Joined:
    Aug 29, 2008
    #10
    Ignus, got it. Thanks. So i guess Appletalk is a different communication protocol from the one used by MacFUSE / Disk for Iphone, which works over USB...

    i think i get it. I don't know this stuff very well but i'm trying to get the concepts. all ears if there's more in the crash course. i will be doing those commands in MobileTerminal for password change, that's really cool.
     
  11. equlizer macrumors regular

    Joined:
    Aug 12, 2008
  12. ViViDboarder macrumors 68040

    ViViDboarder

    Joined:
    Jun 25, 2008
    Location:
    USA
    #12
    In his picture Saurik had his phone named Saurik's iPhone or whatever. How do we change it from Localhost? That would get confusing to me.
     
  13. Bear Hunter macrumors 6502a

    Bear Hunter

    Joined:
    Aug 10, 2008
    #13
    Since the update has anyone experience any difficulty accessing files as "root"?

    Not that I need it..I SSH using Transmit...but if I try to access my themes folder it just bounces back.
     
  14. brightshadow360 macrumors member

    Joined:
    Sep 11, 2008
    #14
    there is no "shared drive" it doesn't even show the network in finder even though it's up and running. what needs to be activated?
     
  15. *unprecedented macrumors newbie

    Joined:
    Nov 8, 2008
    #15
    Off

    i registered just to comment on this thread. i was looking for help too. but then i thought of turning my phone completely off and turning it back on and it appeared on my shared list. so maybe some of you should try that.
     
  16. fwinterb macrumors newbie

    Joined:
    Nov 17, 2008
    #16

    Same with me. Unbeliveable but true - solutions can be that simple...
     
  17. jt999 macrumors regular

    Joined:
    Oct 11, 2007
    #17
    Since I upgraded to 2.2 and re-jaiibroke with Quickpwn, I too cannot get the "Shared" folder to appear in the sidebar.

    This had been working perfectly before the upgrade.
    I am using Leopard; 10.5.5.

    Turning off and on did nothing for me.

    Any help would be appreciated.

    Jeff
     
  18. Bear Hunter macrumors 6502a

    Bear Hunter

    Joined:
    Aug 10, 2008
    #18
    I didn't even install it this time around. I SSH using Transmit anyway.
     
  19. redgaz26 macrumors 68020

    redgaz26

    Joined:
    Mar 6, 2007
    Location:
    Glasgow
    #19

    worked for me !!!!! this is excellent:D
     
  20. jt999 macrumors regular

    Joined:
    Oct 11, 2007
    #20
    I finally solved the problem.

    I did a force quit/relaunch of Finder.
    The "Shared" folder reappeared and is now working properly.

    Jeff
     
  21. *unprecedented macrumors newbie

    Joined:
    Nov 8, 2008
    #21
    other question

    how do i access my photos i took with my iPhone through netatalk?
    i have a video up on youtube about my problem. help would be nice.

    just look up "theoriginalcoolness"
    thats my screen name. look me up.
    its the only video i've uploaded.
     
  22. Mikey B macrumors 65816

    Mikey B

    Joined:
    Jan 4, 2008
    Location:
    the island
    #22
    i LOVE NetaTalk. It totally pwns SSH, IMO. If you are used to digging through your iPhone/Touch's filesystem through a secure shell, it may take a minute to get used to NetaTalk. But, it is really much easier and definitely much more of a Mac experience.
     
  23. MacUser100 macrumors newbie

    Joined:
    Dec 4, 2008
    #23
    The Solution ! and reason why its not working w OS 10.5

    All the options listed above are a good backup!

    The reason why iPhone doesn't show up in the finder is because it is connected to Edge or 3G network at the time you connected it to your computer.

    Edge or 3G don't have/create static IP's for your phone.

    The best thing to do is to create a network with your mac and then connect to it in your iPhone (you can also try connecting to any wifi network if available)

    And Voila, your iphone appears under the shared section in your finder. If it still doesn't you can try all the other solutions listed above.

    [how to create network]
    On your Mac go to airport icon on the top-right screen -> choose create a network, name it anything then press OK (don't mind any other stuff). Then on your iPhone goto settings -> WiFi -> (turn it on if it's not) then select the network you created !
    Open the finder on your Mac and there's your iPhone.


    You can actually see it disappear if you discontinue the network and on the iphone invoke the Edge or 3G network by opening a page in iphone safari.
    Of course you have to Eject your iphone drives first then Reconnect iphone.
    Open the finder and it's not there !

    Remember you need to be in WiFi mode!
     
  24. cyranocytoplasm macrumors newbie

    Joined:
    Feb 20, 2008
    #24
    New one for you all

    The bizzarities continue. I was blissfully using Netatalk to backup my App Store applications and other tidbits when my phone was 2.1, no problem. I also used it to prepare my upgrade to 2.2.

    So here's the problem I've encountered. Now that I'm running 2.2, I am unable to connect through Finder as "mobile". I can connect just fine as "root", but attempting to connect as "mobile" just spins Finder's wheels. I know I am using the correct password. Logging in as root won't do me much good, since any files I transfer back will be owned by root, and not of much use that way. I could go chown them all, but what a pain. Has anyone else had this problem?
     
  25. bombtech13 macrumors newbie

    Joined:
    Jan 4, 2009
    Location:
    Oklahoma
    #25
    I also registered just to comment as well, I wasnt it in sidebar on Leopard 10.5.5 with iphone 3g and 2.2. I went to the advanced settings in network preferences and turned AppleTalk on, and Tadaaaa! there it was in my sidebar!
     

Share This Page