Netflix crashes on ATV4, will not run. Tried nearly everything

Discussion in 'Apple TV and Home Theater' started by stanman64, Jun 6, 2017.

  1. stanman64 macrumors 6502a

    stanman64

    Joined:
    Jul 9, 2010
    #1
    Thinking I will be calling Apple customer support soon and/or taking it to an Apple Store.


    The Netflix app will not run on my ATV4. It immediately crashes back to the home screen when you try to start the app. Every once in a while, I will be able to get to the Log In screen, enter my email and password, hit submit, and then it crashes.

    Things I've tried:
    - quit Netflix app
    - restart ATV4
    - uninstall/reinstall Netflix app from App Store
    - reset ATV4
    - completely wiped and reset ATV4
    - called Netflix*
    - ripped my hair out
    - ensured both ATV and Netflix app are most current versions
    - restarted modem & router
    - unplugged/plugged in modem & router
    - tried using ethernet cable to ATV4 instead of wifi, no change
    - Netflix streams fine on all of my other devices on the same network and on the same account (iPhone, TV, Xbox One, MBP)

    *The call with Netflix was interesting. I was forwarded from their support hotline to their "Technology Research" department out of Salt Lake City, where I spent about 45 minutes on the phone with a tech that wanted all sorts of info from me, including a data packet from my modem/router that I unfortunately couldn't provide because my Mac doesn't have an ethernet port. I also sent them a video of the issue which they were perplexed by. Anyway, he told me it is an active issue that they were just starting to see with some ATV4's and were trying to fix. So basically, they had no idea why it was happening and were working on it. Well, two months later, it still isn't working and I don't see an update on the App Store.

    If you're still reading this, thanks for staying around. So at this point I am thinking it must be a hardware issue or some deep-rooted software issue with the particular ATV4 that DirecTV sent me (it's probably a refurbished unit anyway). So I plan on calling Apple support next, and/or visiting an Apple Store seeking a replacement since Netflix is on of the main reasons I wanted an ATV4 in the first place.

    The only other thing I can think of is doing a reset via iTunes using a USB-C cable from my 2016 MBP to my ATV4, but at this point I don't have much faith in that.


    Any other suggestions? And even though I got this ATV4 via DirecTV, I am still eligible for a 1 year warranty for any hardware/software defects from Apple, correct?

    edit: spells
     
  2. Mi1lion macrumors member

    Mi1lion

    Joined:
    Jun 4, 2017
    Location:
    Twin Peaks, CA
    #2
    Find your Serial Number of the ATV and check the coverage (should be 1 year): https://support.apple.com/

    Then maybe make an appointment a Genius Bar and explain to them your problem.
     
  3. drewsof07 macrumors 68000

    drewsof07

    Joined:
    Oct 30, 2006
    Location:
    Ohio
    #3
    I have this same issue on two ATVs purchased at separate times from different stores. I don't think it's a hardware issue. I believe it to be an authentication issue with Netflix. Sometimes lasting weeks at a time. After pulling my hair out much like yourself, I've found that rebooting my modem actually fixes it most of the time. I'm no network engineer, and can't explain why this would be - I have a static IP, but it seems to work.

    Also, this has been happening to me for over a year, so Netflix tech saying "this is a new issue" is BS.
     
  4. Tech198 macrumors G4

    Joined:
    Mar 21, 2011
    Location:
    Australia, Perth
    #4
    Fine here....

    Perhaps Netflix app since it was re-downloaded perhaps it was a newer version, which requires an update of Apple TV ? *shrugs* You didn't restore which would have put the latest tvOS on, so that's the only other thing. 10.2.1
     

Share This Page