Resolved New External HDD Ejects on Sleep, help!

Discussion in 'Mac OS X Lion (10.7)' started by baryon, Aug 26, 2011.

  1. baryon, Aug 26, 2011
    Last edited: Aug 28, 2011

    baryon macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #1
    I just bought a 2 TB Samsung G3 station external USB 2.0 hard drive. The drive is working fine, however when I put my computer to sleep, upon waking it, I am instantly greeted with the red exclamation mark message saying "The drive was not ejected properly". The drive seems to be unmounted at this point, as it does not appear on the desktop. To get it to mount again, I have to unplug it and plug it back in.

    In Energy Saver, I have unchecked "Put Hard Disks to Sleep when Possible", but it doesn't help.

    I'm suspecting that my Samsung external simply powers off completely when I put my Mac to sleep, and even if it does power back on when I wake it, it's in an ejected state for some reason.

    I also have a WD 500 GB MyBook Essential drive, which is USB 2.0 as well, and that does not have this issue at all. When I put my Mac to sleep, the light in the drive goes off and it spins down (I can hear it) and it spins right back up when I open my Mac, and there are no problems with ejecting and it being unmounted at all.

    My Samsung drives also seems to power down when I put my Mac to sleep, however, it seems to power up just fine when I wake my computer, but the computer thinks otherwise.

    Any help would be greatly appreciated!

    PS: I'm running Lion and I have never tested the Samsung on anything else.
     
  2. baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #2
    I'm aware that the Samsung drive powers off when the USB is disconnected. But when I put my MacBook Pro to sleep, the USB is NOT disconnected, in fact, it still supplies power (my iPod charges through USB when the computer is sleeping). The data is indeed disconnected, but my WD goes to stand by at that time and doesn't completely power off (I guess it doesn't eject itself just spins the drive down).

    What could I do to get the Samsung to stay mounted? Is there a way to auto-remount it when I wake from sleep? Can I at least disable the annoying "The disk was not ejected properly" warning? It's not that anything can go wrong since nothing accesses the drive while the computer's sleeping.
     
  3. baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #3
    Just writing to let you know that the problem is still happening. (this is by no means a bump)
     
  4. blackburn macrumors 6502a

    blackburn

    Joined:
    Feb 16, 2010
    Location:
    Where Judas lost it's boots.
    #4
    Man that used to happen to me with every external hdd:mad:. (I tend to use 2,5 usb powered ones, but I have 3,5 one wd that turns off when the computer sleeps).
    It used to happen with flash drives too, but no more. Somewhere along the road it stopped happening..
    My external toshiba hd stays with the led lit when I sleep the macbook, but the hd is powered off (even when on battery).
    I do have a new usb 3.0 one that is giving me issues, it spins up twice on my mac, but works fine under windows. But even the problematic one mounts just fine after waking up the macbook.

    So I'm able to reproduce what you wrote but I no longer can get that error.
    PS: That setting doesn't affect external hdds. The usb-sata bridge or the hdd itself (some wd don't have an bridge, at least separated) gives the hdd the sleep command, maybe yours has a bug, like mine has.
     
  5. brand macrumors 601

    brand

    Joined:
    Oct 3, 2006
    Location:
    127.0.0.1
    #5
    How is it not a bump? According to the MacRUmors FAQ/Rules this would be a bump even if you think it is not a bump.

     
  6. baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #6
    I fixed the issue by disassembling the enclosure, removing the hard drive and placing it in my old Western Digital enclosure. It no longer ejects during sleep and it runs fine! It was a pain to take apart but now it works at least.

    It is a bump, but I was trying to be funny since I was kind of breaking the rules. But I was right to do so, since I eventually got some replies, didn't I? :D
     
  7. krispykrunch macrumors newbie

    Joined:
    Sep 19, 2011
    #7
    Not really resolved is it?

    I understand that you're happy you don't have the problem anymore, but there is a problem with Samsung external HD's that still needs to be resolved. Not everyone can switch drives into a case that does work. I'm glad I don't have any Samsung externals and wouldn't recommend them to anyone. WD, LaCie, and iOmega drives do not have any of these problems. Samsung needs to get a firmware fix out and nail this problem.
     
  8. EggyWeggs macrumors newbie

    Joined:
    Oct 20, 2011
    #8
    I'm experiencing this right now with a SAMSUNG EcoGreen F4 HD204UI 2TB and a Rosewill fanned enclosure over USB 2 on a MacbookPro Early 2011.

    All kinds of issues with sleeping, waking...

    I do have an old WD enclosure. That may be my last resort.
     
  9. baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #9
    Yes, this isn't a real solution, but it really seems to me that the issue is caused by Samsung's controller detecting the computer's sleep state, and this switching the drive completely off (and I mean completely, as in it loses 100% of its power and so disconnects from the computer). My WD drive spins down when my computer sleeps, but doesn't disconnect the USB.

    Since the firmware is probably hard coded into the controller, the only solution is to use a different controller (different case)…

    I may be wrong, there may be a way to hide the sleep state from the drive, or update the firmware, but I can't seem to be able to do that.

    Lesson learnt: Stop buying external drives and buy internal drives with external enclosures. It will be cheaper and you won't have these kinds of surprises.
     
  10. EggyWeggs macrumors newbie

    Joined:
    Oct 20, 2011
    #10
    After I posted last night, I tried a few things out.

    Using the same Rosewill enclosure, I swapped in an older WD 3200JS bare bones drive (320GB, non "green" drive) and got the same results: Upon entering sleep, the drive would go into standby mode but then wake itself backup and never re-enter sleep.

    I then plugged in my old WD WD3200D032 My Book external enclosure drive and voila! Perfect standby mode achieved. I thought, Great! This WD external enclosure plays nice with Lion and proceeded to use this Instructables guide to open the enclosure up so I could swap in my Samsung F4 drive:

    http://www.instructables.com/id/How-to-Open-a-Western-Digital-MyBook-USB-Drive./

    However, after I opened the enclosure and pulled the old WD drive out, I realized the enclosure uses an entirely different power source than the Samsung drive uses, and therefor it was a failed procedure.

    Moving on, I attached two more mini WD external drives I own:

    Western Digital Elements 640GB USB 2.0 (WDBAAR6400) - Successfully entered Standby mode when the MacBook was placed in Sleep

    and

    Western Digital Passport Portable 250GB USB 2.0 (WD2500XMS-00) - An older external drive, it failed to properly go into Standby and exhibited the same behavior as the 2TB Samsung bare drive and 320GB WD bare drive by initially going into Standby mode but then waking itself back up and never going back to sleep.

    Exhausted, I at least boiled it down to the individual controllers in the external drives and not a problem with Lion itself & all external drives as I had previously suspected.

    SO...Last night I ordered one of these:

    OWC Mercury Elite Pro
    http://eshop.macsales.com/item/Other World Computing/MEFW934FWU2K/

    This enclosure is "OS X Lion Compatible" as declared by the manufacturer, and it's obviously geared towards Mac users. It should (fingers crossed) properly enter the drives into Standby mode when the MacBook is set to Sleep. I should have the enclosure in a few days and will report back.
     
  11. EggyWeggs macrumors newbie

    Joined:
    Oct 20, 2011
    #11
    Just an update:

    The Mercury Elite AL-Pro works brilliantly with the 2TB SAMSUNG EcoGreen F4 HD204UI in Lion 10.7.2. The drive/enclosure successfully goes to sleep when the computer is put to sleep.

    Also, the Mercury Elite for anyone wondering oozes high quality. The Samsung drive was already very quiet to begin with. Inside the enclosure it's nearly inaudible. Highly recommended:

    (Enclosure only, no drive):
    http://eshop.macsales.com/item/Other World Computing/MEFW934FWU2K/
     
  12. brangates macrumors newbie

    Joined:
    Jul 13, 2012
    #12
    Same kind of issue with a seagate drive

    I have two seagate 1TB externals, one is a small one that is powered with usb 2.0 and the other one is a bigger one with its own power source . These are both on a new mac mini running lion. The small one i have no problem with. Every time the mini goes to sleep with bigger drive still mounted I will wake up the mini and get that annoying warning saying i didn't eject the drive properly. It is also my Time Machine backup drive, so the way i have been dealing with it is just ejecting the drive every night, or when i go to work. Does anyone have any other suggestions? The drive always remounts when i wake the computer up, but not if i eject the drive before bed. Then i have to restart or unplug the drive and plug it back in. I do not know if i might damage the drive or lose data if i just leave it alone and deal with the warning every morning. The warning says it could damage the drive, I just do not know.
     
  13. ZipZap macrumors 601

    Joined:
    Dec 14, 2007
    #13
    My 2 drives power down on sleep but when I wake, they spin up and the mac has the red warning message.
     
  14. RonPriest macrumors newbie

    Joined:
    Oct 13, 2010
    #14
    Yes, I have that same enclosure and have no problems with my computer goes to sleep but I can't say the same thing about OWC's 2 drive enclosure. I have two 3 TB Hitachi drives in this unit and when my computer wakes up from sleep the drive disconnects and I get the dreaded warning that the drive wasn't ejected properly. This strange thing is, this doesn't happen if Im connected via Firewire, but only when connected via eSATA. So buyer beware, if you get this drive either don't let your computer sleep, or use it in Firewire mode.

    http://eshop.macsales.com/item/Other World Computing/MEPQ946QL2/
     
  15. Panico macrumors newbie

    Joined:
    Apr 12, 2009
    #15
    rekindle

    My MyBook 2T has the same issue with FW800, since I upgraded from Snow to Mavericks. Behind the MyBook is a FW800 G-Tech 1T with the boot partition, and behind that a FW400 DVD-writer.

    Any thoughts? First I blamed the configuration with my mini late 2009, and/or the burner, but now that I find the issue mentioned here and elsewhere, I keep looking for a solution that does not require a screw driver ;-)
     

Share This Page